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1  Lambda Predict Training Guide

1.1  About this Training Guide
This training guide is intended to provide you with many examples to demonstrate the use of Lambda
Predict. It begins with step-by-step examples and then proceeds into more advanced examples and
questions. At any time during the training, please feel free to ask the instructor(s) any questions you
might have.

Some of the examples in this training guide require you to access files that have been shipped with the
Lambda Predict application. These files are located in the Examples folder in your application
directory (e.g. C:\Program Files\ReliaSoft\Prediction\Examples).

1.2  Lambda Predict Documentation
Like all of ReliaSoft's standard software products, Lambda Predict is shipped
with detailed printed documentation on the product (Lambda Predict User's
Guide). This training guide is intended to be a supplement to that reference.
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1.3  Contacting ReliaSoft
ReliaSoft can be reached at:

ReliaSoft Corporation
ReliaSoft Plaza

115 South Sherwood Village Drive
Tucson, AZ 85710  USA
Phone: +1.520.886.0366

Fax: +1.520.886.0399
E-mail: Support@ReliaSoft.com

For up-to-date product information, visit our Web site at: 
http://Predict.ReliaSoft.com 



2  Features Summary

The examples in this training guide have been designed to introduce you to the features available in
Lambda Predict. This section presents a brief summary of these features. If you are already familiar
with Lambda Predict’s features, you can proceed to the next chapter, First Steps.

2.1  Lambda Predict Supports All Major Reliability Prediction Standards
Lambda Predict can be used to perform standards based reliability prediction analyses according to
any of the major published standards. This includes:

• MIL-HDBK-217: Reliability Prediction of Electronic Equipment (MIL-HDBK-217F), issued by
the U.S. Department of Defense in December, 1991. Lambda Predict supports both the Part
Stress and Parts Count calculation methods for electronic components in commercial and
military applications.

• Bellcore/Telcordia: Reliability Prediction Procedure for Electronic Equipment (TR-332 Issue
6), issued by Bell Communications Research in 1995. This standard provides reliability
prediction models for electronic components in commercial applications.

• NSWC (Mechanical): The Handbook of Reliability Prediction Procedures for Mechanical
Equipment (NSWC-98/LE1), originally released in the 1980s by the Naval Surface Warfare
Center. This standard provides reliability prediction models for mechanical components, such as
seals, springs, pumps, valves, brakes and more.

• RDF 2000: Based on methods developed by the French Telecommunication industry, this
standard provides reliability prediction models for a range of components using cycling profiles
and applicable phases as a basis for failure rate calculations.

• China 299B: The Chinese military standard GJB/z 299B provides calculation methods for
electronic components.
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The standards that will be available on your computer depend on the license that you have purchased. If you
wish to use a standard that is not enabled for your copy of the software, please contact ReliaSoft for
information about upgrading your license.

2.1.1  Derating Standards
The following derating standards have been added to Lambda Predict:

• NAVSEA-TE000-AB-GTP-010: This standard is based on the Parts Derating Requirements and
Application Manual for Navy Electronic Equipment.

• MIL-STD-975M: Electronics parts, materials and processes for space and launch vehicles.

• MIL-STD-1547: This standard provides part selection for electrical, electronic and electromechanical
parts used in the design and construction of space flight hardware in space missions as well as essential
ground support equipment (GSE).

• Naval Air System Command AS-4613: Application and derating requirements for electronic
components, General spec. F.

For the MIL-217, Bellcore or RDF 2000 Lambda Predict standards, you can choose a derating standard to
use for the components of the system. Once a standard has been chosen, each component indicates if its
current stress levels are within the derating standard or not. Graphical displays of the situation are available
for ease in identifying problem areas. Parametric displays are also available to show the temperature vs.
stress situation of the component.

You can also define your own derating requirements, giving you the ability to combine any of the published
standards with your own. A derating File Manager is included in Lambda Predict to help manage the
different derating files.

2.2  Work with Multiple Projects and Systems Simultaneously
The first step to perform a standards based reliability prediction analysis in Lambda Predict is to create a
project file (*.LPP) and a system. Systems can be created according to any of the reliability prediction
standards that are enabled for your copy of the software (i.e. MIL-217, Bellcore, NSWC, RDF 2000 and/or
China 299B). The options available for defining the system configuration and component properties, as well
as the analysis results, will vary depending on the standard that you are using.

Each project can contain multiple systems (with the failure rate and other metrics calculated at the project
level based on the calculations for the systems it contains). You can work with multiple projects
simultaneously, which provides an easy way to copy information among projects.

2.3  Calculated Results
Lambda Predict provides several ways to obtain calculated results for your analyses. Failure Rates, MTBFs,
Pi Factors and other metrics can be displayed in the Project and System panels, in the Pi/Rate window and in
the Results Viewer. Results are available for individual components, higher level assemblies, systems and
even projects. 

2.4  Graphical Plots/Charts
The Plot Viewer provides a complete array of plots/charts to demonstrate your analysis graphically. This
includes plots for Failure Rate, MTBF, Contribution and Unavailability (independently and versus
Temperature, Environment, Stress, Voltage, etc.).

You can customize your plots using the Plot Setup. The Plot Setup gives you full control over the default
colors and fonts used by the application for the Plot Viewer.
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2.5  Print-Ready Reports
Lambda Predict provides a variety of print-ready reports for your analysis, including Failure Rate, Parts List,
Pi Factors, etc. You can customize the appearance of all pre-defined reports and also build and manage your
own custom report templates. 

Lambda Predict’s Reports window also gives you the flexibility to create your own graphical reports (plots)
and include them in print-ready report output.

2.6  Flexible Data Management (Import and Export)
Lambda Predict's flexible data management options include the ability to import and export data from
Microsoft Jet databases (such as MS Access, *.mdb), Excel spreadsheets and delimited text files.

2.7  Links and Transfers
Lambda Predict allows you to create linked blocks that represent the relevant reliability prediction
characteristics of another block or component. You can then view a summary of all the links that have been
established within the current project within the Project Link View window. You can also transfer blocks
from one system type to another. 

2.8  Libraries
Lambda Predict's libraries provide pre-configured components that you can copy and paste or import into
your project. You can create your own libraries or take advantage of the extensive collection of parts
libraries included with the application. Additional libraries are also available for purchase. 

2.9  Allocations
The Allocations utility provides five allocation models that can be used to logically apportion the product
design reliability into lower level design criteria such that the cumulative reliability still meets the
requirements. The available models are: Equal Allocation, AGREE Allocation, Feasibility of Objective
Allocation, ARINC Apportionment Technique and Repairable Systems Allocation. 

2.10  Customize the Application
Lambda Predict’s User Setup allows you to configure the work environment and analysis settings to meet
your particular needs. This includes the fields displayed in the Project and System panels, the displayed
math precision, the convention used to name items, the menu options, etc. 





3  First Steps

3.1  Starting Lambda Predict
Lambda Predict has been designed to work with Windows 98, Me, 2000, NT and XP. The Lambda
Predict internal screens and commands are identical regardless of which operating system you are
using, and this training guide is equally applicable. To start Lambda Predict, from Start select
Programs, ReliaSoft Office and then Lambda Predict.
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3.2  Multiple Document Interface and Data Folio
Lambda Predict's Multiple Document Interface (MDI) is the workspace within which you can create, edit
and manage your standards based reliability prediction analyses. The MDI remains open until you close the
program and closing the MDI terminates the program. The next figure displays the Lambda Predict MDI and
its default components.

The Project panel, which appears in the top left corner by default, displays the projects that are currently
open and the systems that have been defined for each project. The tabs at the bottom of the Project panel
allow you to view the systems for each open project.

The System panel, which appears in the bottom left corner by default, displays the configuration
(subsystems, components, etc.) for the system that is currently selected in the Project panel. The tabs at the
bottom of the System panel allow you to view configurations for each type of analysis. The Library panel is
not displayed by default but can be added to the interface if desired. It works like the System panel and
displays the system configuration for the library that is currently selected in the Project panel.

The Data panel, which appears on the right by default, displays the properties of the project, system, block or
component that is currently selected in the Project, System or Library panel. The two tabs at the bottom of
this panel allow you to view and/or edit the information in two complementary views, the Dialog view and
the Grid view. 

3.3  Getting Help in the Lambda Predict Environment
ReliaSoft's Lambda Predict includes complete on-line help documentation. This help can be obtained at any
time by pressing F1 or by selecting Contents from the Help menu.
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3.4  First Steps Example
This example has been designed to familiarize you with Lambda Predict’s interface and tools. It uses a
sample data set for demonstration purposes that is not intended to be realistic. You will:

• Create a new project for a MIL-217 system.

• Build a hierarchical system configuration using the blocks and components that are available for the
MIL-217 standard.

• Obtain the calculated results for your analysis.

• Plot the data for the system.

• Save the project.

3.4.1  Create a New Project
The first step in performing a standards based reliability prediction analysis in Lambda Predict is to create a
project file (*.LPP) and a system. Systems can be created according to any of the reliability prediction
standards that are enabled for your copy of the software (i.e. MIL-217, Bellcore, NSWC-98, RDF 2000 and/
or China 299B). Although the basic procedures are the same, the options available for defining the system
configuration and component properties, as well as the analysis results, will vary depending on the standard
that you are using. If you do not have a standard mentioned in this guide, you may be able to substitute
another standard for a similar result.

• To create a project, click Create a New Project in the What do you want to do? window that may
appear at startup, select New Project from the File menu or click the New Project icon in the MDI
toolbar.

• In the Create New Project window, click Select standard and then select MIL-HDBK-217F, as shown
next.
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• Click Finish to display the new project and system. The MDI will look like the one shown next.

The Project panel will appear in the top left corner of the MDI by default. The Project panel displays the
projects that are currently open and the systems that have been defined for each project. In this case, there is
one project (Project1 tab) and one MIL-217 system.

The System panel will appear in the bottom left corner of the MDI by default. This panel displays the
configuration for the system that is currently selected in the Project panel. 

The Data panel will appear on the right side of the MDI by default. This panel displays the properties of the
project, system, block or component that is currently selected in the Project or System panels. The two tabs
in the Data panel allow you to view and/or edit the information in two complementary views: the Dialog
view and the Grid view.

3.4.2  Build the System Configuration
You can build the hierarchical system configuration using the blocks and components that are available for
the current standard. In general, blocks are used to represent groups of items within a multilevel system
configuration (e.g. subsystems, subassemblies, etc.). They can have components and other blocks below
them in the hierarchy and they inherit calculated values (e.g. Failure Rate, MTBF) from these lower level
items. Components (e.g. Fuse, Switch, Resistor, Pump) have pre-defined properties based on the selected
standard and must be placed at the lowest level within a branch of the hierarchy.

For this example, you will be defining the following configuration (a subassembly that consists of three
capacitors):

Block 10

Capacitor 10.1

Capacitor 10.2

Capacitor 10.3
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• To add a block to the system, right-click the system in the System panel and select Add then Add Block
from the shortcut menu. The block will be added to the system, as shown next.

• Now add components to the block. To do this, right-click the block and select Add then Add
Component from the shortcut menu. The Select Category window will appear, as shown next.

• Select Capacitor from the list and either double-click it or click OK to add it to the block.

• Add another capacitor by copying the first one you added and pasting it to the block. To do this, right-
click the capacitor and select Copy from the shortcut menu. Next, right-click the block and select Paste
from the shortcut menu. The pasted capacitor will appear on the level beneath the block, along with the
original capacitor.

• Add a third capacitor using either of the methods given above.
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• Once you have finished adding the three components, the MDI will look like the one shown next. Note
that the name of your final capacitor may vary, depending on the method you used to add it.

You can use the Dialog view of the Data panel on the right side of the MDI to view and modify the
properties of the system, block or component that is currently selected (e.g. Part Number, Description,
MTTR, etc.).

• Select the system in the System panel (bottom left) to display the properties in the Data panel (right). 

• From the Dialog view, notice that some of the fields have already been filled out for the system by
default. You can change any of these properties or use the default. For this example, we will use the
default. Enter the following additional information into the corresponding field for the system.

Description: ABC Computer System Model ABC/XT
Pentium-based Microcomputer
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• The Data panel (in the Dialog view) for the system will look like the one shown next.

• Next, select the block that you added to the system. From the General tab of the Data panel (in the
Dialog view), enter the following information:

• The Data panel for the block (now named “10”) will look like the one shown next.

Part Number: PS1
Name: 10
Analyst: A. Designer
Description: Power Supply 110/240 V AC Supply, 5V/12V 

DC Output
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• Click the Application tab in the Data panel. The Application tab contains some of the MIL-217
parameters required for the failure rate calculation. Notice that the application parameters are already
set for the block. You can change any of these parameters or use the defaults. For this example, we will
use the defaults.

• Now select the first capacitor in the System panel and enter the following information into the General
tab of the Data panel.

• The Data panel for the first capacitor (10.1) will look like the one shown next.

• You can view the physical parameters for the capacitor by clicking the Physical tab in the Data panel.
The Physical tab contains additional MIL-217 parameters required for the failure rate calculation. You
can also view the application parameters by clicking the Application tab. For this example, we will use
the default parameters.

Part Number: CK 33PF
Name: 10.1
Circuit Ref: C1
Description: CAPACITOR, FIXED, CK, 33PF
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• Now enter the following information into the General tabs for the second and third capacitors.

• You can take the time to view the default physical and application parameters for these two capacitors,
if desired. 

• Next, select Capacitor 10.3 in the System panel and switch to the Grid view by clicking the Grid tab at
the bottom of the Data panel, as shown next.

• Use the scroll bar at the bottom of the panel to view all the information in the Grid. Once you have
finished, return to the Dialog view in the Data panel.

3.4.3  Obtain the Calculated Results
Lambda Predict uses the block properties together with the calculations for the blocks and components in the
next lower level to determine the failure rate, MTBF and other results for the subassembly that each block
represents and for each system. These are displayed in the Project panel. Results for systems and projects are
displayed in the System panel. Calculated results can also be displayed in the Pi/Rate window and in the
Results Viewer.

• Select Capacitor 10.1 in the system configuration and select Analyze from the Tools menu or click the
Analyze icon.

Capacitor 2
Part Number: CQ-10NF
Name: 10.2
Circuit Ref: C6-10
Description: CAPACITOR, FIXED, POLYESTER, 10nF
Notes: These capacitors are rated at 24 volts and being used at 

20. If this causes a problem upgrade to 40V devices.

Capacitor 3
Part Number: 0805 COG
Name: 10.3
Circuit Ref: C3-C5
Description: CAPACITOR, FIXED, CERAMIC CHIP, 220 pF
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• The Pi/Rate window will appear, as shown next.1

The results that appear in this window are for the currently selected component. You can click another item
in the Project or System panel to display the results for that item. Note that the results will vary depending
on the type of item that is currently selected (e.g. only Failure Rate is displayed when the block is selected,
whereas selecting one of the capacitors gives the results shown above).

• When you are finished experimenting with the Pi/Rate window, click the Close (x) button in the upper
right corner of the window to close it.

• Select Block 10 in the system configuration and open the Results Viewer by selecting Results from the
Tools menu. The Results Viewer will appear, as shown next.

The first panel displays the Failure Rate, MTBF, Unavailability and Contribution values that have been
calculated for the selected block. The second panel displays the Failure Rate values that have been

1. If the default properties of the component have been changed on your computer, your results will vary.
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calculated for the selected block and for the components in the next level of the system configuration
hierarchy. The third panel displays the Pi Factors for the components in the next level. As with the Pi/Rate
window, you can click another item in the Project or System panel to display the results for that item.

• Click the Close button (x) in the upper right corner of the window to close the Results Viewer.

3.4.4  Plot the System Data
The next step is to plot the system data.

• Select the system in the System panel and then select Plots from the Tools menu. The Plot Viewer will
appear.

• By default, the last plot type that was selected will automatically be plotted when you open the Plot
Viewer. For this example, select Failure Rate vs Temperature from the Plot Type drop-down menu
that appears in the Control Panel on the right side of the Plot Viewer. If the Auto Refresh option is not
selected, you will have to click the Refresh Plot icon to refresh the plot with the new plot type.2

The Failure Rate vs. Temperature plot will appear, as shown next.

You can generate other plots by selecting different types from the Plot Type drop-down menu. Remember
that if the Auto Refresh option is not selected, then you will have to click the Refresh Plot icon to refresh
the plot with the new plot type.

The data in the plot is based on the system that is currently selected in the System panel. Just like the Pi/Rate
window and the Results Viewer, the Plot Viewer will remain open while you select a different project,
system or block.

2. If the range for the plot has not been defined in the Range input boxes, enter 0 for the minimum temperature (Min), 
100 for the maximum temperature (Max) and 20 for the number of intervals (Steps).
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• Close the Plot Viewer by selecting Close from the File menu or by clicking the Close (x) button in the
upper right corner of the window.

3.4.5  Save the Project
• If you are using a fully functional copy of the software (i.e. not a demonstration version), save the

analysis. To do this, select Save Project from the File menu or click the Save icon.

The Save As window will appear. Type First Steps as the file name and accept the default file type,
Lambda Predict Project file (*.LPP). By default, Lambda Predict will save the file to your My
Documents folder; you can select another location if you prefer.3

• Click Save to save the file.

• After saving the project, close the project by selecting Close Project from the File menu. You will now
be looking at the MDI with no projects open.

3. For the examples in this training guide, we have created a Files folder in the application directory.



4  Step-by-Step Examples

4.1  List of Examples
This chapter provides the following step-by-step examples, designed to introduce you to the features
of the Lambda Predict software:

• Example 1 - Working with Projects and Systems - page 19

• Example 2 - Working with Component Properties - page 28

• Example 3 - Working with Different Types of Systems in the Same Project - page 39

• Example 4 - Performing a What-If Analysis - page 44

• Example 5 - Using Reporting and Printing Capabilities - page 47

• Example 6 - Working with Libraries - page 52

• Example 7 - Importing and Exporting Data - page 59

• Example 8 - Using the Allocations Utility - page 65

• Example 9 - Derating - page 72

4.2  Example 1 - Working with Projects and Systems
This example will demonstrate more advanced features of working with projects and systems in
Lambda Predict. It uses a sample data set for demonstration purposes that is not intended to be
realistic. You will:

• Create a new project.

• Build the system configuration using a variety of data entry techniques.
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• Transfer blocks from one type of system to another type of system.

• Link blocks between two systems in a project.

• Review the links in the Project Link View window.

• Save the project.

4.2.1  Create a New Project
• Create a new project by selecting New Project from the File menu or by clicking the New Project icon

on the MDI toolbar.

• In the Create New Project window, click Select standard and then select both MIL-HDBK-217F and
Bellcore (SR-332), as shown next. This will automatically create two systems in your new project.

• Click Finish to display the new project and systems. The MDI will look like the one shown next.
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4.2.2  Build the System Configuration
• In the Project panel, select the MIL-217 system.

• In the System panel, add a block to the system by right-clicking the system and selecting Add then Add
Block from the shortcut menu or by clicking the system and selecting Add Block from the System
menu.

• Add the following three components to the block:

Diode, High Frequency

Fuse

External

• You can do this by right-clicking the block and selecting Add then Add Component from the shortcut
menu, then selecting the component type from the Add Component window that appears. With the
External component selected, the MDI will look like the one shown next.

External components are supplied so that the user can enter components with properties that are determined
from a source external to the reliability prediction standard. These components have no failure rate until the
user supplies one. 
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• With the External component selected in the System panel, click the Physical tab in the Data panel.
Enter an External Base Failure Rate of 2.037, as shown next.

Lambda Predict also offers special block types for each reliability prediction standard. Although the General
properties that can be defined for these special block types are the same as standard blocks, the Physical,
Application and/or Mission Phase properties (depending on the standard being used) fit the unique
requirements for the specific type of construction. In this example, you will use a Plated Through block,
which allows you to model printed circuit boards (PCBs) and printed wiring assemblies (PWAs) that utilize
plated through holes (PTH) technology.

• Add a Plated Through block to the block in the System panel by right-clicking the block and selecting
Add then Plated Through from the shortcut menu.

• Add a Capacitor and a Resistor to the Plated Through block. Note that you can add components below
special block types, but you cannot add other blocks. With the Plated Through block selected in the
System panel and the General tab active in the Data panel, the MDI will look like the one shown next.
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Lambda Predict’s Grid view offers the capability to edit multiple system components quickly and easily.
Note that you can navigate in the Grid view using the mouse or using the Tab, Enter and arrow keys.

• In the System panel, select the block (1). In the Data panel, switch to the Grid view. Note that the Grid
view displays the selected block and any blocks and components in the level directly below it, but does
not display subsequent levels (i.e. you can view and edit the Plated Through block in this configuration,
but you cannot view or edit the components below it).

• In the System panel, select the Plated Through block. In the Data panel, click the Name cell for the
Plated Through block. You can now enter a name for the block. Name the block and its components as
follows:

• In the Category column, change the resistor to a switch by selecting Switch from the drop-down menu
that appears when you click in the cell. Note that the description does not change when you change the
component’s category, so if you had entered a custom description, it would not be lost.

• Change the description of the switch to “Switch.” The MDI will look like the one shown next.

Other properties can be edited in a similar manner via the Grid view.

4.2.3  Copy and Paste a Subassembly
Often, subassemblies may be used multiple times in a system configuration. Lambda Predict allows you to
copy and paste components or blocks (including special block types) to save time and effort when defining
system configurations. Pasted items are independent from the original items and changes made to one will
not affect the other. One simple way to copy/paste items is with the drag-and-drop feature.

• Change the Data panel back to Dialog view.

Item Name

Plated Through Block PTB1

Capacitor PTB1.1

Resistor PTB1.2
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• Add another block to the system.

• Click the Plated Through block and drag it to the new block that you just created. The MDI will look
like the one shown next.

Note that the subcomponents of the block have been copied along with the block and that Lambda Predict
has automatically named the copied items.1

You cannot drag and drop items between systems. To do this, you can use copy/paste instead, as described
next.

• Add a new MIL-217 system to the project by clicking inside the Project panel and selecting Add MIL-
217 System from the Project menu.

• Return the focus to the first MIL-217 system (MIL217:1) by selecting it in the Project panel. When you
select a different system in the Project panel, the System panel will be refreshed to display the
configuration for that system.

• In the System panel, select the original Plated Through block and select Copy from the shortcut menu
or from the Edit menu.

1. The names generated by Lambda Predict for new items and for copied/pasted items will vary depending on the
options you have selected in the Name Generator, accessed via the User Setup.
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• Select the MIL217:3 system in the Project panel, then select the system in the System panel and select
Paste from the shortcut menu or from the Edit menu. The MDI will look like the one shown next.

4.2.4  Transfer a Block and Components
You cannot copy and paste items from one type of system to another (e.g. from a MIL-217 system to a
Bellcore system). Instead, Lambda Predict allows you to transfer blocks and components from one system
type to another. This action converts the properties of the blocks/components to their closest equivalents in
the new analysis type. A transferred block or component is independent from the source and changes made
to one will not affect the other.

• Select the MIL217:3 system and add a new block. The block will be added at the same hierarchical level
as the Plated Through block that has been defined for this system.

• Add a capacitor, a coil and a switch to the new block. The MDI will look like the one shown next.
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• Right-click the new block and select Start Transfer To from the shortcut menu. The cursor will change
to two circling arrows, which indicates that the application is in transfer mode.

• Next, activate the Bellcore system in the Project panel and right-click the system in the System panel.
Select End Transfer Here from the shortcut menu. The block and components from the MIL-217
system will be added to the Bellcore system, as shown next with the hierarchy expanded.

Note that the capacitor has been transferred as a capacitor, while the coil has become an inductor. The
Bellcore standard does not have coils; inductors are the comparable part. Components where no comparable
part exists, such as the switch, are transferred as external components.

• Select one of the components in the System panel for the Bellcore system. The Data panel will refresh
to display the properties and parameters for the component. Notice that some of the properties and
parameters are the same as they were for the MIL-217 component and some have changed to meet the
requirements of the Bellcore standard. In addition, a Method tab appears in the Data panel. This tab
allows you to assign the method parameters for the component, which are required for a Bellcore
analysis.

The block and components that were transferred to the Bellcore system are independent of the source block
and components in the MIL-217 system. Therefore, if you make any changes to the source block/
components, they will not be reflected in the transferred block/components and vice versa.

4.2.5  Create a Linked Block
Lambda Predict allows you to create linked blocks that represent the relevant standards based reliability
prediction characteristics of another block or component.

• Activate the first MIL-217 project (MIL217:1) in the Project panel.

• Select the first block in the System panel and then change the name of the block to SBA-01.

• Activate the second MIL-217 project (MIL217:3) in the Project panel.
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• Right-click the system in the System panel and select Add then Add Linked Block from the shortcut
menu. A linked block will appear, as shown next.

• Next, right-click the linked block and select Start Selection for Source from the shortcut menu. The
cursor will change to < - >, which indicates that the application is in link mode.

• Again, activate the first MIL-217 project (MIL217:1).

• Right-click the block called “SBA-01” and select End Selection for Source from the shortcut menu.
This block will be the source for the linked block. The linked block now represents the characteristics of
the source block. If you change the characteristics of the source block, they will be reflected
automatically in the linked block.

• In the Project panel, return the focus to MIL217:3 and then select the linked block in the System panel.
The Data panel will refresh to display the properties and parameters for the block. Notice that the name,
source name and failure rate of the source block are displayed on the Physical tab of the Data panel, as
shown next.
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You can also select a component as the source for a linked block; the Link source name field on the Physical
tab of the Data panel will display the category of the source item.

4.2.5.1  Review the Links in the Project Link View Window
The Project Link View window displays a summary of all the links that have been established among
systems within the current project. 

• Select the project in the Project panel.

• Select Project Link View from the Tools menu. The Project Link View window will appear, as shown
next.

This window provides a list of each linked component in the project, including the name and type of the
source and destination projects, and the name of the source and destination components. To view the list
broken down by system, you can click the tab for each system. You can save this list as a text file if desired,
using the Save button. You can also use the Delete button to remove links between blocks. When a link is
removed, the source block/component is unchanged and the linked block remains in its system. However, a
new source must be selected for the linked block.

• Close the Project Link View window by clicking OK.

4.2.6  Save the Project
• If you are using a fully functional copy of the software (i.e. not a demonstration version), save the

project by clicking the Save icon or selecting Save Project from the File menu. The Save As window
will appear. Type Training Example 1 as the file name and accept the default file type, Lambda Predict
Project file (*.LPP).

• Click Save to save the file.

• After saving the project, close the project by selecting Close Project from the File menu. You will now
be looking at the MDI with no projects open.

4.3  Example 2 - Working with Component Properties
This example will demonstrate more advanced features of working with component properties in Lambda
Predict. It uses a sample data set for demonstration purposes that is not intended to be realistic. You will:

• Create a new project and copy a system from an existing project.

• Work with default component properties.

• Change connection types for your analysis, including a custom connection type.

• Plot your results.

• Save the project.

• Reset the default properties.
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4.3.1  Create the Project and Build the System
• Create a new project by selecting New Project from the File menu or by clicking the New Project icon

on the MDI toolbar.

• In the Create New Project window, select Blank Project and then click Finish to display the new
project. After clicking the project in the Project panel, the MDI will look like the one shown next.

• Open the Example3.LPP project that was shipped with the Lambda Predict software by selecting Open
Project from the File menu or by clicking the Open icon.
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• In the Open window, browse for and select the Example3.LPP file, located in the Examples folder in
your application directory (e.g. C:\Program Files\ReliaSoft\Prediction\Examples). Click Open. You
will now have two projects open in the MDI, with the focus on Example3.LPP, as shown next.

• In the Project panel, select the MIL217:3 system and copy it by right-clicking it and selecting Copy
from the shortcut menu or by selecting Copy from the Edit menu.

• Click the Project1 tab in the Project panel to return the focus to your new project. Paste the system you
have copied by right-clicking the project and selecting Paste from the shortcut menu or by selecting the
project then selecting Paste from the Edit menu. 

• Click the (+) beside the project to expand the tree to display the copied system, then click the system so
that it is displayed in the System panel, as shown next.

• In the Project panel, click the Example3.LPP tab, then select Close Project from the File menu. If
asked if you want to save changes to Example3.LPP, click No.
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4.3.2  Working with Default Settings
Each block or component that you add to a system has default properties that are pre-defined based on the
type of analysis that you are working with (i.e. MIL-217, Bellcore, etc.). If you have changed the settings for
an item, you can change them back to the saved default settings or you can set the changes to be the new
default properties for that item and analysis type.

• In the System panel, click the (+) beside Block 1 to display its components. Add a new capacitor to the
block and change its name to CAP-A. Notice that the failure rate of CAP-A is different from that of
Capacitor 1.1, even though they are the same type of component (i.e. capacitors). This is because the
properties of Capacitor 1.1 were changed from the defaults during the original Example3.LPP analysis.

• Compare the properties of the two capacitors on the Physical and Application tabs in the Data panel and
note the differences.

• Select Capacitor 1.1 and then select Set to Default from the Edit menu.2 A dialog box like the one
shown next will appear, asking you to confirm that you want to set the values of the selected component
back to the default values. 

• Click OK. The failure rates of the two capacitors now match. Take a moment to confirm that the
Physical and Application properties match as well.

• With Capacitor 1.1. still selected, change the capacitor style to Ceramic Trimmer and the number of
pins to 16 on the Physical tab of the Data panel.

• Select Save as Default from the Edit menu. The properties you have just entered for the selected
capacitor are now the default properties for all new capacitors.

2. You can also right-click inside the Data panel to access these commands via shortcut menu.



Step-by-Step Examples                                                                                                                           Lambda Predict

32      http://Predict.ReliaSoft.com      

• Add another capacitor to Block 1 called CAP-B and confirm that its properties match those of Capacitor
1.1. The MDI will look like the one shown next.

Resetting the default properties to the ones that were shipped with the application is covered at the end of
this example.

4.3.3  Define Connection Types
You may notice that the failure rates displayed for the components in a given block do not add up to the
failure rate displayed for the block. This is because Lambda Predict takes the connections between
components into account when calculating the block’s failure rate.

• To see this clearly, add a new, top-level block to the system (called “Block 4” by default), then add an
alpha-numeric display and a bubble memory to the block. Note that the failure rate of the Alphanumeric
Display, 0.00171 fphm, and the failure rate of the Bubble Memory, 0.394 fpmh, add up to 0.39571
fphm, while the failure rate of the block is 0.397 fpmh. Also note the failure rate for the system, 23.984
fpmh. The System panel is shown next.
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• In the Data panel, view the Application tab for Block 4. Change the connection type from Reflow
Solder to Spring Contact.

• Click any other block or component in the System panel to refresh. The failure rate for Block 4 has now
changed to 2.946 fpmh, and the failure rate for the system has changed to 26.533 fpmh, as shown next.

• Select each component of Block 4 and note that the Connection Type for each has changed to Spring
Contact to match the block.

In MIL-217 analyses, you also have the ability to define your own connection types. The connections you
create will be saved with the project and will be available to you at a later date, or to other users who open
the project.
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• Select Custom Connections from the Edit menu. The MIL-217 Custom Connections window will
open, as shown next. Two additional connection types have been pre-defined.

• In the Description field for User defined 3, type My Custom Connection. Enter 0.0049 in the Base
Rate field and click OK.

• In the System panel, select Block 4 and change its connection type to User defined 3 in the Application
tab of the Data panel. This option now represents the custom connection type that you just defined.
Click any other block or component in the System panel to refresh. Note the changes to the failure rates,
as shown next.
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4.3.4  Plot Results
• Select the system in either the Project panel or the System panel. From the Tools menu, select Plots.

The Plot Viewer will appear, with the system data plotted in whatever plot type was last selected. Make
the following selections in the Control Panel and then refresh the plot if necessary.

•  Plot Type: Failure Rate

•  Include Blocks: Selected

•  Blocks Only: Not Selected

•  Group: No Grouping

•  Allocation: None

•  Auto Refresh: Selected

This plot shows the failure rate of each block and component. If you were to clear the Include Blocks option,
the plot would show only the failure rates of the components.

• Make sure that Auto Refresh and Include Blocks are selected, then select Failure Rate vs.
Environment from the Plot Type drop-down menu. If the Plot Viewer has not been used to plot an
environment plot before, it will generate an alert, as shown next.
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• Click OK, then click Environment in the Plot Viewer. The Environment Setting window will appear,
as shown next.

• Select all five of the Airborne environments and click OK. The Failure Rate vs. Environment plot will
appear, as shown next.

This plot shows the system failure rate in each of the selected environments.
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• Keeping the Plot Viewer open (and using the caption bar to move it if necessary), select Block 3.2 in the
System panel. The results now displayed in the Plot Viewer are the failure rate for only that block in the
selected environments, as shown next.

• Select Category from the Group menu to group the plot by component category, as shown next.

Suppose that you want to take a closer look at the component categories with the three lowest failure rates.
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• Click Exclude and the Exclude window will appear, as shown next.

• Select Micro, Digital and use the >> button to move it to the Excluded from area, then do the same for
Micro, Memory and click OK.

• Click the Draw Plot icon to refresh the plot.

Note that the new plot uses a different scale on the Y-axis from that of the original plot, thereby magnifying
your view of the remaining categories, as shown next.

• Close the Plot Viewer.

4.3.5  Save the Project
• If you are using a fully functional copy of the software (i.e. not a demonstration version), save the

project as Training Example 2.LPP.

• Close the project.
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4.3.6  Reset the Default Properties
• Close Lambda Predict.

• In Windows Explorer, find your application directory (e.g. C:\Program Files\ReliaSoft\Prediction).
Within that directory, choose Programs\LambdaPredict_DefaultProperty\MIL217, as shown next. 

• Delete the Capacitor.PRP file. This will restore the default settings for MIL-217 capacitors to the ones
that are shipped with the software (which restores the software to the state that it was in before you
made the changes specified in Section 4.3.2).

Note that deleting the entire LambdaPredict_DefaultProperty folder will restore all settings in Lambda
Predict to the defaults shipped with the software.

4.4  Example 3 - Working with Different Types of Systems in the Same
Project
One of the features that contributes to Lambda Predict’s flexibility is the ability to have multiple projects
open simultaneously and to analyze multiple systems within each project. This makes copying and pasting
between systems and projects easy, which can reduce the time it takes to model system configurations. It
also gives you the capability to analyze different types of systems concurrently. For example, you may wish
to analyze an electromechanical system by combining a MIL-217 analysis (for electrical components) with
an NSWC analysis (for mechanical components). The project-level results will display the failure rate and
other information for all components combined.

In this example you will:

• Create a new project.

• Copy an electronic system and a mechanical system from other projects.

• View the results at the project level.

• Configure the display of information in the MDI.

• Save the project.

4.4.1  Create a Project and Copy Existing Systems
• Create a new, blank project.

• Open the Example1.LPP project that was shipped with the Lambda Predict software, located in the
Examples folder in your application directory (e.g. C:\Program Files\ReliaSoft\Prediction\Examples).
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• Open the Example2.LPP project, located in the same directory. You will now have three projects open
in the MDI, with the focus on Example2.LPP. The next figure shows the MDI with the second MIL-217
system in the Example2.LPP project selected.

• In the Project panel, select the MIL217:3 system and copy it by right-clicking it and selecting Copy
from the shortcut menu or by selecting Copy from the Edit menu.

• Click the appropriate tab in the Project panel to return the focus to your new, blank project. Paste the
system you have copied by right-clicking the project and selecting Paste from the shortcut menu or by
selecting the project then selecting Paste from the Edit menu. 

• Click the (+) beside the project to display the copied system, as shown next.

• Next, click the Example1.LPP tab in the Project panel, select the NSWC:2 system and copy it.

• Return the focus to the new project and paste the system. Note that you can only paste it directly to the
project and not anywhere else in the Project panel.
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• Close Example1.LPP and Example2.LPP. The MDI will look like the one shown next.

4.4.2  View the Results
• Select the project in the Project panel. Note that the Analyze command is unavailable in the toolbar and

in the Tools menu because you cannot view project level results in the Pi/Rate window. For project-
level results, you must use the Results Viewer.

• Select Results from the Tools menu. The Results Viewer will open, as shown next.

Results available at the project level are limited to Failure Rate, Unavailability and Mean Time Between
Failures (MTBF). For more detailed results on either system or blocks and components within either system,
select the item while the Results Viewer is open.

• Close the Results Viewer.

4.4.3  Configure the Display
As previous examples have demonstrated, failure rate and other results are also displayed in the Project and
System panels. You can use the User Setup to choose which columns will be displayed in these panels as
well as the units (i.e. fph, fpmh or fits) and numerical precision for displayed results. These options are set
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independently for project-level results and for each type of analysis. For this example, assume that you want
to display the contributions that the electrical and mechanical subsystems make to the overall failure rate for
the system. In addition, you will change the number of decimals displayed for the results.

• Select User Setup from the File menu. The User Setup window will appear, as shown next.

• Click the Project tab. The Project page will appear, set to the Layout tab, as shown next. This page
controls which columns are displayed in the Project panel.

• Clear the MTBF, Unavailability and Time options and select Contribution. 
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• Now, click the Precision tab on the left. The User Setup window will look like the one shown next.

• Change the Floating point significant digits option to 2 and click OK to save the changes and close the
window. 

• The appearance of the Project panel will be updated automatically, as shown next. You can see that the
electrical components (analyzed with MIL-217) contribute 4.63% of the total failure rate while the
mechanical components (analyzed with NSWC) contribute the remaining 95.36%. These values are
displayed with two decimal places, as specified in the User Setup. 

4.4.4  Save the Project and Restore Default User Setup
• If you are using a fully functional copy of the software (i.e. not a demonstration version), save the

project as Training Example 3.LPP.

• Close the project.

• In the User Setup, reset the options you changed in this example by clicking the Other tab, then Set
Workspace to Default. You will need to restart Lambda Predict for this to take effect.

• Click OK to save the change and close the User Setup then re-start Lambda Predict before proceeding
with the next example.
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4.5  Example 4 - Performing a What-If Analysis
Lambda Predict’s ability to analyze multiple systems within each project also allows you to perform “what-
if” analyses for comparison purposes. For example, you may wish to change one parameter (such as
temperature, environment, etc.) to see what impact it will have on the predicted failure rate.

For this example, imagine that you wish to analyze the effect of ambient temperature on a computer system.
You will: 

• Create a new project.

• Copy/paste a system from an existing project.

• Duplicate the system and change the temperature parameters to compare the results under the different
conditions.

• Save the project.

4.5.1  Create a Project and Copy/Paste an Existing System
• Create a new, blank project.

• Open the Example3.LPP project that was shipped with the Lambda Predict software, located in the
Examples folder in your application directory (e.g. C:\Program Files\ReliaSoft\Prediction\Examples).

• Copy the MIL-217 system called “MIL217:3” from Example3.LPP and paste it into the new project.
Then close Example 3.LPP. After expanding the hierarchy in the Project panel for the new project, and
with the MIL-217 system selected, the MDI will look like the figure shown next.
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4.5.2  Duplicate the System and Change the Temperature
• In the Project panel, copy the system and then paste it to the project. The MDI will look like the one

shown next. 

• Select the pasted system (MIL217:2) in the Project panel. In the Data panel, change the description to
read “ABC Computer System Model ABC/XT (+15 degC).”

• Select any block or component in the System panel. On the Application tab of the Data panel, note that
the Ambient Temperature (degC) field displays 30.

• Select the system in the System panel, then select Global Edit from the Edit menu. The MIL-217
Global Edit window will appear, as shown next.
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The MIL-217 Global Edit window allows you to simultaneously change the operating conditions for all
blocks and components within a given block or system, or even all MIL-217 systems within a project. By
using this feature on the system you have just pasted, you can change the temperature and compare the new
failure rates under the higher temperature to the original failure rates.

• Make sure that Temperature is selected at the top of the window.

• In the Temperature section of the window, make sure that Incremental addition is selected and enter 15
in the input box to the right. This will add 15 degrees C to the ambient temperature of every block and
component within the selected scope (see next step).

• At the bottom of the window, you have the option to apply your changes to all MIL-217 systems within
the current project or to all blocks and components in the selected system. Make sure the second option
is selected. The window will look like the figure shown next.

• Click OK to close the window and apply the changes. Now when you look at the Ambient Temperature
(degC) field for any block or component in the system, you can see that the temperature has been
increased by 15 degrees to 45. The failure rates and other results have also been updated accordingly.
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• Compare the failure rates for the MIL217:2 system to those for the MIL217:1 system. Note that the
increase in ambient temperature has affected the failure rates throughout the system. The MDI will look
like the one shown next. 

Other types of “what-if” analyses can be performed in a similar manner.

4.5.3  Save the Project
• If you are using a fully functional copy of the software (i.e. not a demonstration version), save the

project as Training Example 4.LPP.

• Leave the project open for use in the next example.

4.6  Example 5 - Using Reporting and Printing Capabilities
This example will demonstrate some of Lambda Predict’s printing and reports capabilities. Using the
Training Example 4.LPP project created in the last example, you will:

• Preview and/or print the information available in each of the MDI panels.

• Select, customize and preview and/or print a report.

4.6.1  Print the Active View
You can print the information currently displayed in the Project panel, the System panel or the Grid view of
the Data panel.

• Click anywhere in the Project panel, then select Print Preview then Preview Active View from the File
menu. The Print Preview window will open to display a preview of the printout of the Project panel
hierarchy. If desired, you can use the buttons at the top of the window to adjust the zoom and/or send the
document to the printer.

• When you are finished experimenting with the Print Preview feature, close the window by clicking the
Close button.

• Follow the process outlined above to preview and/or print the System panel. Note that the panels will be
printed as they appear in the MDI (i.e. blocks will be expanded to display components in the printout
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only if they are currently expanded in the software), so you may wish to expand the view of each block
so that the full system configuration is displayed in the printout. The printout is not limited by the size
of the panel; all displayed information will be printed. The next figure shows the preview of the System
panel with all blocks expanded and the zoom set to 100%.

• Close the Print Preview window and then select the first block in the MIL217:2 system. Set the Data
panel to Grid view.

• Select Page Setup then Page Break Preview from the File menu. The page breaks will appear on the
grid, as shown next.

There are numerous ways to adjust the printout of the Grid view. These are demonstrated next.

• Select Print Setup from the File menu, select Landscape in the window that appears and click OK.
The change may not be reflected automatically on your screen; if this is the case, turn off the page break
preview by re-selecting Page Setup then Page Break Preview from the File menu, then turn the page
break preview back on again.
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• Select Page Setup then Fit to Page from the File menu. The Page Configuration window will appear,
as shown next.

• Select Fit to Grid and enter 3 in Pages Wide and 2 in Pages Long. This will cause the printout of the
grid to be sized to fit into the designated number of pages. Click OK to close the window and update the
display in the Grid view. Note that the pages are numbered in the order in which they will print, which is
currently across then down within the worksheet.

• Select Page Setup then Page Printing Order from the File menu. Note that the current printing order
(Left to Right) is displayed beside this command. The printing order will change so that pages are
printed top to bottom; this change is reflected in the page numbers in the Grid view.

• You can print the document, if desired, or select Print Preview then Preview Active View from the File
menu to preview how the printout will look on the page. When finished, close the Preview window.

4.6.2  Generate Pre-Defined Reports
In addition to the ability to print the information in any of the MDI panels, Lambda Predict also provides a
complete array of print-ready reports.

• Select Print then Reports from the File menu to open Lambda Predict's Reports window. This window
allows you to select and print pre-defined reports, preview selected reports, create custom report
templates and/or customize pre-defined report templates. The Reports window is made up of four pages
that are accessible by page index tabs. The first page in the Reports window is the Selection page. This
page allows you to select the reports that you want to create. 

• In the Project/System Selection panel on the left side of the Selection page, select the system that you
want to create the report for, MIL217:2. 

• The Report Selection panel that appears on the right side of the Selection page displays the default and
user-defined or customized report templates that can be used to generate the reports. This panel allows
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you to select the reports you want to create for the selected system. For this example, select both the
tabular Failure Rate report and the graphical Failure Rate report, as shown next.

• Click the Preview tab. This page allows you to preview the reports that are currently selected on the
Selection page before they are sent to the printer. For this example, the tabular MIL-217 Failure Report
will be displayed first, as shown next. 

• Click the Go To Next Page button at the top of the window to preview the remaining pages of this
report. 

• Click the Next Report button at the bottom of the window to preview the next selected report, i.e.
Failure Rate bar chart.
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• When you are finished experimenting with the Preview page, click the Customize tab, which allows
you to customize selected reports.

• In the hierarchy that appears on the left side of the page, select the template for the tabular Failure Rate
report under MIL-217 Reports. The right side of the page will be updated to allow you to customize the
header, footer, fields displayed and other information for the selected report. 

• For this example, change the header of the report to display the Name, Description and Failure Rate
fields and change the font to Times New Roman, as shown next.

• Return to the Preview page to see the effect of the changes. If necessary, use the Zoom menu to
increase the magnification so that you can see the fields more clearly.

• If desired, print the reports at this time. A separate Print window will appear for each report that is
printed.

• Close the Reports window.

• Save the project if you are using a fully functional copy of the software then close the project.
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4.7  Example 6 - Working with Libraries
Lambda Predict’s libraries provide pre-configured components that you can copy and paste or import into
your project. You can use the extensive collection of parts libraries that are included with the application or
create your own libraries that contain frequently used components. You can then use these libraries to build
the systems for your analyses. 

This example will guide you through the basic techniques for working with libraries in Lambda Predict. You
will:

• Create a system using blocks/components from a library.

• Create a new library with blocks/components from an existing system.

• Load a library in the background.

• Use the Part Number Search feature to set component properties based on a background library.

4.7.1  Create a New Project and Open a Library
• Create a new project with a MIL-217 system.

• Select Open Library from the Library menu, then browse for and select the DemoLib.LPL file,
located in the Examples folder in your application directory (e.g. C:\Program
Files\ReliaSoft\Prediction\Examples). Click Open. 

The library will open in the Library panel, which will appear by default between the Project and System
panels and the Data panel. In addition, the library will appear in the Project panel, indicated by a tab. Please
note that you can adjust the size or position of the panels within the MDI to meet your particular preferences
for data entry. For example, you can click the bar at the top of a panel and drag it to a new position. You can
also drag the “splitter” at the bottom and right sides of a panel to adjust the height and width. When the
mouse is in a position to drag the “splitter,” it will change to look like two bars with arrows on either side.

The next figure shows the MDI with the Project panel at the top left, the System panel at the bottom left, the
Library panel in the middle and the Data panel on the right.
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4.7.2  Create a System Using Blocks/Components from a Library
To copy pre-defined blocks and components from the library into your new MIL-217 analysis, do the
following:

• In the Project panel, select the first MIL-217 system in the library. The Library panel will refresh to
show the contents of the selected system.

• Return the focus to the new project, then click the new MIL-217 system to refresh the System panel.

• Select the block in the Library panel and either copy/paste or drag/drop it into the new MIL-217 system
that you are building in the System panel. 

The next figure shows the MDI with the current system configuration. You can see that the block and all of
its components have now been added to the new system configuration, with the properties that were pre-
defined in the library. As with all copy/paste actions in Lambda Predict, the pasted items are independent
from the source and subsequent changes to the blocks/components in the library will not be reflected
automatically in the system. 

4.7.3  Create a New Library from an Existing System
To create your own custom library with blocks/components from an existing system, do the following:

• Open the First Steps.LPP project that you created in the First Steps example.3

3. If you are using a no-save demonstration version of the software, you can perform the rest of the example using one of
the example files that was shipped with the software instead of the First Steps.LPP project.
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• Create a new library by selecting New Library from the Library menu. The MDI will look like the one
shown next.

• Right-click the new library in the Project panel and select Add then Add MIL-217 System from the
shortcut menu. The MIL-217 system will appear in the Project panel and the Library panel.

• Activate the First Steps project by clicking its tab in the Project panel. Then select the MIL-217 system
to update the System panel.

• Select the block in the System panel and either copy/paste or drag/drop it into the MIL-217 system in
the Library panel, as shown next. 
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4.7.4  Save the New Library and Close Both Libraries
• If you are using a fully functional copy of the software (i.e. not a demonstration version), select the

library in the Project panel then select Save Library from the Library menu. Type First Steps Library
as the file name and accept the default file type, Lambda Predict Library file (*.LPL), as shown next.

• Click Save to save the file. The block and components (with the properties defined in the existing
analysis) will now be available to add to other system configurations, when this library is activated.

• With First Steps Library.LPP selected in the Project panel, select Close Library from the Library
menu and then repeat the process for the DemoLib.LPP. When both libraries have been closed, the
Library panel will no longer be displayed.

4.7.5  Load a Background Library
Lambda Predict’s Library Manager enables you to load one or more libraries in the background. This allows
you to have access to the pre-defined component data stored in libraries without taking space in the MDI to
display the Library panel. When libraries are loaded into the background, they are available for
consideration in the part number search feature.

• Select Load Background Libraries from the Library menu. The Library Manager will appear, as
shown next.



Step-by-Step Examples                                                                                                                           Lambda Predict

56      http://Predict.ReliaSoft.com      

• Click Add to add a new row, then click inside the Path column in that row. Click the Browse icon that
appears on the right side of the column then browse for and select the DemoLib.LPL file that you used
in the previous example.

• The path for the library will now be displayed in the Path column. Make sure the Include checkbox is
selected and click Load Selected Libraries. The library is now loaded in the background. Once the
library has been loaded, the remaining columns in the window will be updated to display the number of
blocks, number of components and other information for each background library.

• Click OK to close the Library Manager.

4.7.6  Create a New System and Configuration
• Activate the project (Project1) in the Project panel then add a new MIL-217 system.

• In the System panel, add a block with the following components:

2 capacitors

1 bubble memory

1 micro, digital

1 resistor

4.7.7  Use the Part Number Search Feature
• Select the first capacitor in the System panel. On the General tab in the Data panel, click the magnifying

glass icon that appears next to the Part Number field. A menu will appear, as shown next.

• Select Search Library then open the drop-down menu in the Part Number field. It will be populated
with a list of all the part numbers assigned to capacitors in the DemoLib.LPL library, which is currently
loaded in the background. 
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• Select part number ECCA3A101JGE (this is the second part number in the list). The other fields in the
General tab of the Data panel will be populated with the properties assigned to the component in the
background library with that part number, as shown next.

• Take a moment to view the properties now assigned to your capacitor on the Physical and Application
tabs of the Data panel, then return to the General tab.

• In the System panel, select the second capacitor. Note that when you do so, the System panel refreshes
to show the properties now assigned to the first capacitor.

4.7.8  Use the Library Browse Window
• Select Browse Library from the Library menu. The Library Browse window will open, as shown next.

Note that because you had a capacitor selected in the System panel when you opened the Library Browse
window, the Category filter in the left-hand column is automatically set to Capacitor and only the parts in the
currently loaded library that match that category and the current analysis type (MIL-217) are displayed in
the Components Table on the right.
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• You will be selecting part number ECCA3A390KGE. While you could look for this part number in the
list, it is simpler to search for it, particularly when you have many libraries or large libraries loaded. In
the Search Strings area on the left, enter 390 in the Part Number field and make sure that the Contains
option is selected, then click Update Search. Only parts of category Capacitor with part numbers
containing “390” are now displayed in the Components Table. 

• Click the component’s row number to highlight it. Note that the cursor must be positioned in the row
number cell, not in any of the other cells, as shown next.

• Click Select. The Library Browse window will close. You will see in the System and Data panels that
the second capacitor now has new properties assigned corresponding to its new part number.

• Follow the steps outlined above to assign the following part numbers to the remaining components, and
thereby set the properties of each component based on the pre-defined library.

Component Part Number

Bubble Memory BM0001

Micro, Digital MD0001

Resistor 3214J-1-500E (this is the third part number in the list)
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The MDI will look like the one shown next.

4.7.9  Save the Project
• If you are using a fully functional copy of the software (i.e. not a demonstration version), save the

project as “Training Example 6.LPP.” 

• Close all open projects. Note that libraries loaded in the background will stay available until you exit
Lambda Predict. 

• Exit and re-start Lambda Predict to clear the background libraries and all display tabs.

4.8  Example 7 - Importing and Exporting Data
This example will guide you through the basic techniques for importing and exporting data with Lambda
Predict. You will:

• Open an existing project.

• Export data from the project to a Microsoft Jet database.

• Create a new project.

• Import data from the Microsoft Jet database you have created into the new project.

• Save the project.

4.8.1  Open the Project for Export
• Open the Example2.LPP project that was shipped with the Lambda Predict software, located in the

Examples folder in your application directory (e.g. C:\Program Files\ReliaSoft\Prediction\Examples).
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4.8.2  Export the Project Data
You can export the data from your Lambda Predict projects to a Microsoft Jet database, Excel file or
delimited text file using the Export Wizard. For this example, we will be using the Microsoft Jet database
format. 

• Select the second MIL-217 system (MIL217:4) as the system that you want to export the data from and
then select Export from the File menu. The Export Wizard window will appear. This wizard guides you
through the steps required to determine which data will be exported and to create the export file. The
steps (i.e. pages) in the Export Wizard are presented next.

4.8.2.1  Export Wizard Step 1
The first step of the Export Wizard displays the location to which the data will be exported in the Pathname
display box, as shown next. This location can be changed in Step 4 of the Export Wizard.

• Click Next >> to move to the next step.
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4.8.2.2  Export Wizard Step 2
The second step of the Export Wizard allows you to select the tables that contain the data that you want to
export.

The available tables appear in the Input Table list on the left and the tables that will be exported appear in the
Output Table list on the right. 

• Add all of the tables to the Output Table list by clicking the Add All (>>>) button.

• Click Next >> to move to the next step.

4.8.2.3  Export Wizard Step 3
The third step of the Export Wizard allows you to select the fields that contain the data that you want to
export. The available fields are based on the tables that you selected in the previous step.

The tables that you selected in the previous step appear in the Select Table list on the left. The fields that are
associated with the selected table appear in the Input Fields list in the middle. The fields that contain the data
that will be exported appear in the Output Fields list on the right.
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• Select the first table in the Select Table list and click the Add All (>>>) button to add all the fields in the
Input Fields list to the Output Fields list.

• Repeat the procedure for the remaining four tables.

• Click Next >> to move to the next step.

4.8.2.4  Export Wizard Step 4
The fourth step of the Export Wizard allows you to select the file format that you want to export the data to,
preview the data that will be exported and specify the path/filename for the exported file. 

• Select Microsoft Jet Database from the Format menu to indicate that the data will be exported to an
*.mdb file.

• Accept the default path/filename for the file or click Browse to specify a different location. Please note
the location so that you can use the export file later in this example. 

If the Show Preview option is selected, a preview of the fields that contain the data that will be exported for
each table will be displayed in the Preview area. Click a tab to view the data for the corresponding table.

• Once you have made the appropriate selections, click Finish to export the data.

• A window will appear asking if you want to save the current export settings. This allows you to save the
settings you have created in the Export Wizard as a template so that they can be reused. Click No for
this example. 

When the export is finished, the Export Wizard will close. The exported data can be accessed from the
location that you specified in Step 4. 

• Close the Example2 project.

4.8.3  Create a New Project and Import Data from the *.mdb File
• Create a new, blank project.

• Select Import from the File menu. 

• You will be prompted to save your project. Save the project as Training Example 7.LPP.

The Import Wizard window will appear. This wizard guides you through the steps required to import data
from an existing Microsoft Jet database, Excel file or delimited text file. The steps (i.e. pages) in the Import
Wizard are presented next.
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4.8.3.1  Import Wizard Step 1
The first step of the Import Wizard allows you to select the file that you want to import the data from, as
shown next.

• Select Microsoft Jet Database from the Format menu and click the Browse button.

• Select the *.mdb file that you just created and click Open to return to the Import Wizard. 

• Click Next >> to go to the next step.

4.8.3.2  Import Wizard Step 2
The second step of the Import Wizard allows you to map the tables in the file you are importing the data
from with the tables in the current project.

The tables that exist in the file you are importing the data from will appear in the Input Tables list on the left.
The tables that are available in the project appear in the Output Tables list on the left.

• Click Auto Match to have the Import Wizard automatically map the tables for you.

• Click Next >> to go to the next step.
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4.8.3.3  Import Wizard Step 3
The third step of the Import Wizard allows you to map the fields in the file you are importing the data from
with the fields that are available in the Lambda Predict project.

The tables that exist in the file you are importing the data from appear in the Table Association list on the
left. The fields associated with the currently selected table will appear in the Input Fields list in the middle.
The fields that are available in the project appear in the Output Fields list on the right.

• Select the first table in the Table Association list and click Auto Match to have the Import Wizard
automatically map the fields for you. 

• Repeat for the remaining three tables in the Table Association list. 

• Click Next >> to go to the next step.

4.8.3.4  Import Wizard Step 4
The fourth step of the Import Wizard allows you to select additional import options.



Step-by-Step Examples                                                                                                                           Lambda Predict

      http://Predict.ReliaSoft.com     65

The path and file name of the file that you are importing the data from appears in the Pathname input box at
the top of the window. The Preview area displays the fields that contain the data that will be imported for
each table. You can click the tab to view the data for the corresponding table.

• For this example, accept the default import options and click Finish to import the data.

• A window will appear asking if you want to save the current import settings. This allows you to save the
settings you have created in the Import Wizard as a template so that they can be reused. Click No for
this example. 

• When the import is finished, the Import Wizard will close. You can see that a MIL-217 system with
blocks and components has been added to your project, as shown next with the new system selected in
the Project panel.

4.8.4  Save the Project
• If you are using a fully functional copy of the software (i.e. not a demonstration version), save the

project. You will not need to assign a name, as this project has already been saved as Training Example
7.LPP.

• Close the project. 

4.9  Example 8 - Using the Allocations Utility
In a project or system with multiple subsystems, it is sometimes necessary to apportion the product design
reliability into lower level design criteria such that the cumulative reliability still meets the requirements.
Lambda Predict’s Allocations utility provides five allocation models that can be used to perform this task. In
this example, you will:

• Open an existing project.

• Use the Allocations utility to determine appropriate reliability goals for subsystems.

• View the results in a plot.

• Generate a report of the results.
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4.9.1  Open an Existing Project
• Open the Example2.LPP project that was shipped with the Lambda Predict software, located in the

Examples folder in your application directory (e.g. C:\Program Files\ReliaSoft\Prediction\Examples).

4.9.2  Use the Allocation Utility to Set Reliability Goals
• In the Project panel, select the MIL217:4 system.

• Open the Allocations utility by selecting Allocation from the Tools menu. The Allocations utility will
open to the Equal page, as shown next.

The Equal Allocation model apportions reliability equally among all subsystems to meet a user-defined
reliability goal for a specified operation time. For this example, we will use the default reliability goal of 0.9,
or 90%, and the default operating time of 8760 hours (1 year). You can see that, in order to reach the
reliability goal of 0.9, each subsystem must achieve a reliability of 0.982.

• Click the ARINC tab. The ARINC page will appear, as shown next.

The ARINC apportionment technique allocates improved failure rates to meet the reliability goal at the
given operating time by deriving weighting factors from the present allocations of the subsystems and using
them to recalculate subsystem goals, which combine to meet the overall goal. Note that the values in the
Allocated Failure Rate column are in proportion to the values in the Present Failure Rate column. This
model assumes that all subsystems are in series and have constant failure rates. 
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• Click the AGREE tab. The AGREE page will appear, as shown next.

The AGREE model takes into account additional data for each subsystem, including complexity and
importance, when calculating subsystem reliability goals.

• Input the following values for the subsystems:

The Allocated Failure Rate and other calculated columns (gray background) will be updated based on your
inputs, as shown next.

Part Number Operating 
Time

Importance 
Factor

Number of 
Subelements

Block One 4380 1 2

Block Two 8760 1 2

Block Three 8760 1 2

Hybrid One 8760 5 2

Circuit Board One 8760 10 2

Surface Mount One 8760 20 2
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Note that the values in the Reliability Allocated, Allocated Failure Rate and Allocated MTBF columns
change depending on the values you input. Because each subsystem in this example has the same number of
subelements, you can clearly see the effect that operating time and importance factor have on the allocation
of reliability goals.

• Close the Allocations utility by clicking OK.

4.9.3  View the Results in a Plot
• With the MIL217:4 system still selected in the Project panel, select Plots from the Tools menu to open

the Plot Viewer.

• Make sure the Auto Refresh option is selected and choose Failure Rate from the Plot Type drop-down
menu. 

• For this example, select Blocks Only so that components will not be plotted. Your plot will look like the
one shown next.
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• From the Allocation drop-down menu, select AGREE.4 The plot will refresh to display the apportioned
failure rate goals that you just calculated in the Allocations utility along with the current failure rates
from the analysis. Your plot will look like the one shown next.

• Close the Plot Viewer.

4.9.4  Generate an Allocation Report
• Select Print then Reports from the File menu. Lambda Predict's Reports window will be displayed. 

• On the Selection page, select the MIL217:4 system in the hierarchy on the left and select the Allocation
report in the hierarchy on the right, as shown next. 

4. If this menu is not enabled, re-select Failure Rate from the Plot Type menu to update the utility.
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• Go to the Preview page to view the Allocation report, as shown next. 

Note that it contains columns for the Feasibility of Objective and Repairable Systems allocations models.
Since this example does not contain data for those models, you will remove the columns pertaining to them.

• Go to the Customize page and select the Allocation report under MIL-217 Reports to display the
customization options for this report. 

• Click the Fields tab, which allows you select the data fields that will be included in the report and make
other display decisions.

• Select Feasibility Allocated Failure Rate and then click Remove Field to remove it from the list.
Repeat this procedure for the following fields:

•  Feasibility Allocated MTBF

•  Repairable Systems Allocated Failure Rate

•  Repairable Systems Allocated MTBF
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When you are finished, the window will look like the figure shown next.

• Return to the Preview page and check that the appropriate columns have been removed from the report,
as shown next.

• If desired, print the report before closing the Reports window and then closing the project.
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4.10  Example 9 - Derating 
Most equipment failures are precipitated by stress. When the applied stress exceeds the inherent strength of
the part, either a serious degradation or a failure will occur. To assure reliability, equipment must be
designed to endure stress over time without failure. In addition, design stress parameters must be identified
and controlled and parts and materials that can withstand these stresses must be selected. Derating standards
are used to help you select and apply parts and materials so that the applied stress is less than rated for a
specific application. 

For this example, imagine that you wish to analyze the effect of ambient temperature on a computer system.
You will: 

• Create a new project.

• Copy/paste a system from an existing project.

• Apply an existing derating standard to the system.

• Change the application parameters to view the effects on derating.

• Save the project.

4.10.1  Create a Project and Copy/Paste an Existing System
• Create a new, blank project.

• Open the Example3.LPP project that was shipped with the Lambda Predict software, located in the
Examples folder in your application directory (e.g. C:\Program Files\ReliaSoft\Prediction\Examples).

• Copy the MIL-217 system called “MIL217:3” from Example3.LPP and paste it into the new project.
Then close Example 3.LPP. After expanding the hierarchy in the Project panel for the new project, and
with the MIL-217 system selected, the MDI will look like the figure shown next.
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4.10.2  Apply an Existing Derating Standard to the System
• Select the system in the System panel and then select Derating from the Tools menu. The Lambda

Predict Electronics Prediction Derating window will appear, as shown next. 

• Select the NAVSEA TE000-AB-GTP-010 standard and click OK.

• In the System panel, expand the first block. You will see that the derating standard has been applied; in
the System panel, the components are color-coded according to whether they meet the derating
requirements, as shown next.

Components that meet the derating requirements (here, the Diode, Low Frequency) will have a “D” on the
component icon. Components that are not over-stressed but are above the nominal value given in the
derating standard are shown with light blue icons (here, all capacitors and one resistor). Components that are
over-stressed based on the derating requirements (here, the transformer) have a red icon. Components with a
plain, dark blue icon (here, the connection and one resistor) are not considered in the derating standard.
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• Select the first capacitor and then select Derating from the Tools menu. The Lambda Predict
Electronics Prediction Derating window will appear, now displaying derating information specific to
the capacitor, as shown next.

The blue dot on the plot shows where the capacitor stands with respect to the requirements of the derating
standard. The red line represents the worst case points and the green line represents the nominal points. Note
that the capacitor currently falls between the nominal and worst case lines. In other words, it does not meet
the derating requirements, but is not actually over-stressed. You can see from the shape of the plot that
altering the ambient temperature will not address this problem. Instead, the voltage stress must be reduced.

4.10.3  Change the Application Parameters
• Position the cursor at the intersection of the green line and the Y-axis. The location of the cursor, (0.00,

0.4000), will appear as a tool tip. This gives you an idea of the appropriate voltage stress for this
component in the current environment.

• Leave the Derating window open and select the first block in the System panel of the main window.

• In the Data panel, select the Application tab. Change the Voltage Stress to 0.39 and click in any other
field on the Application tab to update the block with your change. You will see that all seven capacitors
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associated with the block  now have a “D” in their component icons, indicating that they meet the
derating requirements, as shown next.

You will also see that the display in the Lambda Predict Electronics Prediction Derating window has been
updated to reflect your changes, as shown next.

4.10.4  Save the Project
• If you are using a fully functional copy of the software (i.e. not a demonstration version), save the

project as Training Example 9.LPP.

• Close the project. 




