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1.1  About this Training Guide

This training guide is intended to provide you with many examples to demonstrate the use of Lambda
Predict. It begins with step-by-step examples and then proceeds into more advanced examples and
questions.

Some of the examples in this training guide require you to access files that have been shipped with the
Lambda Predict software. These files are located in the Training Guide folder in your application directory
(e.g. C:\Program Files\ReliaSoft\LambdaPredict3\Training Guide).

1.2  Lambda Predict Documentation

Like all of ReliaSoft's standard software products, Lambda Predict is shipped with
detailed printed documentation on the product (Lambda Predict User's Guide). This
training guide is intended to be a supplement to that reference.

1.3  Minimum System Requirements

Lambda Predict 3 is compiled and designed for Microsoft Windows XP and Vista and takes advantage of the
features available in these platforms.
 
Minimum system requirements:

 Windows XP or Vista.

 Microsoft Excel® 2003 or higher for automated report generation.

 433 MHz Pentium class, AMD Opteron, AMD Athlon64 or AMD Athlon XP processor with 256 MB of
RAM (512 MB or more is recommended), SVGA display and at least 125 MB of hard disk space.

Please note that if you have set your computer to use large fonts, you will need to set your screen display to
1024x768 in order for all windows to display correctly.

Lambda Predict Training 
Guide 1
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1.4  Contacting ReliaSoft

ReliaSoft can be reached at:
ReliaSoft Corporation
Worldwide Headquarters

1450 South Eastside Loop
Tucson, AZ 85710-6703  USA

Phone: +1.520.886.0410
Fax: +1.520.886.0399

E-mail: Support@ReliaSoft.com

For up-to-date product information, visit our Web site at:
http://Predict.ReliaSoft.com
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The examples in this training guide have been designed to introduce you to the features available in Lambda
Predict. This section presents a brief summary of these features. If you are already familiar with Lambda
Predict’s features, you can proceed to the next chapter, First Steps.

2.1  Lambda Predict Supports Major Reliability Prediction Standards

Lambda Predict can be used to perform standards based reliability prediction analyses according to any of
the following major published standards:

 MIL-HDBK-217: Reliability Prediction of Electronic Equipment (MIL-HDBK-217F), issued by the
U.S. Department of Defense in December, 1991. Lambda Predict supports both the Part Stress and Parts
Count calculation methods for electronic components in commercial and military applications.

 Bellcore/Telcordia: Reliability Prediction Procedure for Electronic Equipment (SR-332 Issue 2), issued
by Telcordia Technologies in September, 2006. This standard provides reliability prediction models for
electronic components in commercial applications. Lambda Predict also supports two previous versions
of the standard (TR-332 Issue 6, issued by Bell Communications Research in 1997 and SR-332 Issue 1,
issued by Telcordia Technologies in 2001).

 NSWC (Mechanical): The Handbook of Reliability Prediction Procedures for Mechanical Equipment
(NSWC-07), issued by Naval Surface Warfare Center Carderock Division on July 31, 2007. This
standard was originally released in the 1980s. It provides reliability prediction models for mechanical
components, such as seals, springs, pumps, valves, brakes and more.

2.1.1  A Note about Licensing

Your copy of Lambda Predict is limited to the reliability prediction standard(s) that you purchased with your
license. If you receive a file that contains systems that use standards that are not included in your license:

 You will be able to open the database file. You will see a notification upon opening the file that it
contains systems based on standards not included in your license.

 You will be able to open all predictions in the project. You will, however, see only those systems that are
based on standards included in your license.

 You will be able to open any and all stored plots in the project, and all original data will be displayed in
the plots. If you refresh a plot (or make a change that causes an automatic refresh), however, the new plot
will not include any items that are based on standards not included in your license. You will see a
warning prior to the plot being redrawn.

Features Summary 2
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2.2  Derating Standards

The following derating standards are available for use in Lambda Predict:

 NAVSEA-TE000-AB-GTP-010: Parts Derating Requirements and Application Manual for Navy
Electronic Equipment (Rev. 1 with Change A), issued by the Naval Sea Systems Command in March
1991. This standard provides derating curves for ten electrical and electronic parts.

 MIL-STD-975M: NASA Standard Electrical, Electronic, and Electromechanical (EEE) Parts List,
issued by the U.S. National Aeronautics and Space Administration in 1994. This standard provides part
selection information and derating curves for electronic parts, materials and processes for space and
launch vehicles.

 MIL-STD-1547A: Electronic Parts, Materials, and Processes for Space and Launch Vehicles, issued by
the U.S. Department of Defense in November 1998. This standard provides part selection information
and derating curves for electrical, electronic and electromechanical parts used in the design and
construction of space flight hardware in space missions as well as essential ground support equipment
(GSE).

 Naval Air System Command AS-4613: General Specification for Application and Derating
Requirements for Electronic Components, issued by the U.S. Naval Air Systems Command in 1976. This
standard provides derating curves for three classes of electronic and electromechanical parts.

 ECSS-Q-30-11-A: Space Product Assurance, issued by the European Cooperation for Space
Standardization in April, 2006. This standard provides derating requirements for electronic, electrical
and electromechanical components used for space projects and applications.

For MIL-HDBK-217F or Bellcore/Telcordia systems in Lambda Predict, you can choose a derating standard
to use for the components of the system. Once a standard has been chosen, each component indicates if its
current stress levels are within the derating standard or not. Graphical displays of the situation are available
for ease in identifying problem areas. Parametric displays are also available to show the temperature vs.
stress situation of the component.

You can also define your own derating requirements, giving you the ability to combine any of the published
standards with your own.

2.3  Work with Multiple Predictions and Systems Simultaneously

The first step to perform a standards based reliability prediction analysis in Lambda Predict is to create a
database file (*.lp3) and a prediction. Systems can be created within the prediction according to any of the
reliability prediction standards that are enabled for your copy of the software (i.e. MIL-HDBK-217F,
Bellcore/Telcordia or NSWC-07). The options available for defining the system configuration and
component properties, as well as the analysis results, will vary depending on the standard that you are using.

Each file can contain multiple predictions (with the failure rate and other metrics calculated at the prediction
level based on the calculations for the systems it contains). You can work with multiple predictions
simultaneously, which provides an easy way to copy information among predictions or compare alternate
designs.

2.4  Calculated Results

Lambda Predict provides several ways to obtain calculated results for your analyses. Failure Rates, MTBFs,
Pi Factors and other metrics can be displayed in the System Hierarchy and Properties panels. Results are
available for individual components, higher level assemblies and systems.
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2.5  Graphical Plots/Charts

Lambda Predict provides a complete array of plots/charts to demonstrate your analysis graphically. This
includes plots for Failure Rate, MTBF, Mission Time and Unavailability (displayed independently and
versus Temperature, Environment, Stress, etc.).

You can customize your plots using the Plot Setup. The Plot Setup gives you full control over the settings
used both for individual plots and as default settings for all new plots.

2.6  Reports

Lambda Predict gives you the ability to generate template-based reports for your predictions. Reports are
generated in Microsoft Excel®, which provides maximum flexibility for additional post-generation
customization and distribution. You can customize the appearance of all predefined reports and also build
and manage your own custom report templates to include information about Failure Rates, Application
Parameters, Physical Parameters, Pi Factors, etc.

2.7  Flexible Data Management (Import and Export)

Lambda Predict's flexible data management options include the ability to import and export data from other
Lambda Predict 3 files as well as importing from Excel spreadsheets and delimited text files.

2.8  Libraries

Lambda Predict's libraries provide pre-configured components that you can copy and paste into your project.
You can create your own libraries, use the libraries included with the application or take advantage of the
collection of parts libraries available on ReliaSoft’s Web portal at http://www.PartLibraries.org, which
contains the data found in the installed part libraries and will also be continually updated with the most
current commercial components.

2.9  Allocations

The Allocations utility provides five allocation models that can be used to logically apportion the product
design reliability into lower level design criteria such that the cumulative reliability still meets the
requirements. The available models are: Equal Allocation, AGREE Allocation, Feasibility of Objective
Allocation, ARINC Apportionment Technique and Repairable Systems Allocation.

2.10  Intuitive, Flexible and Customizable Work Environment

The powerful and flexible interface allows you to keep all related analyses and information together in a
single database file. Using the “Project Explorer” approach that is employed in many of ReliaSoft’s other
applications (e.g. Weibull++, ALTA and BlockSim, among others), Lambda Predict provides an intuitive,
hierarchical (tree) structure to allow you to view and manage maintain multiple predictions, plots and
attachments within a project.

Lambda Predict's User Setup allows you to configure the work environment and analysis settings to meet
your particular needs. This includes the parameters and results displayed in the System Hierarchy panel, the
displayed math precision, etc.
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3.1  Starting Lambda Predict

To start Lambda Predict, from Start select All Programs, ReliaSoft Office and then Lambda Predict 3.

3.2  Multiple Document Interface and Data Folio

Lambda Predict's Multiple Document Interface (MDI) is the workspace within which you can create, edit
and manage your standards based reliability prediction analyses. The MDI remains open until you close the
program and closing the MDI terminates the program. The next figure displays the Lambda Predict MDI and
its default components.

The Project Explorer panel presents all of the items associated with the current project in a hierarchical tree
structure. The project name is displayed at the top of the tree structure. The folders that contain the
predictions, stored plots and attachments are displayed below the project name.

The System Hierarchy panel displays the system hierarchy, which includes all systems, blocks and
components that have been defined in the prediction.

The Properties panel allows you to view and edit the properties of the system, block or component that is
currently selected in the System Hierarchy panel.

3.3  Getting Help in the Lambda Predict Environment

ReliaSoft's Lambda Predict includes complete on-line help documentation. This help can be obtained at any
time by pressing F1 or by choosing Help > Contents.

First Steps 3
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3.4  First Steps Example

This example has been designed to familiarize you with Lambda Predict’s interface and tools. It uses a
sample data set for demonstration purposes that is not intended to be realistic. You will:

 Create a new database/project, including a new prediction with a MIL-HDBK-217F system.

 Build a hierarchical system configuration using the blocks and components that are available for the
MIL-HDBK-217F standard.

 Modify general properties of the system, block and components.

 Plot the data for the system.

3.4.1  Create a New Database and Project

The first step in performing a standards based reliability prediction analysis in Lambda Predict is to create a
database file (*.lp3) with an associated project and the next step is to add a prediction. The prediction can
contain one or more individual systems, analyzed according to one of the reliability prediction standards
supported by Lambda Predict (i.e. MIL-HDBK-217F, Bellcore TR-332 Issue 6, Telcordia SR-332 Issue 1,
Telcordia SR-332 Issue 2 or NSWC-07). Although the basic procedures are the same, the options available
for defining the system configuration and component properties, as well as the analysis results, will vary
depending on the standard that you are using.

At this time, we assume that you have started the application.

 Create a new Lambda Predict database by choosing File > New Database or by clicking the New

Database icon.1

 In the Create New Database window, browse to the desired location for the database, type the name
QuickStart and click Save to continue.

 In the Edit Prediction Properties window that appears next, do the following:

 In the Name field, type First Steps.

 Select the Select Standards option. In the list that becomes available, select MIL-HDBK-217F and
click OK. The Edit Prediction Properties window will look like the one shown next.

1. If you have just started Lambda Predict and the initial window is displaying, you can click Create New Database.
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 Click OK to create the new prediction and system. The MDI will look like the one shown next.

3.4.2  A Note about Terminology

When working in the System Hierarchy panel in Lambda Predict, you should be aware of how the following
terms are used:

 Systems are analyzed according to one of the reliability prediction standards supported by Lambda
Predict (e.g. MIL-HDBK-217F, Telcordia SR-332 Issue 2, etc.). Such systems are made up of blocks and
components.

 Lambda Predict also offers a Generic system, which has no analysis properties of its own and cannot
have blocks or components. Generic systems can only contain other systems, and they serve purely
as a way to roll up failure rates from their subsystems.

A system is always the first item added to a prediction.

 A block represents a group of blocks and/or components in the next lower level of the system
configuration. Lambda Predict uses the block properties (based on the applicable reliability prediction
standard) together with the calculations for the blocks and components in the next lower level to
determine the failure rate, MTBF and other results for the subassembly that the block represents.

 A component represents an individual item (such as a fuse, capacitor, valve, spring, etc.) with properties
based on the applicable reliability prediction standard that are used to calculate the item's failure rate,
MTBF and other results. Components always represent the lowest level within a branch of the hierarchy.
In other words, you cannot place another block or component below an existing component.

On the System Hierarchy menu, Lambda Predict uses the following terminology:

 Top Level Item: When you add a Top Level Item, you add a system to the prediction. The Generic
system is always available; the availability of the other system types depends on the standards that you
purchased.

Note: It is recommended that you always use a block as the parent of components, rather than adding
components directly to a system. This allows you to more accurately represent connections (if applicable, as in
MIL-HDBK-217F systems) and facilitates more advanced analysis.
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 Same Level Item: When you add a Same Level Item, you add an item at the same level of the system
hierarchy as that of the item you currently have selected:

 If a system is selected, select Add Same Level Item to add a new system as the current system.

 If a block or component is selected, select Add Same Level Item to add a component, block, or
linked block to the system.

 Next Level Item: When you add a Next Level Item, you add an item immediately subordinate to the
currently selected item:

 If a generic system is selected, select a Add Next Level Item to add a dependent system to the
generic system.

 If any other system type, a block or component is selected, select Add Next Level Item to add a
component, block, or linked block to the system.

3.4.3  Build the System Configuration

You can build the hierarchical system configuration using the blocks and components that are available for
the current standard. In general, blocks are used to represent groups of items within a multilevel system
configuration (e.g. subsystems, subassemblies, etc.). They can have components and other blocks below
them in the hierarchy and Lambda Predict uses the block properties (based on the applicable reliability
prediction standard) together with the calculations for the blocks and components in the next lower level to
determine the failure rate, MTBF and other results for the subassembly that the block represents.
Components (e.g. fuses, switches, resistors, pumps) have pre-defined properties based on the selected
standard and must be placed at the lowest level within a branch of the hierarchy.

For this example, you will be defining the following configuration (a subassembly that consists of three
capacitors):

 Block 10

 Capacitor 10.1

 Capacitor 10.2

 Capacitor 10.3
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 To add a block to the system, click the MIL-HDBK-217F system in the System Hierarchy panel (center)
and choose System Hierarchy > Add Next Level Item > Block. The block will be added to the system,
as shown next.

 Now add components to the block. To do this, right-click the block and choose Add Next Level Item >
Component/Block from the shortcut menu. The Select a Component window will appear, as shown
next.

 You can either double-click Capacitor in the list or click it once and click OK to add it to the block.

 Add another capacitor by copying the first one you added and pasting it to the block. To do this, right-
click the capacitor and select Copy from the shortcut menu. Next, right-click the block and select Paste
As Next Level from the shortcut menu. The pasted capacitor will appear on the level beneath the block,
along with the original capacitor.

Note: The simplest way to add 3 capacitors to the system at one time is to type 3 in the Number of Duplicate
Items field and click OK. However, to demonstrate some of the other techniques that you can use in Lambda
Predict when building systems, this example uses several other methods to add the capacitors to the system.
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 To add the third capacitor, right-click the first capacitor and select Copy from the shortcut menu. Next,
right-click the original capacitor and select Paste As Same Level from the shortcut menu.

 Once you have finished adding the three components, the MDI will look like the one shown next.

3.4.4  Explore Additional Views

By default, the first time you open Lambda Predict, the Tree view is used in the Properties panel. The Tree
view organizes item properties into a hierarchical structure. The appearance of the Tree view will vary
depending on the type of record that is currently selected in the System Hierarchy panel and the type of
analysis that is being performed.

Lambda Predict also includes three additional view types: Pi Factor, Tab and Grid.

 The Pi Factor view displays the item properties based on the Pi factor(s) that they contribute to. Pi
factors account for the effects of various factors such as environment, stress, quality, etc. on the part's
expected failure rate, which is the product of the part’s base failure rate and each Pi factor (or
acceleration factor) that quantifies the effect of a particular factor's variance from baseline. This means
that all Pi factors for a part operating under baseline conditions will be equal to 1, while if the part is
operating under conditions other than baseline, one or more Pi factors will greater than or less than 1.

 The Tab view displays the item properties grouped on separate tabs, rather than in a hierarchical tree
structure.

 The Grid view displays each item property as a column.2

2. By default, only the “general” properties are displayed in the Grid view. To change the columns that are displayed
and/or the order in which they are displayed, right-click in any column header and choose Customize. 
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To change the Properties panel view, choose View > Select Properties View and then choose the desired
view or click the appropriate icon in the View toolbar.

The properties that are shown and the way in which they are displayed and/or edited will vary depending on
the view that you are using.

In all views, the following tips apply:

 Fields that cannot be edited are displayed with a grey background.

 In the Tab and Grid views, when you point to a numeric parameter, a tooltip will appear that displays the
maximum and minimum allowable values for that field. In the Tree and Pi Factor views, the tooltip
displays when you click inside the field.

 Additional information is available for certain parameters. These parameters have an Information icon
that you can click to display the information in a tooltip.

For example, to view the First Steps data in the Pi Factor view, with the third capacitor selected, do the
following:

 Choose View > Select Properties View and then choose Pi Factor View. The MDI will look like the
following.

 You can take some time to look the other views, if desired. When you are finished, return to the Tree
view.

Tree View

Pi Factor View

Tab View

Grid View
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3.4.5  Modify General Properties of the System, Block and Components

You can use the Properties panel on the right side of the MDI to view and modify the properties of the
system, block or component that is currently selected.

Before modifying the properties choose View > Wrap Text. The enables Lambda Predict’s text wrap
functionality, which allows row heights to be expanded and text wrapped to fit within the viewable area
where necessary.

 Select the system in the System Hierarchy panel (called “MIL-HDBK-217F”) to display the properties in
the Properties panel.

 Notice that some of the fields have already been filled out for the system by default. You can change any
of these properties but for this example, we will use the defaults. Enter the following additional
information into the corresponding field for the system.

 Press ENTER or click outside the Description field to accept your input.

 The Properties panel for the system will look like the one shown next.

 Next, select the block that you added to the system. In the General properties area of the Properties
panel, enter the following information:

Description: ABC Computer System Model ABC/XT
Pentium-based Microcomputer

Name: Block 10

Part Number: PS1

Analyst: A. Designer

Description: Power Supply 110/240 V AC Input, 5V/12V DC Output
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 The Properties panel for the block (now named “Block 10”) will look like the one shown next.

 Scroll down through the Properties panel and notice the Application properties. The Application
properties contain some of the MIL-217 parameters required for the failure rate calculation, including
parameters that specify information about the environment in which the item is being used. Notice that
the application parameters are already set for the block. For this example, we will use the default
settings.

 Now select the first capacitor in the System Hierarchy panel and enter the following information into the
General properties area of the Properties panel.

 The Properties panel for the first capacitor (Capacitor 10.1) will look like the one shown next.

 You can view the physical parameters for the capacitor by scrolling down through the Properties panel to
the Physical properties section. The Physical properties include parameters that specify information
about the component itself, which are also required for the failure rate calculation. Notice that the
physical parameters are already set for the capacitor. You can also scroll down to the Application
properties section to view those parameters. For this example, we will use the default settings for all
physical and application parameters.

Name: Capacitor 10.1

Part Number: CK 33PF

Description: CAPACITOR, FIXED, CK, 33PF
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You can use the Grid view to quickly enter information for multiple items at the same time.

 In the System Hierarchy panel, select Block 10. Choose View > Select Properties View and then choose
Grid View. (Note that only the immediately selected item in the System Hierarchy panel and its children
are shown in the Grid view.)

 Now enter the following information for the second and third capacitors.

 After entering the data, return to the Tree View.

 You can take the time to view the default physical and application parameters for these two capacitors, if
desired.

Looking at the System Hierarchy panel will show that the value for the system in the Failure Rate(t) column
is 0.0310 FPMH. In other words, at the default mission time (24 hours, specified in the Mission Time field
in the system’s general properties), the expected failure rate is 0.0310 failures per million hours.

3.4.6  Plot the System Data

 Select the system in the System Hierarchy panel and then choose Tools > Plot or click the Plot icon.

The Plot window will appear.

 By default, the last plot type that was selected will automatically be plotted when you open the Plot
window. For this example, choose Failure Rate vs. Temperature from the Plot Type list in the Control
Panel on the right side of the Plot window. If the Auto Refresh option is not selected, you will have to
click the Refresh icon to refresh the plot with the new plot type.

 In the Range area, enter 0 for the minimum temperature (Min), 100 for the maximum temperature
(Max) and 20 for the number of intervals (Steps). Also make sure that the Include Blocks option is
selected and that the Include Top Level and Include Components options are not selected.

Capacitor 2

Name: Capacitor 10.2

Part Number: CQ-10NF

Description: CAPACITOR, FIXED, POLYESTER, 10nF

Comments: These capacitors are rated at 24 Volts and being used at 
20V. If this causes a problem upgrade to 40V devices.

Capacitor 3

Name: Capacitor 10.3

Part Number: 0805 COG

Description: CAPACITOR, FIXED, CERAMIC CHIP, 220 pF
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The Failure Rate vs. Temperature plot is shown next.

The data in the plot are based on the system that you selected in the System Hierarchy panel for use as the
top level item. Systems or blocks can be used as top level items.

You can generate other plots by choosing different types in the Plot Type list. Remember that if the Auto
Refresh option is not selected, then you will have to click the Refresh icon to refresh the plot with the new
plot type.

 Click the Save icon to save the plot in the current project.

 You will be prompted to enter a name for the plot so that it can be saved to the project's Stored Plots
folder in the Project Explorer. Accept the default name, First Steps - Plot 1, and click OK.

 Close the plot by clicking the Close (x) button in the upper right corner of the window.

This feature allows you to save the plot together with the project file so you can access it again (with the
same data set and settings) in the future. If you do not save the plot, you can re-create it in the future but you
will need to make all selections again.

Lambda Predict also allows you to create plots from within the Project Explorer by choosing Project > Add
Plot or right-clicking the project's Stored Plots folder in the Project Explorer and choosing Add Plot on the
shortcut menu. Plots created in this way can have multiple top level items. Closing a plot created in this way
causes Lambda Predict to prompt you for a name for the plot so that it can be saved to the project's Stored
Plots folder in the Project Explorer.

For more information about plots, refer to Example 8 on page 53.
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3.4.7  Close the Database

You have completed the First Steps example. You can now close the Lambda Predict database. Lambda
Predict saves each change to the database as it is made, so there is no need to save prior to closing the file.

If you do not close the database, it will be closed automatically when you create a new database for the next
example or open an existing database.

 To close the database, choose File > Close Database.

 Proceed to the Step-by-Step Examples in Chapter 4.
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4.1  List of Examples

This chapter provides the following step-by-step examples, designed to introduce you to the features of the
Lambda Predict software:

 Example 1 - Working with Component Properties - page 19

 Example 2 - Working with Parts Outside the Standard - page 26

 Example 3 - Using Libraries - page 32

 Example 4 - Importing Data From Excel - page 36

 Example 5 - Further Analysis - page 42

 Example 6 - Advanced Analysis: Allocation - page 45

 Example 7 - Advanced Analysis: Derating - page 50

 Example 8 - Information Reporting - page 53

4.2  Example 1 - Working with Component Properties

This example will demonstrate more advanced features of working with component properties in Lambda
Predict. It uses a sample data set for demonstration purposes that is not intended to be realistic. You will:

 Create a new prediction and copy a system from an existing prediction.

 Work with default component properties.

 Change component properties.

 Reset the default component properties.

 Change block properties.

 Change connection types for your analysis, including changing a custom connection type.

4.2.1  Opening a Database

For this example, you will be working with the QuickStart.lp3 database that you created in the First Steps
example in Chapter 3.

 Open the database by choosing File > Open Database or by clicking the Open Database icon.

Step-by-Step Examples 4
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 In the Open Database window, browse to the location of the database, click the QuickStart.lp3 file and
click Open to continue.

4.2.2  Create a New Prediction

For this example, you will create a new prediction without any standards initially selected.

 To create a new prediction, choose Project > Add Prediction or right-click the Predictions folder in the
Project Explorer and choose Add Prediction from the shortcut menu.

 In the Edit Prediction Properties window that appears, do the following:

 In the Name field, type Working with Properties. The Edit Prediction Properties window will look
like the one shown next.

 Click OK to create the new prediction. The MDI will look like the one shown next.
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 In the Project Explorer, double-click the First Steps prediction to open it. The MDI will look like the one
shown next.

 In the System Hierarchy panel, click the MIL-HDBK-217F system and choose Edit > Copy. You can
also click the Copy icon or right-click the system and choose Copy from the shortcut menu.

 To bring the focus to the Working with Properties prediction, click the Working with Properties tab.

 To add the copied system to the prediction, you can click in the System Hierarchy panel and choose Edit
> Paste As Same Level or click the Paste As Same Level icon or right-click in the System Hierarchy
panel and select Paste As Same Level from the shortcut menu.

The pasted system, its block and its components will appear in the System Hierarchy panel. The MDI
will look like the one shown next.
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4.2.3  Changing and Resetting Properties

Each block or component that you add to a system has default properties that are pre-defined based on the
type of analysis that you are working with (i.e. MIL-HDBK-217, Bellcore, etc.). If you have changed the
settings for an item, you can change them back to the default settings.

 In the System Hierarchy panel, click the capacitor named Capacitor 10.3. Note that the Properties panel
displays its properties.

 In the Properties panel, in the capacitor’s Application properties, change the value of the Voltage Stress
field to 0.5.

 Press ENTER or click outside the Voltage Stress field to accept your input. Note that in the System
Hierarchy panel, the failure rate of the capacitor has changed. In addition, the failure rates of the block
and the system have changed.

 Click Capacitor 10.3 and then choose Tools > Reset Component to Default. A dialog box like the one
shown next will appear, asking you to confirm that you want to set the values of the selected component
back to the default values.

 Click Yes. The failure rates of the capacitors now matches the other capacitors.

4.2.4  Changing the Failure Rate by Changing the Connection Type

Notice that the failure rates displayed for the components in the block do not add up to the failure rate
displayed for the block. This is because for MIL-HDBK-217F systems, Lambda Predict takes the
connections between components into account when calculating the block’s failure rate.

 For example, add a new block to the system and change its name to Block 20, then add an alpha-numeric
display component and a microprocessor, digital component to the block, as shown next.

Note: When using the Select a Component window, you can select multiple items by clicking the first item and
then pressing CTRL and clicking additional items or by clicking the first item and then pressing SHIFT and
clicking another item to select all items between and including the two.



4.2  Example 1 - Working with Component Properties

 Lambda Predict 3 Training Guide 23

Note that the failure rate of the alphanumeric display (0.0017 FPHM) and the failure rate of the
microprocessor, digital (0.3123 FPMH) add up to 0.3140 FPHM, while the failure rate of the block is
0.3162 FPMH. For each component in a block, the connection type failure rate per pin is multiplied by
the value in the Number of Pins field in the component's physical properties. The resulting value is
added into the parent block's failure rate along with the component's failure rate.

In MIL-HDBK-217F analyses, you also have the ability to define your own connection types. The
connections you create will be saved in the database and will be available to you at a later date, or to other
users who open the database.

For this example, you have changed your connection method to use a method that is not defined elsewhere.
Based on your research, you know that the base failure rate of your method is 0.0049 FPMH per pin.

 Choose Tools > Custom Connections. The Custom Connections window will appear. You will see that
two additional connection types have been pre-defined.

 In the Description field for User Defined 3, type New Connection. Enter 0.0049 in the Base Rate field
and click OK.

 In the System Hierarchy panel, click Block 20 and change its connection type to User defined 3 (New
Connection: 0.0049) in the Application properties. Click any other block or component in the System
Hierarchy panel to refresh. Note that the Failure Rate of Block 20 is now 0.4757, as shown next.

This shows that since there is 1 pin for the alphanumeric display and 32 pins for the digital
microprocessor that the connection failure rate for the block is (1 pin + 32 pins) x (0.0049 FMPH/pin) =
0.1617 FMPH, which is what is added to the components failure rates to obtain the block failure rate.
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4.2.5  Setting the Non-Operational Failure Rate

For blocks and/or components in MIL-HDBK-217F systems, you can specify separate parameters to be used
during a non-operational phase. For example, an item in long-term storage may be in a different
environment, at different temperatures, etc, from its normal operating conditions; such changes will affect its
failure rate.

 In the System Hierarchy panel, click Block 20 and then choose Tools > Non Operational. The Non
Operational window will appear.

 In the Environment field, choose Ground, Fixed and enter 10 in the Temperature field.

 Select the Update Children check box and then click OK. This updates the non-operational parameters
for the sub-items associated with the block so that they also use the environment, temperature and MTB
(Mean Time Between) power cycles parameters defined in the window.

You can view other calculated results in the System Hierarchy panel. Note that to view the non-operational
failure rate, you must first enable it on the System Hierarchy page of the User Setup window.

 Choose File > User Setup. The User Setup window displays.

 In the navigation area on the left of the User Setup window, click System Hierarchy. The System
Hierarchy page displays.
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 On the System Hierarchy panel, select the Non-Operational Failure Rate option, then click OK.

 In the System Hierarchy panel, click the MIL-HDBK-217F system and choose View > Splitter Right.
You can also click the Splitter Right icon.

The MDI will look like the one shown next.

Notice the additional columns that appear. In particular, the following two columns present some useful
information:

 MTBF displays the mean time between failures, expressed in hours.

 Contribution displays the contribution made by the item to the failure rate of its direct parent. For

example, Capacitor 10.3 contributes 32.89% of the failure rate of its direct parent, Block 10.1.

 Scroll to the right and notice that the non-operational failure rate for Block 20 is 0.0073.

 Right-click the Status Flag cell for Block 20 and choose Complete. This adds a green flag to the cell,

which indicates that you have completed your work with Block 20.2

 You can take the time to view the other calculated results, if desired.

 To return the System Hierarchy to the default look, choose View > Splitter Center. You can also click
the Splitter Center icon.

Note: For blocks in MIL-HDBK-217F systems, Lambda Predict takes into account the connections between
components when calculating the contributions so the contributions made by items may not add up to 1.

1. The MTBF and Contribution columns display by default. You can view other results as well. For more information
about how to view them, refer to the Lambda Predict 3 User’s Guide.
2. The Status Flag is displayed in the System Hierarchy panel only and does not affect reports. You can use it to provide
a visual indication of the status of a given item.



4  Step-by-Step Examples

26 http://Predict.ReliaSoft.com

4.2.6  Close the Database

You have completed this example. You can now close the Lambda Predict database. Lambda Predict saves
each change to the database as it is made, so there is no need to save prior to closing the file.

 To close the database, choose File > Close Database.3

4.3  Example 2 - Working with Parts Outside the Standard

There may be times when you are modeling a system using a particular reliability prediction standard and
you find that a given component or subsystem either cannot or should not be modeled using that standard.
Consider, for example, a transducer assembly that includes both mechanical and electronic components in
the following configuration:

 Transducer Assembly

 Spring

 Sensing Elements

 Primary Coil

 Secondary Coil

 Secondary Coil

This example will guide you through the following ways to combine results from different sources and
standards to model such a configuration. You will:

 Create a new database.

 Import a prediction from an existing database.

 Use an external component to model the data for an item.

 Use a generic system to encompass data from two subsystems using separate reliability prediction
standards.

 Use a linked block to incorporate data from a system that uses a different reliability prediction standard.

4.3.1  Create a New Database/Project

 Create a new database file by choosing File > New Database or clicking the New Database icon.

 Browse to the desired location for the database, name the database Parts Outside the Standard and then
click Save.

 In the Edit Prediction Properties window that appears, click Cancel. This will create the database with
no predictions.

4.3.2  Import a New Prediction

For this example, you will import a prediction from another database. This prediction contains the blocks
and components that will be used in the following steps of this example to model the transducer assembly.

3. If you do not close the database, it will be closed automatically when you create a new database for the next example
or open an existing database.
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 Choose Project > Import Prediction(s). In the window that appears, navigate to the Transducer.lp3 file,
which is located in the Training Guide folder within your application directory (e.g. C:\Program
Files\ReliaSoft\LambdaPredict3\Training Guide) and click Open to select the file. The Import window
displays, as shown next.

 Select the Parts prediction check box and then click OK. The Parts prediction is added to your database.

 In the Project Explorer, double-click the Parts prediction to open it. The MDI will look like the one
shown next.

4.3.3  Option 1: Using an External Component

If a component or subsystem cannot be modeled using the current reliability prediction standard but you
have information about its failure rate, one way to incorporate that information is to represent the component
or subsystem with an external component.

To practice this approach, you will first create another prediction.

 Choose Project > Add Prediction or right-click the project's Predictions folder in the Project Explorer
and choose Add Prediction from the shortcut menu.
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 In the Edit Prediction Properties window that appears, do the following:

 In the Name field, type External Component.

 Select the Select Standards option. In the list that becomes available, select NSWC-07 and click
OK. The Edit Prediction Properties window will look like the one shown next.

 Click OK to create the new prediction and system. The MDI will look like the one shown next.

 Click the NSWC-07 system and then, in the Properties panel, in the Name field, change the name to
Transducer Assembly. Press ENTER or click outside the Name field to save the change.

 Return to the Parts prediction by clicking the tab or double-clicking the name in the Project Explorer.

 In the System Hierarchy panel, under the Transducer Assembly Mechanical Components system,
right-click the Transducer Mechanical Components block and click Copy on the shortcut menu that
appears.

 Return to the External Component prediction. In the System Hierarchy panel, right-click the
Transducer Assembly system and choose Paste As Next Level on the shortcut menu that appears.

You can now add an external component to the system, which will represent the failure rate of the electronic
components that cannot be analyzed with the NSWC standard.

 Right-click the Transducer Mechanical Components block and choose Add Next Level Item >
Component/Block from the shortcut menu.

 In the Select a Component window, click the External component and then click OK.
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 Now select the external component in the System Hierarchy panel and enter the following information
into the Properties panel.

From prior testing, you know that the sensing elements have a failure rate of 0.0017 FPMH.

 Click the External Base Failure Rate (FMPH) field and type 0.0017 and then press ENTER or click
outside the field. The MDI will look like the one shown next.

Note that the failure rate of the system, as shown in the Failure Rate(t) column, is 0.5449 FMPH.

4.3.4  Option 2: Using a Generic System

If you are able to model the component or subsystem using a different reliability prediction standard and the
resulting failure rates can be combined by simple summation (i.e. a series configuration is assumed and that
subsystems are not physically connected or the failure rate due to connections is considered negligible), then

you can model the main system using a “Generic” system.4

To practice this approach, you will first create another prediction.

 Choose Project > Add Prediction or right-click the project’s Predictions folder in the Project Explorer
and choose Add Prediction on the shortcut menu.

 In the Edit Prediction Properties window, do the following:

 In the Name field, type Generic System.

 Select the Select Standards option. In the list that becomes available, select Generic and click OK.

Name: Sensing Elements

Part Number: X00023-2

Comments: Failure rate known from previous testing.

4.  Note that for MIL-HDBK-217F systems, Lambda Predict takes into account the fact that components are connected
to each other; the Connection Type field (in the Application properties of components and blocks) allows the user to
specify how each item is connected. Each connection type is associated with its own failure rate, and this contributes to
the failure rates of higher-level and top-level items. Thus, if the main system you are working with is a MIL-HDBK-
217F system, the generic system method given in this section may not be an appropriate choice.
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 Click OK to create the new prediction and system. The MDI will look like the one shown next.

 Return to the Parts prediction by clicking the tab or double-clicking the name in the Project Explorer.

 In the System Hierarchy panel, right-click the Transducer Assembly - Mechanical Components
system and choose Copy on the shortcut menu that appears.

 Return to the Generic System prediction.

 In the System Hierarchy panel, right-click the Generic system and choose Paste As Next Level from the
shortcut menu that appears.

 Repeat the above steps to copy the Transducer Assembly - Electronic Components system from the
Parts prediction to the Generic System prediction. The MDI will look like the one shown next, with one
NSWC-07 system and one MIL-HDBK-217F system combined together under the “Generic” system.

Note that the failure rate of the generic system is 0.5449 FMPH. This is the sum of the failure rate for the
mechanical components (as analyzed with NSWC-07) and the failure rate of the electronic components (as
analyzed with MIL-HDBK-217F).
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4.3.5  Option 3: Using a Linked Block

If you are able to model the component or subsystem using a different reliability prediction standard, another
way to model the main system is to use a linked block.

To practice this approach, you will first create another prediction.

 Create a new blank prediction, called Linked Block.

 Copy the Transducer Assembly - Mechanical Components and Transducer Assembly - Electronic
Components systems from the Parts prediction and paste them in the Linked Block prediction. (You can
select the first system and then press CTRL and select the second system so that you can copy both
systems at the same time.) The MDI will look like the one shown next.

 In the NSWC system, right-click the Transducer Mechanical Components block and choose Add
Next Level Item > Linked Block from the shortcut menu. The Link Block window appears.
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 Choose Sensing Elements as the source for the linked block and then click OK. When you are done, the
MDI will look like the one shown next.

Note that the failure rate for the NSWC system, which now represents both the mechanical components and,
by linked block, the electronic components, is 0.5449 FMPH.

 Close the database and proceed to the next example.

4.4  Example 3 - Using Libraries

Lambda Predict 3 allows you to use part libraries to store pre-configured system elements for use in your
predictions. This example will guide you through the basic techniques for adding components from a library
to your system hierarchy and adding components from your system hierarchy to a library. You will:

 Create a new database/project and prediction.

 Create a system and import components from a library to the system.

 Create a new library file and add parts to it.

4.4.1  Create a New Database/Project

 Create a new database file and its associated project by choosing File > New Database or clicking the
New Database icon.

 Browse to the desired location for the database, name the database Using Libraries and then click Save.

4.4.2  Create a New Prediction

You will be prompted to create a prediction.

 In the Edit Prediction Properties window that appears, type Using Parts from a Library in the Name
field.
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 Select the Select Standards option and choose MIL-HDBKF-217F in the drop-down list and click OK,
as shown next.

 Click OK to create the prediction and system. The MDI will look like the one shown next.
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4.4.3  Build the System Configuration

 To add a block to the system, click the system in the System Hierarchy panel and choose System
Hierarchy > Add Next Level Item > Block. The block will be added to the system.

Next, you will add three components from an existing library file to your system.

 To do this, right-click the block and choose Add Next Level Item > Existing Components from the
shortcut menu. The Add Existing Components window displays.

 Select the Library option.

 Click the Browse button to browse for the PartsCount.lplib file, which is located in the Libraries folder
within your application directory (e.g. C:\Program Files\ReliaSoft\LambdaPredict3\Libraries) and click
Open.

 In the first list box, choose Part Number and then type 132 in the text field below it.

 Click Search. This will return a list of items that match your search criteria. The following picture shows
the first three results.

 Scroll through the list until you locate the 132 Capac., Fxd CKR G_B capacitor and then select its
check box.

 Click Add to add the capacitor to your system.
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You can refine your search by specifying multiple criteria to reduce the number of matches returned.

 In the first list box, choose Description and then type Socket in the text field below it.

 Choose And in the field next to the text field.

 In the second list box, choose Part Number and then type G_B in the text field below it.

 Click Search. A list of items that match your search criteria display.

 Click the check box next to the 188 Connector G_B socket connector and then click Add to add it to
your system.

Lambda Predict can also search for partial matches and the search is not case-sensitive.

 In the first list box, choose Part Number and then type 62 in the text field below it.

 Choose And in the field next to the text field.

 In the second list box, choose Part Number and then type g_b in the text field below it.

 Click Search. A list of items that match your search criteria display. You will notice that “62” is part of
both part numbers and “G_B” was returned as a match even though you typed the criteria with lowercase
letters.

 Click the check box next to the 062 Diode, Low Freq. G_B low frequency diode and then click Add to
add it to your system.

 Click Close to close the window. The MDI will look like the one shown next.
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4.4.4  Add Parts to a Library File

Based on your work, you know that you will be using these components again in other projects. You also
know that you want to keep a clean copy of the library file that you installed with Lambda Predict as a
backup. Therefore, you decide to create your own personalized library file that you can share with
coworkers.

You will now add these parts to a new library file.

 Click the MIL-HDBK-217F system and then choose System Hierarchy > Add to Library. The Add To
Library window displays.

 Click Browse to display the Open Library window.

 In the File name field, type My Library and then click Save. You will return to the Add to the Library
window.

 Click OK. The parts are added to the library file. (To confirm this, you can go back to the Add Existing
Components window, browse for the library file you created, and then search for the components you
just exported.)

 When you are finished, close the database and proceed to the next example.

4.5  Example 4 - Importing Data From Excel

This example will guide you through the basic techniques for importing data from a Bill of Materials (BOM) 
into Lambda Predict. You will:

 Create a new database/project and prediction.

 Import data from a BOM (provided) as part of creating the prediction.

4.5.1  Create a New Database/Project

 Create a new database file and its associated project by choosing File > New Database or clicking the
New Database icon.

 Browse to the desired location for the database, name the database Import BOM and then click Save.

Important: ReliaSoft recommends that you do not add your own parts to the library files shipped with the
software as any changes you make will be lost if you reinstall the software.
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4.5.2  Create a New Prediction

You will be prompted to create a prediction.

 In the Edit Prediction Properties window that appears, type Demand Response Thermostat in the
Name field.

 Select the Import BOM option and choose Telcordia SR-332 Issue 2 in the drop-down list that
becomes available, as shown next.

 Click OK to create the prediction.

4.5.3  Import Data from the BOM

Because you specified that the prediction would contain data imported from a BOM, the Import Wizard will
appear automatically once the prediction and top-level Telcordia SR-332 Issue 2 system have been created.

In the Import Wizard, do the following:

 Choose Excel in the Format field.

 Click the Browse button to browse for the DR Thermostat BOM.xls file, which is located in the Training
Guide folder within your application directory (e.g. C:\Program Files\ReliaSoft\LambdaPredict3
\Training Guide) and click Open to select the file for use in the import.

 Choose Sheet1 in the Worksheet field.

 In the Import Mapping field, click the Add Import Mapping icon.

4.5.3.1  Create a New Import Mapping Template

Import mapping templates specify the kinds of information contained in the columns in an Excel file or a
delimited text file so that the information can be imported into the correct parameter fields within Lambda
Predict. Each import mapping template is associated with a particular standard. When you add a new
template, the Import Mapping Templates window is automatically set up to work on a new template for the
selected standard (which you have already specified in the Edit Prediction Properties window).
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For your reference, the first few rows of the DR Thermostat BOM.xls file are shown next.

 In the Available Fields area of the Import Mapping Templates window, click the + beside General to
show all of the general fields that are available in Lambda Predict.

 The first column in the Excel spreadsheet is titled “Level.” Click the Level field and then click the
Include icon (>) or simply double-click the Level field to move it from the Available Fields area to the
Selected Fields area, as shown next. 

 Click the Name field in the Available Fields area and then click the Include icon (>) or simply double-
click the Name field to move it from the Available Fields area to the Selected Fields area.

 Continue to add fields to the Selected Fields area in this manner, in the order shown in the Excel
spreadsheet. You will find the Type, Technology, Number of Pins and Number of Contact Pairs fields
under the Physical heading. All other fields are located under the General heading.

Note: You will notice that the Category field is already included in the Selected Fields area in the first position, as
if it were the first field in the Excel spreadsheet. We will change the field order to reflect its actual position in the
Excel spreadsheet once all relevant fields have been added.
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 Once you have added all of the fields, click the Category field in the Selected Fields area and use the
Down Arrow to move the field below the Part Number field, or simply drag the Category field to the
desired position, as shown next.

 Click the Save icon and save the import mapping template that you have created as DR Thermostat
Mapping.lp3im. Save it in the default location.

 Close the Import Mapping Template window. You will return to the Import Wizard.

 Choose the DR Thermostat Mapping template in the Import Mapping field, if it is not already
selected.

 Enter 2 in the Starting Row field, as shown next, and click Next.
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 In the Preview that is displayed, make sure that the column headings and data displayed are correct (i.e.
that they match the Excel file), as shown next.

 If you find errors, click Back to return to the Import Parameters page of the Import Wizard and edit your
choices and/or import mapping template as necessary. (To edit the mapping you would click the Edit
Import Mapping icon.

In the Import Mapping Template window, you would make the necessary changes. When you are done,
you would save the mapping template and continue with the remaining steps.) If everything is correct,
click Finish. The Bill of Materials data will be imported to the Telcordia SR-332 Issue 2 system.
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4.5.4  Specify the Failure Rate for the External Component

You will notice that the BOM did not contain failure rate information for the external component (called
Passive Infrared Sensor and circled in the System Hierarchy panel shown next).

For this example, we will assume that the base failure rate for a passive infrared sensor of this sort is known
to be 127 FITS.

 Click the external component in the System Hierarchy panel.

 In the Physical properties, enter 127 in the External Base Failure Rate (FIT) field, then press ENTER
or click outside the field to accept the input.

You will see that the system failure rate changes to reflect the new information.

4.5.5  View the Failure Rate Upper Bound

Lambda Predict offers upper confidence bounds on failure rates in Telcordia SR-332 Issue 2 systems. To
display this information, do the following:

 Choose File > User Setup.

 In the navigation area on the left of the User Setup window, click System Hierarchy.
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 On the System Hierarchy panel, select the Failure Rate Upper Bound(t=inf) option, then click OK.

 In the System Hierarchy, scroll to the right until the Failure Rate Upper Bound column is visible.

You can see that the system has an expected failure rate of 6194.7844 FITS, with a 90% upper bound of
7359.4555 FITS. This bound is calculated based on the expected failure rate (rolled up from the
components’ failure rates), the standard deviation (rolled up from the standard deviations of the
components) and the Confidence Level for Upper Bound (%) field in the Application properties at the
system level. The bound calculation will take into consideration the base failure rate for any external
components but assumes that external components’ failure rates have no associated variability.

 When you are finished, close the database and proceed to the next example.

4.6  Example 5 - Further Analysis

This example will show you how to import a prediction from another database and how to perform “what-if”
analyses for comparison purposes. For example, you may wish to change one parameter (such as
temperature, environment, etc.) to see what impact it will have on the predicted failure rate. You will:

 Import a prediction from an existing database.

 Duplicate the system and change the temperature parameters to compare the results under the different
conditions.

 Change a system configuration from series to parallel (i.e. use redundancy).

4.6.1  Create a New Database

 Create a new database file by choosing File > New Database or clicking the New Database icon.

 Browse to the desired location for the database, name the database Further Analysis and then click
Save. You will be prompted to create a prediction.

 In the Edit Prediction Properties window that appears, click Cancel. This will create the database with
no predictions.

4.6.2  Import a New Prediction

For this example, you will import a prediction and all of its systems, blocks and components from another
database.

 Choose Project > Import Prediction(s). In the window that appears, navigate to the Power Supply.lp3
file, which is located in the Training Guide folder within your application directory (e.g. C:\Program
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Files\ReliaSoft\LambdaPredict3\Training Guide) and click Open to select the file. The Import window
displays, as shown next.

 Select the Power Supply Prediction check box and then click OK. The Power Supply prediction is
added to your database.

 Open the Power Supply prediction. The MDI will look like the one shown next.

4.6.3  Changing the Ambient Temperature

Lambda Predict’s ability to analyze multiple systems within each project allows you to perform “what-if”
analyses for comparison purposes. In this case, you will first copy the MIL-HDBK-217F system and then, in
the copy, change the ambient temperature at which it operates.

 In the System Hierarchy panel, right-click the MIL-HDBK-217F system and select Copy from the
shortcut menu.

 Right-click the MIL-HDBK-217F system and select Paste As Same Level from the shortcut menu.

 In the Properties panel, change the Name to Test Version.
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 In the System Hierarchy panel, click the 5 VDC Power Supply Module block under the Test Version
system.

 In the Properties panel, change the value of the Ambient Temperature field to 40 and press ENTER or
click outside the field to accept the change.

 In the System Hierarchy panel, click the Power XFMR transformer and, in the Properties panel, note
that its Ambient Temperature value is now also 40. This is because the 5 VDC Power Supply Module
block's Update Children property is set to True and therefore changes to the block's properties affect its
children's properties as well.

 Compare the failure rates for the Test Version system to those for the original MIL-HDBK-217F system.
Note that the increase in ambient temperature has affected the failure rates throughout the system. The
MDI will look like the one shown next.

 Return the Ambient Temperature value for the 5 VDC Power Supply Module block to 30. The failure
rates of the two systems now match.

4.6.4  Using Redundancy

You can perform other “what-if” tests as well. In this case, you will see what happens when you change a
system from a series configuration to a parallel configuration.

Note: The parent block’s Update Children and Update Temperature Mode properties determine if and how
changes to its properties will affect its children. Note that this is a one-way relationship, and that changing a child
item’s properties will not change the parent block’s properties. For more information about updating children,
refer to the Lambda Predict User’s Guide.
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 Click the MIL-HDBK-217F system. Collapse the system details by clicking the minus sign (-) beside
the system name in the System Hierarchy panel, by choosing View > Collapse or by clicking the
Collapse icon.

 Click the 5 VDC Power Supply Module block in the Test Version system. In the Properties panel,
change the value of the Redundancy field to True and change the value of the Quantity field to 2, then
press ENTER or click outside the Quantity field. The MDI will look like the one shown next.

Changing the Redundancy value to True means that the system is now in a parallel configuration. There are
two of the 5 VDC Power Supply Module blocks present, as indicated in the Quantity field, and only one of
those two blocks needs to be functioning at any given time in order for the system to be functional.

In the System Hierarchy panel, note that the value of the Failure Rate(t) field has changed to 3.6633E-05
FPMH from the original value of 0.8736 FPMH, while the value of the Failure Rate(t=INF) field remains at
0.8736 FPMH. The Failure Rate(t) field displays the expected failure rate at the mission time, t (hours),
specified in the Mission Time field in the general properties of the item (in this case, 24 hours). The Failure
Rate(t=INF) field displays the expected failure rate when the mission time is equal to infinity (i.e. the
steady-state failure rate).

 Close the database and proceed to the next example.

4.7  Example 6 - Advanced Analysis: Allocation

This example will show you how to use the Allocation utility to logically apportion the product design
reliability into lower level design criteria such that the cumulative reliability still meets the requirements.
You will:

 Import a prediction from an existing database.

 Use the AGREE and ARINC allocation models to apportion the product reliability.

 Plot the allocation results.
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4.7.1  Create a New Database and Import Two Predictions

 Create a new database file by choosing File > New Database or clicking the New Database icon.

 Browse to the desired location for the database, name the database Allocation and then click Save.

 In the Edit Prediction Properties window that appears, click Cancel. This will create the database with
no predictions.

 Choose Project > Import Prediction(s). In the window that appears, navigate to the Allocation
Example.lp3 file, which is located in the Training Guide folder within your application directory (e.g.
C:\Program Files\ReliaSoft\LambdaPredict3\Training Guide) and click Open to select the file. The
Import window displays, as shown next.

 Select the AGREE and ARINC prediction check boxes, and then click OK. The predictions are added
to your database.

 Open the ARINC prediction. The MDI will look like the one shown next.
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4.7.2  Using the EQUAL and ARINC Models

 Click the Vehicle system and choose Tools > Allocation. The Allocation window displays, with the
EQUAL allocation type displaying by default and a reliability goal of 90% at 8760 hours, as shown next.

The Equal Allocation model apportions reliability equally among all subsystems to meet a user-defined
reliability goal for a specified operation time.

 For each component, click the Include check box. Note that each component has the same calculated
reliability value, in this case 0.9740.

 In the Allocation Type field, choose ARINC.

 For each component, click the Include check box. The ARINC apportionment looks like the following.

The ARINC Allocation model assumes that all subsystems are in series and have constant failure rates. It
meets the defined reliability goal by weighing the individual failure rates of the subsystems based on the
current values of subsystem reliability.

By default, the Present Failure Rate column displays in white, which indicates that you can enter the
failure rates that determine the weighing factors. This gives you the ability to see how different failure
rates affect the system.

As an alternative, you can select the Use Failure Rate From Current Project check box in the Control
Panel to use the calculated failure rates from the prediction. In this case, the Present Failure Rate column
displays in gray, which indicates that you cannot change values in it.
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 Click the Use Failure Rate From Current Project check box. Notice how the values in the other
columns have changed, as shown next.

When using the EQUAL Allocation model, each component has an allocated failure rate of 3.0069
FMPH. Similarly, when using the ARINC Allocation model with identical present failure rates, the
allocated failure rates are also 3.0069 FMPH. However, when the ARINC Allocation model is used with
the unequal present failure rates given in the prediction, the components with the higher present failure
rates are allocated higher failure rates.

 Close the Allocation window.

4.7.3  Using the AGREE Model

 Open the AGREE prediction.

 Choose Tools > Allocation. The Allocation window displays.

 In the Allocation Type field, choose AGREE. The Allocation window looks like the one shown next.

The AGREE model takes into account additional data for each subsystem when calculating subsystem
reliability goals, including complexity and importance. The Importance Factor indicates how critical the
block is to the overall system operation, expressed as a decimal from 0 to 1, where 0 indicates that the
block's failure will not cause any problem for the system and 1 indicates that the block's failure will
definitely cause system failure.

 For each component, click the Include check box.
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 Enter the following values for the components:

The values in the Reliability Allocated and other calculated columns (gray background) will be updated
based on your inputs, as shown next.

4.7.4  View the Results in a Plot

 Click the Plot icon in the Allocation utility Control Panel.

The Allocation window looks like the one shown next:

The plot displays the apportioned failure rate goals that you just calculated in the Allocation utility.

 Close the Allocation window.

Name Operating Time Importance Factor Number of Subelements

Power Supply 12 1 35

Transmitter 12 1 91

Receiver 12 1 88

Control 12 1 231

Moving Target 6 0.25 88
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 Close the database and proceed to the next example.

4.8  Example 7 - Advanced Analysis: Derating

Most equipment failures are precipitated by stress. When the applied stress exceeds the inherent strength of
the part, either a serious degradation or a failure will occur. To assure reliability, equipment must be
designed to endure stress over time without failure. In addition, design stress parameters must be identified
and controlled while parts and materials that can withstand these stresses must be selected. Derating
standards are used to help you select and use parts and materials so that the applied stress is less than rated
for a specific application.

For this example, imagine that you wish to analyze the effect of ambient temperature on a computer system.
You will:

 Import a prediction from an existing database.

 Apply an existing derating standard to the system.

 Change the application parameters to view the effects on derating.

4.8.1  Create a New Database and Import a Prediction

 Create a new database file by choosing File > New Database or clicking the New Database icon.

 Browse to the desired location for the database, name the database Derating and then click Save.

 In the Edit Prediction Properties window that appears, click Cancel. This will create the database with
no predictions.

 Choose Project > Import Prediction(s). In the window that appears, navigate to the MIL Example.lp3
file, which is located in the Training Guide folder within your application directory (e.g. C:\Program
Files\ReliaSoft\LambdaPredict3\Training Guide) and click Open to select the file.

 In the Import window, select the HIGH SPEED SWITCH 2 prediction check box, and then click OK.
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 Open the HIGH SPEED SWITCH 2 prediction. The MDI will look like the one shown next.

4.8.2  Apply an Existing Derating Standard to a System

When a derating standard is applied to a system, each component in the system is automatically evaluated to
determine whether it meets the derating requirements defined for its component type in the standard. Any
components of types not specified in the derating standard are not considered in the derating.

 Choose Tools > Apply Derating Standard. The Available Standards window displays, as shown next.
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 Select the NAVSEA standard and then click OK. Notice that the icons in the System Hierarchy panel
have changed to show the derating status of each component, as shown next.

Components that meet the derating requirements display a green box with two straight lines on the
component icon. Components that are not over-stressed but are above the nominal value given in the
derating standard are shown with light blue icons with two wavy lines. Components that are over-
stressed based on the derating requirements have a red icon with two wavy lines. Components with a
plain, dark blue icon with two straight lines are not considered in the derating standard.

 To view the derating analysis for one particular component, select the CAP-NP-0603 capacitor and then
choose Tools > View Component Derating. The Component Derating window displays, as shown next.

The blue point on the plot shows where the capacitor stands with respect to the requirements of the
derating standard. The red line represents the worst case points and the green line represents the nominal
points. Note that the capacitor currently falls between the nominal and worst case lines. In other words, it
does not meet the derating requirements, but is not actually over-stressed. You can see from the shape of
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the plot that altering the ambient temperature will not address this problem. Instead, the voltage stress
must be reduced.

 Position the cursor at the intersection of the green line and the Y-axis. The location of the cursor,
(0, 0.4000), will appear as a tool tip. This gives you an idea of the appropriate voltage stress for this
component in the current environment 

 Close the window.

4.8.3  Changing a Stress Value

 In the System Hierarchy panel, with the CAP-NP-0603 capacitor still selected, change the Voltage
Stress field to 0.39 in the Properties panel.

 Press ENTER or click outside the Power Stress field to accept your change. Notice that in the System
Hierarchy panel, the CAP-NP-0603 capacitor component’s icon has changed to green with two straight
lines, indicating that the component now meets the derating requirements.

 Select the CAP-NP-0603 capacitor and then choose Tools > View Component Derating. Note the
difference in the Component Derating window as compared to the earlier version.

 Close the Component Derating window.

 Close the database and proceed to the next example.

4.9  Example 8 - Information Reporting

This example will show you how to create and use plots and reports. You will:

 Create a plot “on the fly” (i.e. from within the prediction).

 Create a plot from the Project Explorer.

 Customize a plot.

 Create a report template and report.

4.9.1  Create a New Database

 Create a new database file called Information Reporting.
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 In the Edit Prediction Properties window, click Cancel to create the database with no predictions.

 Import the Power Supply prediction from the Power Supply.lp3 file, which is located in the Training 
Guide folder within your application directory (e.g. C:\Program Files\ReliaSoft\LambdaPredict3
\Training Guide).

 Open the Power Supply prediction. The MDI will look like the one shown next.

4.9.2  Adding a Plot from the Prediction

Lambda Predict includes two ways of creating plots:

 From the prediction, where you create a plot based on a selected system or block in the System
Hierarchy panel. You will not be prompted to save the plots that you create this way, but you can save
them, if desired.

 From the Project Explorer, where you can select multiple systems and blocks from any prediction in your
database. You will be prompted to save the plots that you create this way.

First you will create a plot from the prediction.

 In the System Hierarchy panel, click the MIL-HDBK-217F system.

 Choose Tools > Plot or click the Plot icon.

By default, the last plot type that was selected will automatically be plotted when you open the Plot
Window. For this example, choose Failure Rate vs. Temperature from the Plot Type drop-down list
that appears in the Control Panel on the right side of the Plot Window. If the Auto Refresh option is not
selected, you will have to click the Refresh icon to refresh the plot with the new plot type.
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The Failure Rate vs. Temperature plot will appear, as shown next.

If desired, you can take some time now to modify this plot and/or create other plots. For example, you can
view this information as a line plot by choosing Line Plot in the Plot Setup field. You can change the values
in the Range area to view the results over a different range of temperatures or in more or fewer steps, or see
the individual component values by selecting the Include Components check box. You can also use the
Plot Type field to view other types of plots.

 When you are done, close the plot by clicking the Close (x) button in the upper right corner of the
window. Note that you are not prompted to save the plot. (If you want to save the plot, click the Save
icon and use whatever name you want.)
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4.9.3  Adding a Plot from the Project Explorer

In this case, you will create a plot from the Project Explorer.

 Choose Project > Add Plot or right-click the project's Stored Plots folder in the Project Explorer and
choose Add Plot on the shortcut menu that appears. The Select Top Level Items to Plot window will
appear.

 Select the check box next to the MIL-HDBK-217F item and then click OK.

 For this example, choose Unreliability vs. Temperature from the Plot Type drop-down menu that
appears in the Control Panel on the right side of the Plot window and select the Include Top Level,
Include Blocks and Include Components check boxes. The Unreliability vs. Temperature plot will
appear, as shown next.
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 In the Plot Style field select Line Plot. Notice how the plot changes, as shown next.

 Click the Close (x) button. You will be prompted to save the plot.

The Save Plot window displays.

 Accept the default name and then click OK.
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 The MDI now includes the saved plot in the Stored Plots folder in the Project Explorer, as shown next.

Note that changes to the data in the prediction will not cause the plot to be updated automatically. To have
the plot reflect the changed data, you must change the plot settings. If you delete a prediction that is
referenced by a stored plot, the plot will remain available, but you will not be able to make any changes to it.

4.9.4  Customizing a Plot

Lambda Predict allows you to customize plots to meet your needs. The Plot Setup window gives you full
control over the settings used both for individual plots and as default settings for all new plots. For this
example, you will change the default label font size and then add a custom label to the plot.

 In the Project Explorer, open the Power Supply Prediction - Plot 1 plot.

 Click the Plot Setup icon on the Plot Control Panel.

The Plot Setup window displays.
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 In the navigation panel, click Plot Labels.

 In the Plot Labels area, click the Set Font button. The Font Dialog displays.

 Change the Font Size field to 20 and select the Bold check box.

 Click OK to close the Font Dialog and then click OK again to close the Plot Setup window.

 To add a custom label to the plot, press CTRL and click near the blue Filter Capacitor line. A new label
will appear in the plot as shown next.
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 Delete the old text, type Filter Capacitor and then click on the plot. The Plot window will look like the
one shown next.

 Click the Save As icon on the Plot Control Panel.

 In the Save Plot window, accept the default name and click OK.

 Close the Plot window. The MDI will look like the one shown next.
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4.9.5  Creating a Report

Lambda Predict gives you the ability to generate template-based reports for the systems in your predictions.
You can customize the appearance of all predefined report templates and also build and manage your own
custom report templates. Reports are generated in Microsoft Excel®, which provides maximum flexibility
for additional post-generation customization and distribution.

 To create a report, select the MIL-HDBK-217F system in the System Hierarchy panel. The report will
include data for this system and its subsystems. Choose Tools > Report or click the Report icon.

The Select Report window displays.

For this example, you will create your own custom report template.

 Click the Add Report icon.

The Report Templates window displays.

 Click the plus (+) button to open the General group.

 Click the Name field and then click the Include icon (>) or simply double-click the Name field to move
it from the Available Fields area to the Selected Fields area.
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 Add the following fields to the Selected Fields area in this manner, in the order given below.

 General heading: Part Number, LCN, Reference Designator, Mission Time and Quantity.

 Application heading: Environment and Ambient Temperature.

 Physical heading: All Physical Parameters.

 Once you have added all of the fields, click the All Physical Parameters field in the Selected Fields area
and use the up arrow to move the field below the Quantity field, or simply drag the All Physical
Parameters field to the desired position, as shown next.

 Click the Header tab.

 In the Header Options area, select the Display on every page check box. This ensures that the header
will appear on every page.
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 To see what the report template looks like, click the Preview tab, as shown next.

 Click the Save icon and save the report template that you have created as My Report Template. Save it
in the default location.

 Close the Report Template window. Notice that your new report template is selected in the Select Report
window.

 Click OK.

 In the Save As window, type My Report and then click Save to save it to the default location. By
default, Lambda Predict saves reports to the ReliaSoft\Lambda Predict\Reports directory within your My
Documents folder. Lambda Predict generates the report and displays it in Excel.

 You may wish to adjust the column widths to your liking.
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 To view the report with the header displaying, you can use Excel’s Print Preview functionality, as shown
next.

 After you are finished reviewing the report, close it.

 Close the database.
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