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1.1  About this Training Guide

This training guide is intended to provide you with many examples to demonstrate the use of the Weibull++
7 software. It begins with step-by-step examples and then proceeds into more advanced examples. At any
time during the training, please feel free to ask the instructor(s) any questions you might have.

NOTE: If you have a demonstration version of Weibull++, you may not be able to create new project files
and enter your own data to perform the examples in this training guide. Therefore, sample files required to
perform these examples are provided in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide). The name of the applicable file is provided at the
beginning of each example in this training guide.

1.2  Other Example Files

In addition to the examples described in this training guide, ReliaSoft provides a large array of example files
to demonstrate various types of analyses and product features. These files are located in the “Examples”
folder in your application directory (e.g. C:\Program Files\ReliaSoft\Weibull7\Examples). The Examples
folder is also accessible by clicking the Open Examples Folder... link in the What do you want to do?
window or by selecting Open Examples Folder... from the Help menu. 

1.3  Weibull++ 7 Documentation

Like all of ReliaSoft's standard software products,
Weibull++ 7 is shipped with detailed printed
documentation on the product (Weibull++ 7
User's Guide) and the underlying principles and
theory (ReliaSoft's Life Data Analysis Reference).
This training guide is intended to be a supplement
to those references.

Weibull++ 7 Training 
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1  Weibull++ 7 Training Guide
1.4  Contacting ReliaSoft

ReliaSoft can be reached at:

ReliaSoft Corporation
Worldwide Headquarters

1450 South Eastside Loop
Tucson, AZ 85710-6703 USA

Phone: +1.520.886.0366
Fax: +1.520.886.0399

E-mail: Support@ReliaSoft.com

For up-to-date product information, visit our Web site at:
http://www.ReliaSoft.com
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The examples included in this training guide have been designed to introduce you to the features available in
Weibull++ Version 7. This section presents a brief summary of these features. If you are already familiar
with Weibull++'s features, you can proceed to the examples.

2.1  Intuitive and Flexible Work Environment

The Weibull++ interface is an intuitive, flexible and completely integrated work center designed around the
Data Folio (similar to an Excel® worksheet). In Version 7, the interface has been enhanced to allow you to
manage multiple analysis folios and related information all together in a single file. Using the "Project
Explorer" approach that was first introduced in ReliaSoft’s BlockSim software, Weibull++ now provides an
intuitive, hierarchical (tree) structure to allow you to view and manage one or many standard folios,
specialized folios, plot sheets, reliability block diagrams, spreadsheet reports and/or attached documents per
project. At the same time, the new work environment "stays true to its roots" so that users who are familiar
with previous versions of the software will be able to enter and analyze data in much the same way as
always.

2.2  All the Tools You Need for Standard Life Data Analysis

Weibull++ provides all of the tools that you need for standard life data analysis (Weibull analysis), including
flexible options for data type, lifetime distribution and parameter estimation methods.

2.2.1  Support for All Life Data Types and Multiple Lifetime Distributions

Weibull++’s data entry spreadsheets for standard life data analysis support all life data types and all major
lifetime distributions. You can analyze time-to-failure (complete), right censored (suspension), left censored,
interval censored or free-form data, entered individually or in groups. Available distributions include the 1, 2
and 3 parameter Weibull; 2, 3 and 4 subpopulation Mixed Weibull; 1 and 2 parameter Exponential; Normal;
Lognormal and Generalized Gamma. In addition, Version 7 now supports the Gamma, Logistic, Loglogistic,
Gumbel and Weibull-Bayesian distributions. With the incorporation of the Weibull-Bayesian model, which
considers prior knowledge of the Weibull Beta parameter, Weibull++ now supports methodologies from
both Classical and Bayesian statistics.

The Distribution Wizard automatically performs multiple goodness-of-fit tests on the available lifetime
distributions and recommends the one that best fits your data set. You can use Monte Carlo simulation to
generate sample data sets based on any of the supported lifetime distributions or a user-defined function.
This can include complete data, right censored, interval censored and/or left censored data points, according
to your specifications.

Features Summary 2
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2  Features Summary
2.2.2  Choice of Parameter Estimation Methods

Weibull++ allows you to choose the parameter estimation method that is most appropriate for your data set.
Options include Maximum Likelihood Estimation (MLE), Rank Regression on X or Rank Regression on Y
with Median Ranks, Kaplan-Meier or ReliaSoft ranking methods.

2.3  Results and Plots at the Click of a Button

Always a strength of Weibull++, Versions 7 continues to make it easy to calculate and present your analysis
results in ways that effectively support decision-making. 

2.3.1  Quick Calculation Pad

The Quick Calculation Pad (QCP) provides a quick, easy and accurate way for you to obtain results for the
most frequently asked reliability questions. This includes Reliability or Probability of Failure, Failure Rate,
Warranty Time for a given reliability, B(X) Life and Mean Life calculations. The utility also returns the
conditional reliability or probability of failure given the starting age. 

2.3.2  Plots and Graphics to Showcase Your Analyses

Weibull++ continues to offer unparalleled plotting capabilities to demonstrate your analyses visually. You
can generate Probability, Reliability vs. Time, Unreliability vs. Time, pdf, Failure Rate vs. Time, Contour
and 3-dimensional Likelihood Function Surface plots with the click of a button. In addition, Version 7 now
includes histogram, pie and timeline charts to display failures/suspensions data. The Plot Setup allows you
to configure the appearance of plot output and the software also provides a Chart Wizard to create your own
custom charts. All plot graphics are metafiles that can be pasted or inserted into other reports and
presentations.

The Multiple Plot Sheet makes it easy to compare analyses by automatically plotting the results for multiple
data sets together in the same plot. The Side-by-Side Plots utility allows you to view (and print) multiple
plots for a given data set side-by-side. For example, you may want to show the Probability, Reliability, pdf
and Failure Rate plots for a given analysis together in the same window. Alternatively, you may wish to
compare the Probability or pdf plots for a given data set when analyzed with different distributions. Simply
select the combination that meets your analysis/reporting needs. You can use RS Draw, ReliaSoft’s
integrated metafile graphics editor, to edit and annotate the plots generated by Weibull++. This utility allows
you to insert text, highlight a point or line, mark the coordinates of a point, and much more!

2.3.3  Confidence Bounds for Parameters and Results 

Weibull++ provides confidence bounds for all of the standard life data analysis parameters and results and
also for many of the results from related analyses (such as warranty forecasts, recurrence data analyses, etc.).
In addition to the Fisher Matrix, Likelihood Ratio and Beta Binomial methods, Bayesian confidence bounds
have been added in Version 7. You can choose whether bounds will be displayed and also specify the
confidence level and type of bounds.

2.4  A Complete Array of Related Analyses

In addition to the software’s unparalleled support for all aspects of standard life data analysis, Weibull++
also supports a comprehensive array of related analyses. Whenever applicable, these analyses can be fully
integrated with the standard folio, allowing you to supplement/enhance your basic analysis.

 Warranty Analysis: Perform life data analysis and make warranty projections based on sales and
returns data, entered in a Nevada, Times-to-Failure, Dates of Failure or Usage format. 

 Reliability Block Diagrams: Use Reliability Block Diagrams (RBDs) that are integrated with
calculated data folios to analyze competing failure modes and perform other system analyses. 
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2.5  Additional Tools and Wizards
 Recurrence Data Analysis: Use parametric or non-parametric methods to analyze events that are
dependent and not identically distributed (such as repairable system data) and/or to model the number of
occurrences of an event over time. 

 Degradation Analysis: Use the Linear, Exponential, Power, Logarithmic, Gompertz or Lloyd-Lipow
models to extrapolate the failure times of a product based on its performance (degradation) over a period
of time. 

 Non-Parametric Life Data Analysis: Use Kaplan-Meier, Simple Actuarial or Standard Actuarial
techniques for non-parametric life data analysis. 

 Event Log Interface: Enter data in an event log format (e.g. equipment downtime log) and convert the
data to times-to-failure and times-to-repair for standard life data analysis or export to BlockSim for
system reliability, maintainability and availability analyses.

 Risk Analysis and Probabilistic Design: Use the Monte Carlo simulation tool to perform relationship-
based simulations. When you specify an equation relating different random variables, you can then
determine the joint pdf for the simulated data set. 

 SimuMatic: Automatically perform large quantities of analyses on simulated data sets in order to
investigate various reliability questions, including confidence bounds, testing scenarios, etc. 

2.5  Additional Tools and Wizards

Weibull++ also provides many additional tools and wizards designed to streamline, enhance and supplement
your analyses.

2.5.1  Spreadsheets for Custom Analyses

General Spreadsheets, which can be incorporated into any Weibull++ standard folio, are used just like an
Excel® worksheet to perform your own customized analyses. These spreadsheets provide complete in-cell
formula support, cell references, over 140 built-in functions and integration with the Function Wizard and
the Chart Wizard. You can use the Function Wizard to insert a wide array of calculated results based on your
inputs and, when applicable, a referenced data folio. Available results range from basic math/statistical
functions to common reliability analysis results, and much more. In Version 7, this now works more like
Excel® functions, with the ability to type functions directly into cells and results that are updated
automatically when the inputs change. The Chart Wizard leads you through a step-by-step process to create
and configure your own custom charts/plots based on a selected data set. 

2.5.2  Template-Based Report Generator

The Report Wizard utility allows you to design print-ready reports to showcase your analyses. The template
feature makes it easy to apply the same report format to different analyses. This utility has been revised and
enhanced in Version 7 and now provides an intuitive spreadsheet-based interface for creating and formatting
reports. 

2.5.3  References and Wizards

 Quick Statistical Reference: Frees you from tedious lookups in tables by returning results for common
statistical functions, such as Median Ranks, Chi-Squared values and more at the click of a button. 

 Design of Reliability Tests: Determine the appropriate sample size, test duration or other variable for a
reliability demonstration test. Parametric Binomial, Non-Parametric Binomial and Exponential Chi-
Squared methods are available and results are displayed in both tables and plots.

 Tests of Comparison Wizard: Compare two data sets to determine whether items from the first set will
outlast those of the second.
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2  Features Summary
 Stress-Strength Wizard: Compare a data set with strength data against a data set with stress data to
determine probability of failure (i.e. stress exceeds strength).

 Parameter Experimenter: Solve for a parameter of a distribution given the other parameter(s) and one
data point (unreliability at a given time) or solve for all parameters of a distribution given two
unreliability data points.

 Non-Linear Equation Fit Solver: Estimate the parameters of a non-linear equation, given the equation,
the minimum, maximum and initial guess values for its parameters and at least two data points.

 Non-Linear Equation Root Finder: Iteratively solve for a real root of an unconstrained non-linear
function using a variable order improved memory method.

2.6  Data Import and Integration with Other ReliaSoft Software

In addition to providing a variety of data sheet formats designed to fit your particular data and analysis
requirements, Weibull++ makes it easy to import data from outside sources, including: Weibull++ 4, 5, 6 or
MT; ALTA; Excel® and Tab, Comma, Space or Semi-colon delimited files.

Weibull++ is directly integrated within other ReliaSoft software whenever you need to specify a distribution
and parameters based on a calculated data set. Integration is currently available for the following products:
ALTA, BlockSim, RENO, RGA, Xfmea and RCM++.

2.7  Configure the Workspace to Meet Individual Needs

Weibull++ makes it easy to configure the interface and analysis settings to meet your specific preferences
and needs. For example, the User Setup allows you to specify default options for data sheets, analysis
settings, fonts/symbols, etc. The Plot Setup allows you to configure the appearance of the plots that are
automatically generated by the software. In addition, you can customize the toolbars and/or adjust the
appearance of the workspace by hiding/displaying or changing the position of the Project Explorer and other
panels.

2.8  System Requirements

Weibull++ is compiled and designed for Windows NT, 2000 and XP and takes advantage of the features
available in these platforms. Minimum system requirements: 433-MHz Intel Pentium-class processor or
equivalent, with 32MB RAM (64MB or more is recommended), SVGA display and at least 80MB of hard
disk space. 
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3.1  Starting Weibull++ 7

Weibull++ is a 32-bit application that has been designed to work with Windows NT, 2000 and XP. The
internal screens and commands are identical regardless of which operating system you are using, and this
training guide is equally applicable. To start Weibull++, from Start select Programs, ReliaSoft Office and
then Weibull++ 7.

First Steps 3
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3  First Steps
3.2  Multiple Document Interface

Every time you begin a new session in Weibull++, the first window you will encounter is the Multiple
Document Interface (MDI). It contains the windows you will use to analyze your data. The MDI serves as
the container for the Project Explorer, Standard Folios, Specialized Folios, Special Plots, Diagrams, Other
Tools, Reports and Attachments and manages the different active windows. The MDI remains open until
you close the program. Closing the MDI has the same effect as terminating the program. The next figure
shows the MDI of Weibull++ 7 and its components. The appearance of the MDI will vary depending on the
windows that are currently open and the configuration settings of the Project Explorer.

3.3  Getting Help in the Weibull++ Environment

ReliaSoft's Weibull++ includes complete on-line help documentation. This help can be obtained at any time
by pressing F1 or by selecting Contents from the Help menu. 

3.4  First Steps Example

This section presents you with a very simple example and guides you through the solution. The test case for
this example: Six units were reliability tested and the following times-to-failure were observed: 46, 64, 83,
105, 123 and 150 hr. You will analyze the data with the 2-parameter Weibull distribution and Rank
Regression on X, create the Weibull-Probability plot and estimate the Reliability at 50 hr.

The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “1stSteps.rwp.”

 Create a new project by clicking Create a New Project in the initial window that may appear at startup,
by selecting New... from the File menu or by clicking the New icon.

The Project Wizard will be displayed. This wizard guides you through the steps required to create a new
project that will meet your analysis needs. The steps displayed will vary depending on your selections for
8 http://Weibull.ReliaSoft.com



3.4  First Steps Example
each page. Note that you can click Finish from the first page of the wizard to create another project with the
same settings as the last project you created. You may also choose to create a new project with items
imported from an existing project or based on a saved profile.

 On the first page of the Project Wizard, select to create a new project By following the wizard and click
Next> to proceed to the next step.

 On the second page of the Project Wizard, make sure that Life Data Analysis Folio is selected and click
Next> to proceed to the next step.
 Weibull++ 7 Traning Guide 9



3  First Steps
 On the third page of the Project Wizard, select Times-to-failure data for the Folio Data Type and make
sure that no other options are selected. Click Next> to proceed to the next step.

 On the last page, click Finish to create the new project according to your specifications. The project will
now include one Standard Folio with a data sheet that has been configured to accept the type of data that
you will be entering for this example. Enter the times-to-failure into the Time Failed column of the data
sheet, as shown next.

 The next step is to select a distribution and parameter estimation method to calculate the parameters.
Select the Weibull distribution from the menu on the Main page of the Control Panel. Note that you can
activate this menu in two ways: by clicking the blue bar or by hovering the mouse over the bar for a
second or two. The Parameters/Type area below the menu will be updated to display the options
10 http://Weibull.ReliaSoft.com



3.4  First Steps Example
available for the selected distribution. Select 2 to perform the analysis with the 2-parameter Weibull
distribution, as shown next. 

The other analysis settings are set/displayed in two places within the Control Panel: in the Settings area of
the Main page and on the Analysis page. For this example, you will use the default settings: Rank
Regression on X (RRX) with the Standard Regression Method (SRM) and Median Ranks (MED); and
Fisher Matrix (FM) confidence bounds, as shown next.

 Make sure that the analysis settings for your Folio are set to the defaults. Note that clicking the options
displayed with blue text in the Settings area of the Main page allows you to toggle through the available
settings.

 Calculate the parameters by selecting Calculate from the Data menu or by clicking the Calculate icon.
This icon is displayed in both the Data Analysis Tools toolbar and in the Control Panel.
 Weibull++ 7 Traning Guide 11



3  First Steps
The data sheet with its parameters calculated is shown next. The estimated parameters will appear in the
Results Area, which is located just below the Parameters/Type options.

 Plot the data by selecting Plot from the Data menu or by clicking the Plot icon. This icon is displayed in
both the Data Analysis Tools toolbar and in the Control Panel.
12 http://Weibull.ReliaSoft.com



3.4  First Steps Example
A new sheet called “Plot of Data 1” will be added to the Folio. The Probability-Weibull plot will be

displayed by default, as shown next.1 

The Plot Sheet provides many options for creating and configuring plots to meet your particular analysis and
presentation needs. You may wish to experiment with some of these options at this time. If the Auto Refresh
command is enabled, the display will be updated automatically to fit your new selections. If not, select
Redraw Plot from the Plot menu or click the Redraw Plot icon to implement your selections. 

For example, the Plot Type menu in the Control Panel allows you to create other types of plots. 

In addition, notice that the analysis settings are displayed in the legend in the top right corner of the plot and
the calculated parameters are displayed in the bottom left corner. You can customize these and other display
settings from the Plot Setup window. To access the Plot Setup, select Plot Setup from the Plot menu or click
the Plot Setup icon.

 When you are finished experimenting with the Plot Setup window, return to the data sheet by clicking
the Data 1 tab.

1. If necessary, you may wish to re-size the plot by re-sizing the Folio. 
 Weibull++ 7 Traning Guide 13



3  First Steps
 Open the Quick Calculation Pad (QCP) by selecting Quick Calculation Pad... from the Data menu or
by clicking the icon. This icon is displayed in both the Data Analysis Tools toolbar and in the Control
Panel.

This tool allows you to obtain commonly requested reliability results based on your analysis and any
required inputs. To estimate the reliability at 50 hr for this example, do the following:

 On the Basic Calculations page, make the following selections/inputs:

 Options for Calculations: Std. Prob. Calculations

 Results Options: Results as Reliability

 Required Input from User: Mission End Time = 50

 Click Calculate to obtain the results, as shown next.

 Click Close to close the QCP.

 Save the project by selecting Save from the File menu or by clicking the Save icon.

 When prompted to specify the name and location for the file, browse to the directory of your choice and

type “1stSteps” for the File name.2 Accept the default type (*.rwp) and click Save to close the window
and save the file.

 Close the project by selecting Close from the File menu. 

2. By default, files will be saved in the “My Documents” directory on your computer. You can select a different
directory, if desired, and Weibull++ will “remember” the directory for the next time that you save a file.
14 http://Weibull.ReliaSoft.com



4.1  List of Examples

This chapter provides the following step-by-step examples, which are designed to introduce you to the
features of the Weibull++ software:

 Example 1: Life Data Analysis with Complete and Suspended Data - page 15

 Example 2: Obtain the Unreliability for a Given Operating Time - page 20

 Example 3: Calculate Conditional Reliability and Warranty Time - page 24

 Example 4: 3-Parameter Weibull Analysis - page 27

 Example 5: 2-Parameter Exponential Analysis and Plots - page 30

 Example 6: Normal Probability Plot with Confidence Bounds - page 35

 Example 7: Calculate Reliability and MTTF with Confidence Bounds - page 38

 Example 8: Use the Function Wizard and General Spreadsheet - page 40

 Example 9: Analyze Interval Data - page 44

 Example 10: Analyze Accelerated Test Data - page 47

 Example 11: Degradation Data Analysis - page 56

 Example 12: Warranty Data Analysis - page 60

 Example 13: Competing Failure Modes Analysis - page 65

 Example 14: Weibull-Bayesian Analysis - page 69

 Example 15: Failure Modes RBD Analysis - page 78

 Example 16: Determine Optimum Burn-In Time - page 83

4.2  Example 1: Life Data Analysis with Complete and Suspended Data

Ten identical units were reliability tested at the same application and operation stress levels. Six of these
units failed during the test after operating for the following times, : 16, 34, 53, 75, 93 and 120. Four other

units were still operating, i.e. right censored or suspended, after 120 hr. Determine the parameters of the
Weibull pdf that represents this data set and create the Probability and pdf plots.

The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Training Examples.rwp.” Use Folio1.

Step-by-Step Examples 4
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4  Step-by-Step Examples
Solution

 Create a new project by clicking Create a New Project in the initial window that may appear at startup,
by selecting New... from the File menu or by clicking the New icon.

 Select By following the wizard on the first page of the Project Wizard and Life Data Analysis Folio on
the second page.

 On the third page, select Times-to-failure data for the Folio Data Type and select My data set contains
suspensions (right censored data), as shown next.

 Click Finish to create the new project with the appropriate Standard Folio. In this type of data sheet, the
first column (“State F or S”) contains an F to indicate that the data point entered in the second column
(“Time to F or S”) is a failure or an S to indicate that the data point is a suspension. Note that if you type
a positive value in the “Time to F or S” column, an F will be assigned automatically by the software and
if you type a negative value, an S will be automatically assigned.
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4.2  Example 1: Life Data Analysis with Complete and Suspended Data
 Enter the data for this example, as shown next. 

 The 2-parameter Weibull distribution and Rank Regression on X (RRX) will be used to calculate the
parameters. If these are not the default analysis options on your computer, select Weibull from the
Distribution menu and 2 from the Parameters/Type area on the Main page of the Control Panel, as shown
next.

 There are two ways to set the Analysis Method: select Rank Regression on X (RRX) from the Analysis
page of the Control Panel or click the Analysis Method box on the Main page of the Control Panel until
RRX is displayed, as shown next. 

 Calculate the parameters by selecting Calculate from the Data menu or by clicking the Calculate icon.
This icon is displayed in both the Data Analysis Tools toolbar and in the Control Panel.
 Weibull++ 7 Traning Guide 17



4  Step-by-Step Examples
The results will appear in the Control Panel, as shown next.

 Plot the data by selecting Plot from the Data menu or by clicking the Plot icon. This icon is displayed in
both the Data Analysis Tools toolbar and in the Control Panel.

The Weibull Probability plot for this data set is shown next.
18 http://Weibull.ReliaSoft.com



4.2  Example 1: Life Data Analysis with Complete and Suspended Data
Note that the plotted line represents the unreliability, Q(T), which is defined as:

 

where R(T) is the reliability. If desired, the 2-parameter Weibull pdf representing this data set can be written
as:

or

 You can also plot the Weibull pdf by selecting Pdf Plot from the Plot Type menu on the Control Panel.

 If the Auto Refresh option is selected, the Plot Sheet will be updated automatically to display the new
plot type that you have selected. If the option is not selected, click the Redraw Plot icon or select
Redraw Plot from the Plot menu to update the display.

The pdf plot is shown next.

 Return to the data sheet by clicking the Data 1 tab at the bottom of the Folio.
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4  Step-by-Step Examples
 Save the project by selecting Save from the File menu or by clicking the Save icon.

 When prompted to specify the name and location for the file, browse to the directory of your choice and

type “Training Examples” for the File name.1 Accept the default type (*.rwp) and click Save to close the
window and save the file.

 Leave the project and Folio open and proceed to the next example.

4.3  Example 2: Obtain the Unreliability for a Given Operating Time

What is the unreliability of the units in Example 1 for a mission duration of 227 hr, starting the mission at T
= 0?

The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Training Examples.rwp.” Use Folio1.

Solution

There are several methods of solution for this problem. The first and more laborious method is to extract the
information directly from the plot. It is possible to extract the information from a plot within Weibull++ or
from a printed copy. For this example, let's obtain the information from within the application. This can be

done using ReliaSoft Draw (RS Draw).2

 If Folio1 from the “Training Examples.rwp” project file that you created in the first example is not
already active, open the project by selecting Open from the File menu or by clicking the Open icon.

 Browse for the “Training Examples.rwp” file and click Open.

1. By default, files will be saved in the “My Documents” directory on your computer. You can select a different
directory, if desired, and Weibull++ will “remember” the directory for the next time that you save a file.
2. RS Draw is presented in detail in Chapter 28 of the Weibull++ User's Guide. 
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4.3  Example 2: Obtain the Unreliability for a Given Operating Time
 Click the “plus” (+) to the left of the Standard Folios branch in the Project Explorer on the left side of the
Weibull++ MDI to display a list of the standard life data analysis folios in the current project. Double-
click Folio1 to open it. The MDI will now look like the figure shown next.

 Click the Plot of Data 1 tab at the bottom of the Folio to display the Plot Sheet. Select Probability-
Weibull from the Plot Type menu and refresh the display, if necessary.

 Open RS Draw by selecting Edit Plot with RS Draw... from the Plot menu or by clicking the Edit Plot
with RS Draw icon. This icon is displayed in both the Plot Tools toolbar and in the Control Panel.

 RS Draw can automatically track the position of the mouse cursor and translate the coordinates for you.
Obtain the unreliability at T = 227 hr by placing the cursor at the intersection of the plotted line and T =
227. The position of the cursor is indicated by the Position Indicator located in the lower right corner of
the RS Draw window. The x-coordinate (time) is displayed on the left and the y-coordinate
(unreliability) is displayed on the right. When the x-coordinate reads approximately 227, read off the
value of the y-coordinate. You may not be able to obtain the value of the unreliability at exactly 227 hr.
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4  Step-by-Step Examples
This is one of the disadvantages of reading the value off the plot. The position of the cursor at the
intersection of the plotted line and approximately T = 227 is shown next.

The value of the y-coordinate from the Position Indicator, the unreliability Q(T), is such that %.
Therefore, a good estimate of the probability of failure (unreliability) at 227 hr is 82%. The reliability is
then:

 or %

 Close RS Draw and return to the Plot Sheet by selecting Exit from the File menu or by clicking the
Close button (X) in the top right corner of the window.

You can also read the coordinates from within the Plot Sheet. To do this, position the mouse pointer over the
plot line, press Shift and click the plot. The X and Y coordinates for the current position of the mouse on the
line will be displayed in a yellow box. If you continue to hold down the Shift key while moving the mouse,

Q T  82

R T  1 Q T – 1 0.82–= =

0.18= 18
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4.3  Example 2: Obtain the Unreliability for a Given Operating Time
the pointer will track the plot line, allowing you to read the coordinates for any position on the line. The next
figure shows the Plot Sheet with the coordinates marked at approximately 227 hr.

 Return to the data sheet by clicking the Data 1 tab.

The second method to obtain the unreliability for a given time involves the use of the Quick Calculation Pad

(QCP).3 

 Open the Quick Calculation Pad by selecting Quick Calculation Pad... from the Data menu or by
clicking the Quick Calculation Pad icon. This icon is displayed in both the Data Analysis Tools toolbar
and in the Control Panel. 

 On the Basic Calculations page, make the following selections/inputs:

 Options for Calculations: Std. Prob. Calculations

 Results Options: Results as Probability of Failure

 Required Input from User: Mission End Time = 227

3. The Quick Calculation Pad is presented in detail in Chapter 8 of the Weibull++ User's Guide. 
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4  Step-by-Step Examples
 Click Calculate to obtain the results, as shown next.

The QCP returns a result of %. This agrees with the result found using the plot.
However, using the QCP is more accurate and easier to use. 

 Close the QCP, save any changes, leave the project and Folio open and proceed to the next example.

4.4  Example 3: Calculate Conditional Reliability and Warranty Time

Using the analysis from Example 1, what is the reliability for a mission duration of t = 30 hr, starting the
mission at T = 30 hr? Also, what is the warranty time for a reliability of 85%?

The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Training Examples.rwp.” Use Folio1.

Solution

 If Folio1 from the “Training Examples.rwp” project file that you created in the first example is not
already active, open the project and Folio now.

The functions used to find the reliability are shown next.

 Open the Quick Calculation Pad by selecting Quick Calculation Pad... from the Data menu or by
clicking the Quick Calculation Pad icon. 

 On the Basic Calculations page, make the following selections/inputs:

 Options for Calculations: Std. Prob. Calculations

 Results Options: Results as Reliability

Q T  0.8225 82=

R T t  R T t+ 
R T 

--------------------=

R̂ 30hr 30hr  R̂ 30hr 30hr+ 

R̂ 30hr 
--------------------------------------- R̂ 60hr 

R̂ 30hr 
--------------------= =
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4.4  Example 3: Calculate Conditional Reliability and Warranty Time
 Required Input from User: Mission End Time = 60

 Click Calculate to obtain the results, as shown next.

 Still using the QCP, enter a Mission End Time = 30 and click Calculate to obtain the reliability at
t =30 hr, as shown next.

R̂ 60hr  0.7077=

R̂ 30hr  0.8612=
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4  Step-by-Step Examples
 Divide the reliability at 60 hr by the reliability at 30 hr and you will obtain the conditional reliability for
this example.

%

However, the Quick Calculation Pad can provide this result directly and more efficiently. The Std. Prob.
Calculations are based on a starting mission time, T, equal to zero. This example had a starting mission time
equal to T = 30 hr. A starting mission time greater than zero can be accounted for using Conditional
Calculations. 

 Still on the Basic Calculations page of the QCP, make the following selections/inputs:

 Options for Calculations: Conditional Calculations

 Results Options: Results as Reliability

 Required Input from User: 

 Mission Start Time = 30

 Mission Additional Time = 30

 Click Calculate to obtain the results, as shown next.

The second part of this example involves determining the warranty time for a reliability of 85%. 

 Still on the Basic Calculations page of the QCP, make the following selections/inputs:

 Options for Calculations: Warranty (Time) Information

 Required Input from User: Required Reliability = 0.85

R̂ 30hr 30hr  0.7077
0.8612
---------------- 0.8218= =

R̂ 30hr 30hr  82.18=
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4.5  Example 4: 3-Parameter Weibull Analysis
 Click Calculate to obtain the results, as shown next.

The time required for a reliability of 85% is equal to 32.1482. 

 Close the QCP by clicking Close.

 Close the Folio by clicking the Close button (X) in the top right corner.

 Save any changes, leave the project open and proceed to the next example.

4.5  Example 4: 3-Parameter Weibull Analysis

The 3-parameter Weibull analysis option calculates the correct  and adjusts the points by this value, such
that they fall on a straight line, and then plots both the adjusted and the unadjusted points.

Ten identical units, N = 10, were reliability tested at the same application and operation stress levels. Six of
these units failed during the test after operating for the following times, : 46, 64, 83, 105, 123 and 150.

The four other units were suspended after operating for 150 hr. Using the 3-parameter Weibull distribution
and Rank Regression on X (RRX), find the parameters of the Weibull pdf that represents these data points.

The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Training Examples.rwp.” Use Folio2.

Solution

 With the “Training Examples.rwp” project open, create a new Standard Folio by selecting Add
Standard Folio... from the Project menu or by right-clicking inside the Project Explorer and selecting
Add Standard Folio... from the shortcut menu.



Tj
 Weibull++ 7 Traning Guide 27



4  Step-by-Step Examples
 In the New Data Sheet Setup window, select Times-to-failure data for the Folio Data Type and select
My data set contains suspensions (right censored data), as shown next.

 Click OK to create the new Standard Folio with the data sheet that you have specified.

 Enter the data in the same way as in Example 1. The MDI with the data entered into the new Folio is
shown next. Note that the Project Explorer now displays two standard data analysis folios, Folio1 and

Folio2.4

4. Although the default Folio names have been used for these examples, you can rename Folios to be more descriptive, if
desired. To rename an item in the Project Explorer, right-click the item and select Rename Item from the shortcut
menu or select the item and press F2.
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4.5  Example 4: 3-Parameter Weibull Analysis
 Select Weibull from the Distribution menu and 3 from the Parameters/Type area on the Main page of the
Control Panel, as shown next.

 Set the Analysis Method to Rank Regression on X (RRX) from the Analysis page of the Control Panel
or by clicking the option in the Settings area of the Main page until RRX is displayed.

 Calculate the parameters by selecting Calculate from the Data menu or by clicking the Calculate icon.

The calculated parameters are shown next.

 Plot the data by selecting Plot from the Data menu or by clicking the Plot icon.

 Select Probability-Weibull from the Plot Type menu (if it is not already selected). 

 When the plot has been refreshed, select Show/Hide Items... from the Plot menu or right-click inside the
plot and select the command from the shortcut menu. In the Show/Hide Plot Items window, select to
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4  Step-by-Step Examples
display both the line/points that have been adjusted for Gamma and the line/points that have not been
adjusted for Gamma, as shown next.

 Click OK to close the window and refresh the plot with both the adjusted and unadjusted plot lines
displayed, as shown next.

Note that the original data points, plotted along the curved line, were adjusted by  = 30.92 hr to yield the

straight line. Also note that the x-axis for the plot is T - . Therefore, to obtain the time (T) required for a

given unreliability level using the straight line, you must add the value of  to the x-axis value found at (T -

). Alternatively, you can read the results from the unadjusted line.
 
 Close the Folio, save any changes, leave the project open and proceed to the next example.

4.6  Example 5: 2-Parameter Exponential Analysis and Plots

Twenty units, N = 20, were reliability tested with the following times-to-failure: seven units failed at 100 hr,
five units failed at 200 hr, three units failed at 300 hr, two units failed at 400 hr, one unit failed at 500 hr and
two units failed at 600 hr.

Do the following:

 Enter the data. Use the 2-parameter exponential distribution and Rank Regression on X as the parameter
estimation method.
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4.6  Example 5: 2-Parameter Exponential Analysis and Plots
 Obtain the Exponential Probability plot.

 Obtain the Reliability vs. Time plot.

 Obtain the pdf plot.

 Obtain the Failure Rate vs. Time plot.

The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Training Examples.rwp.” Use Folio3.

Solution

 With the “Training Examples.rwp” project open, create a new Standard Folio by selecting Add
Standard Folio... from the Project menu or by right-clicking inside the Project Explorer and selecting
Add Standard Folio... from the shortcut menu.

 In the New Data Sheet Setup window, select Times-to-failure data for the Folio Data Type and select I
want to enter data in groups, as shown next.

 Click OK to create the new Standard Folio with the data sheet that you have specified.

In this type of data sheet, the first column (“Number in State”) contains the quantity of units that failed at a
given time and the second column (“State End Time”) contains the time-to-failure.
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4  Step-by-Step Examples
 Enter the data into the new Folio and select the 2-parameter exponential distribution with RRX, as
shown next.

 Calculate the parameters by selecting Calculate from the Data menu or by clicking the Calculate icon.

The calculated parameters are shown next.
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4.6  Example 5: 2-Parameter Exponential Analysis and Plots
 Plot the data by selecting Plot from the Data menu or by clicking the Plot icon.

 Select Probability-Exponential from the Plot Type menu and refresh the display if necessary. The
Exponential Probability plot is shown next.

Note that this plot is displayed with automatic scaling and rounding on both the Y-Scale (vertical axis) and
X-Scale (horizontal axis). These are the default plot display options in Weibull++. If you de-select the
Round Y-Scale and Round X-Scale options and refresh the display, the scales will be set automatically
based directly on the data. If you de-select the Automatic Scaling option, you can manually set the starting
and ending values for both scales. Finally, the ^Y and |-X buttons allow you to set one scale manually and
the other automatically. Changes to the scaling do not take effect until you refresh the plot display. As an
example, the figures shown next demonstrate manual scaling for both axes, automatic scaling without
rounding and automatic scaling with rounding on the Y axis but manual scaling on the X axis. Other
combinations are possible to meet your specific scaling requirements.

 After you have finished experimenting with the scaling options, return to the default settings (with
Automatic Scaling, Round Y-Scale and Round X-Scale selected) before creating the rest of the plots.
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4  Step-by-Step Examples
 Select Reliability vs. Time from the Plot Type menu and refresh the display if necessary. The plot is
shown next.

 Select Pdf Plot from the Plot Type menu and refresh the display if necessary. The plot is shown next.
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4.7  Example 6: Normal Probability Plot with Confidence Bounds
 Select Failure Rate vs. Time from the Plot Type menu and refresh the display if necessary. The plot is
shown next.

 Close the Folio, save any changes, leave the project open and proceed to the next example.

4.7  Example 6: Normal Probability Plot with Confidence Bounds

Six units were tested to failure and the following times-to-failure were observed: 11,260; 12,080; 12,125;
12,825; 13,550 and 14,670 hr. Assume the data are normally distributed.

Do the following:

 Determine the parameters for the data using the normal distribution and Rank Regression on X as the
parameter estimation method.

 Obtain the Normal Probability plot for the data with 90%, 2-sided Time (Type 1) confidence bounds.

 Obtain the pdf plot.

The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Training Examples.rwp.” Use Folio4.

Solution

 With the “Training Examples.rwp” project open, create a new Standard Folio by selecting Add
Standard Folio... from the Project menu or by right-clicking inside the Project Explorer and selecting
Add Standard Folio... from the shortcut menu.

 In the New Data Sheet Setup window, select Times-to-failure data for the Folio Data Type and de-select
all other options. Click OK to create the new Standard Folio with the data sheet that you have specified.
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4  Step-by-Step Examples
 Enter the data into the new Folio, select the normal distribution with RRX and calculate the parameters,
as shown next.

 Create the Normal Probability plot, as shown next.
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4.7  Example 6: Normal Probability Plot with Confidence Bounds
 Select Confidence Bounds... from the Plot menu or shortcut menu to open the Confidence Bounds
Setup window. Specify Two-Sided, Time (Type I) and Confidence Level = 90, as shown next.

 Click OK to close the window and display the confidence bounds on the plot, as shown next.

Note that the plot legend now contains information about the confidence bounds that have been plotted.
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4  Step-by-Step Examples
 Plot the pdf plot, as shown next.

 Click the Data 1 tab at the bottom of the Folio to return to the data sheet.

 Save the changes, leave the project and Folio open and proceed to the next example.

4.8  Example 7: Calculate Reliability and MTTF with Confidence Bounds

Using the data and analysis from the previous example, do the following:

 Determine the reliability for a mission of 11,000 hr, as well as the two-sided 90% confidence bounds on
this reliability.

 Determine the MTTF, as well as the two-sided 90% confidence bounds on this MTTF.

The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Training Examples.rwp.” Use Folio4.

Solution

 If Folio4 from the “Training Examples.rwp” project is not already active, open the project and Folio
now.

 Open the Quick Calculation Pad by selecting Quick Calculation Pad... from the Data menu or by
clicking the Quick Calculation Pad icon. 

 On the Basic Calculations page, make the following selections/inputs:

 Options for Calculations: Std. Prob. Calculations

 Results Options: Results as Reliability

 Required Input from User: Mission End Time = 11000
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4.8  Example 7: Calculate Reliability and MTTF with Confidence Bounds
 On the Confidence Bounds page, select Show Confidence Bounds to enable the confidence bounds
options. Select Two Sided and type .90 for the Confidence Level, as shown next. 

 Return to the Basic Calculations page and click Calculate to obtain the result with confidence bounds, as
shown next.
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4  Step-by-Step Examples
 To obtain the MTTF, select Mean Life under Options for Calculations on the Basic Calculations page.
Since the confidence bounds options are already set, click Calculate to obtain the results, as shown next.

 Return to the Confidence Bounds page and de-select Show Confidence Bounds.

 Click Close to close the QCP, leave the project and Folio open and proceed to the next example.

4.9  Example 8: Use the Function Wizard and General Spreadsheet

Using the data from Example 6, obtain tabulated values for the failure rate for ten different mission end
times. The mission end times are 1,000 to 10,000 hr, incremented by 1,000 hr.

The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Training Examples.rwp.” Use Folio4.
Solution

You can easily accomplish this via the use of the Function Wizard within the General Spreadsheet.5 The
General Spreadsheet is very similar to an Excel® spreadsheet. You can input formulas and edit the cells in a
similar manner. The Function Wizard allows you to insert a wide array of calculated results based on your
inputs and, when applicable, a referenced data sheet.

 If Folio4 from the “Training Examples.rwp” project is not already active, open the project and Folio
now.

 Insert a General Spreadsheet by selecting Insert General Spreadsheet from the Folio menu or by
clicking the icon in the Folio Tools toolbar.

5. The General Spreadsheet is presented in detail in Chapter 20 of the Weibull++ User’s Guide and the Function Wizard
is presented in Chapter 22.
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4.9  Example 8: Use the Function Wizard and General Spreadsheet
 Type “Time” in cell A1 and “Failure Rate” in cell B1. Then enter 1000 through 10000 in cells A2 to

A11.6 Finally, place the cursor into cell B2, as shown next. 

 Open the Function Wizard by selecting Function Wizard from the Data menu or by clicking the
Function Wizard icon.

 Select FAILURERATE from the list of functions. Note that the functions are in alphabetical order and if
you click inside the list and start typing the name of the function, the selection will automatically move
to the first function in the list that matches the letters you have typed. Also note that the menu above the

6. To save time, you could also type the equation “=A2+1000” into cell A3 and then copy/paste the equation through cell
A11.
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4  Step-by-Step Examples
list allows you to filter the list to display only those functions of a specific type. With the failure rate
function selected, the wizard will look like the figure shown next.

The inputs required for the selected function are displayed on the right side of the window. The text box at
the bottom of the window allows you to build the function that will be inserted into the spreadsheet. 

 Enter A2 for Time. This indicates that the time input for the equation will be obtained from the specified
cell in the worksheet.

 To specify the existing Weibull++ analysis that the function result will be based on, click Select... to
open the Select Folio/Data Sheet window and then navigate to the desired sheet. If you have been
performing all of the examples in the Training Examples.rwp project as specified in this training guide,
this will be Data 1 in Folio4, as shown next.
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4.9  Example 8: Use the Function Wizard and General Spreadsheet
 Click OK to close the window and return to the Function Wizard. The wizard will look like the figure
shown next. 

 Click Insert to close the window and insert the function code into the General Spreadsheet. Functions
are inserted into the cell that was active when you opened the Function Wizard.

 Copy the function into cells B3 through B11. One way to do this is to position the mouse over the bottom
right corner of cell B2 and when the cursor turns into a plus symbol (+), click and drag the mouse to cell
B11.

 By selecting one of the cells that you copied the function into, you can see that the cell reference was
updated to match the current row, as shown next with cell B11 selected. 
 Weibull++ 7 Traning Guide 43



4  Step-by-Step Examples
The table that you have created displays the failure rate for each time in column A, based on the analysis in
the associated data sheet.

 Close the Folio, save any changes, leave the project open and proceed to the next example.

4.10  Example 9: Analyze Interval Data

Consider the interval data given below. The data set contains the inspection times of 167 identical parts in a
machine and the number of them found cracked at the end of each inspection time.

Determine the parameters of the 2-parameter Weibull distribution using Maximum Likelihood Estimation
and obtain the 3D Log-Likelihood Function surface plot.

The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Training Examples.rwp.” Use Folio5.

Solution

 With the “Training Examples.rwp” project open, create a new Standard Folio by selecting Add
Standard Folio... from the Project menu or by right-clicking inside the Project Explorer and selecting
Add Standard Folio... from the shortcut menu.

Number in State Last Inspected State State End Time

5 0 F 6.12

16 6.12 F 19.92

12 19.92 F 29.64

18 29.64 F 35.40

18 35.40 F 39.72

2 39.72 F 45.24

6 45.24 F 52.32

17 52.32 F 63.48

73 63.48 S 63.48
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4.10  Example 9: Analyze Interval Data
 In the New Data Sheet Setup window, select Times-to-failure data for the Folio Data Type and select all
of the options under Time-to-failure data options, as shown next.

 Click OK to create the new Standard Folio with the data sheet that you have specified.

 Enter the data and calculate the parameters with the 2-parameter Weibull distribution and MLE, as
shown next.

 Create the 3D Likelihood Function Surface plot by selecting ReliaSoft 3D (LK Function)... from the
Tools menu or by clicking the icon in the Control Panel or the General Tools toolbar.
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The plot is shown next.

To rotate the plot, click the plot then press the Ctrl key while holding down the left mouse button and
moving the mouse. Note that the peak of the surface is at the center of the beta-eta plane. 

 When you are finished experimenting with the 3D plot utility, close the window by selecting Close from
the File menu or by clicking the Close button in the toolbar.

 Close the Folio and save any changes to the project.

 Close the project by selecting Close from the File menu and proceed to the next example.
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4.11  Example 10: Analyze Accelerated Test Data
4.11  Example 10: Analyze Accelerated Test Data

A new product was reliability tested. Since the life of this product under operating conditions is expected to
be more than 15,000 hr, testing under these conditions is not time-wise feasible. For this reason, it was
decided to run an accelerated test for this product. The operating temperature for this product is 323K (50°C)
and temperature is the only acceleration variable. A table of the data obtained from the test for three different
operating stress levels is given below.

Do the following:

 Determine the parameters of the 2-parameter Weibull distribution at each stress level using Rank
Regression on X.

 Estimate the parameters for the Eyring model.

 What is the reliability of the unit for a mission duration of 9,000 hr, starting the mission at T = 0 and at
the operating temperature (323K)?

The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Accelerated Analysis.rwp.”

Solution

 Create a new project with a new Standard Folio for time-to-failure data. 

 The Subset ID column will be used to identify the stress level at which each failure time was observed.
To rename this column, double-click the column header, type “Temperature in K (Use is 323K)” in the
Change Heading window and click OK to update the data sheet. Note that you can edit all column
headings, row headings and tab names in a similar manner.

Stress Level, K 393K 408K 423K

Times-to-failure, hr

3850 3300 2750

4340 3720 3100

4760 4080 3400

5320 4560 3800

5740 4920 4100

6160 5280 4400

6580 5640 4700

7140 6120 5100

7980 6840 5700

8960 7680 6400
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4  Step-by-Step Examples
 Enter the data and calculate the parameters with the 2-parameter Weibull and RRX, as shown next (with
only the first 18 data points visible in the picture).

The Batch Auto Run feature allows you to break down the original data set into three different data sets

based on the different operating temperatures. The Batch Auto Run uses the Subset IDs to extract the data.7 

 Open the AutoRun window by selecting Batch Auto Run... from the Data menu or by clicking the
Batch Auto Run icon in the Control Panel or Data Analysis Tools toolbar.

 Click Select All Available> to apply the Batch Auto Run process to all three of the Subset IDs in the
current data set. The window will look like the figure shown next.

7. Batch Auto Run is presented in detail in Chapter 6 of the Weibull++ User’s Guide.
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4.11  Example 10: Analyze Accelerated Test Data
 Click the Set Action Preferences for Processing tab to view/set the calculation and sheet name options.
For this example, only the Calculate Parameters for Selected Subsets option will be selected, as
shown next. This indicates that the parameters will be calculated automatically for each extracted data
set.

 Click OK to initiate the Batch Auto Run process. 

 When the process is complete, the Folio will look like the one shown next.

You will notice that three new data sheets labeled 423K, 408K and 393K will appear in the Folio. Each data
sheet contains the data that has been extracted for the specified Subset ID (i.e. stress level). You can click
each tab to view the new data sheets. Notice that the parameters have already been calculated for each stress
level. 

 Insert a General Spreadsheet by selecting Insert General Spreadsheet from the Folio menu or by
clicking the icon.
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4  Step-by-Step Examples
 Enter the parameters that have been calculated for each stress level into the spreadsheet. You can type the
parameters or use the PARAMETER function in the Function Wizard. If you use the Function Wizard,
use 1 for the Param Index to return Beta and use 2 for the Param Index to return Eta.

 With some additional headings and explanations, the spreadsheet will look like the figure shown next.

The Non-Linear Equation Fit Solver can be used to estimate the parameters of the Eyring model.8

 Highlight the cells containing the stress and eta values (it is assumed that beta remains constant at each
stress level, which is the case for this data set). Copy the data to the Clipboard. 

8. The Non-Linear Equation Fit Solver is presented in detail in Chapter 17 of the Weibull++ User’s Guide.
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4.11  Example 10: Analyze Accelerated Test Data
 Open the Non-Linear Equation Fit Solver by selecting Add Other Tools then Add Equation Fit Solver
from the Project menu or shortcut menu. This window will now be accessible from the Project Explorer
and is currently active within the MDI, as shown next.

 Place the cursor into the first cell in the X column and paste the data that you copied from the General
Spreadsheet. Note that if you used the Function Wizard to enter the parameters in the General
Spreadsheet, you will need to select Paste Special then Paste Values from the Edit menu, as formulas
cannot be pasted into the Non-Linear Equation Fit Solver.

 In the Control Panel on the right, type the following equation for the Eyring model:

 Enter Eyring Acceleration Model for the Equation Name

 Click the Add to Templates icon to include this equation among the saved equation templates that can
be re-used at a later time in other analyses. 

1 X  A B X –  – exp
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4  Step-by-Step Examples
 Click OK to close the window that confirms that the equation has been saved. The window will now
look like the figure shown next. Notice that the focus was switched automatically to the Parameters sheet
when you typed the parameters to be solved for (A and B) into the equation.

 Enter the following values for the parameter A:

 Is greater than: -100

 Is less than: 1000

 Initial guess: 0.001

 Enter the following values for the parameter B:

 Is greater than: -100

 Is less than: 5000

 Initial guess: 0.001
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4.11  Example 10: Analyze Accelerated Test Data
 Select Calculate from the Equation menu or click the Calculate icon. The results are shown next.

The values for A and B are given within the “Value” column.9 The standard deviation for each parameter
appears within the “SDEV” column. Using the solution of the parameters for the Eyring model, you can
calculate the value of eta ( ) for any temperature (stress level), particularly in this case for the operating
temperature of 323K. 

9. Values may vary depending upon decimal places displayed to fit cell and window widths.


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4  Step-by-Step Examples
 Copy the solutions for the parameters of the Eyring model and paste them into the General Spreadsheet,
as shown next. 

To aid in the process of calculating eta at different stress levels, the parameters A and B will be defined as
named variables within the spreadsheet. This allows you to reference these values in a formula without
having to input the actual value.

 Click the cell containing the solution of A, in this case cell E11, and select Define Name... from the
Sheet menu to open the Defined Names window. Type “A” in the first row of the Name column then
click the Active Cell(s) button to associate the specified name with the cell that is currently active in the
spreadsheet.

 Type “B” in the second row of the Name column, go to the spreadsheet and click the cell containing the
solution of B (E12), return to the Define Names window then click the Active Cell(s) button again. The
window will look like the figure shown next.
54 http://Weibull.ReliaSoft.com



4.11  Example 10: Analyze Accelerated Test Data
 Click Close to save these variable name definitions and return to the General Spreadsheet.

 Using the Eyring model and the defined parameters, A and B, create a table like the one shown next to
calculate the value of eta for a range of temperatures (323K-443K). For example, for cell C20, enter the
following formula: =(1/B20)*exp(-(A-(B/B20))) and press Enter. Be sure to type the formula as it
applies to the current structure of your General Spreadsheet.

The value of eta at a stress level of 323K is estimated to be approximately 17933.85.

The final part of this example involves estimating the reliability of the product at the operating stress level
(323K) for 9,000 hr of operation. The Weibull distribution was used to calculate the values of the parameters
eta and beta. 

The Weibull reliability function is given by:

 Create a table of reliabilities for a range of different end times (1000 - 10000 hr) within the General
Spreadsheet using the Weibull reliability function. When referencing the cells containing the values of
beta and eta within the formula to calculate the reliability, you must refer to these cells as an absolute
reference. This involves inserting a $ in front of the column letter and the row number. In the next figure,
the values of beta and eta are located within cells B36 and B37, respectively. When typing the formula
for the Weibull reliability function, these two cells must be referenced using the following format: $B$36
and $B$37. In cell B41, enter the following formula: =exp(-((A41/$B$37)^$B$36)). Copy the formula
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=
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4  Step-by-Step Examples
down to cell B50. The reliability has now been calculated for all of the end times in question, as shown
next.

The reliability at 9,000 hr is estimated to be 94.6979%. 

 Save the project as “Accelerated Analysis.rwp” then close the project and proceed to the next example. 

4.12  Example 11: Degradation Data Analysis

Five turbine blades were tested for crack propagation. The test units were cyclically stressed and inspected
every 100,000 cycles for crack length. Failure is defined as a crack of length 30mm or greater. Following is
a table of the test results:

Using Weibull++'s Degradation Analysis module and the Quick Calculation Pad, determine the B10 life for
the blades using degradation analysis with an exponential model for the extrapolation.

The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Degradation Analysis.rwp.”
 

Cycles 
(x1000)

Unit A Unit B Unit C Unit D Unit E

100 15mm 10mm 17mm 12mm 10mm

200 20mm 15mm 25mm 16mm 15mm

300 22mm 20mm 26mm 17mm 20mm

400 26mm 25mm 27mm 20mm 26mm

500 29mm 30mm 33mm 26mm 33mm
56 http://Weibull.ReliaSoft.com



4.12  Example 11: Degradation Data Analysis
Solution
 
 Create a new project. On the second page of the Project Wizard, select Degradation Analysis Folio, as

shown next then click Finish. This will add a folio to the new project that has been specially designed for
degradation analysis.

 Enter the data, select Exponential for the model and enter 30 for the Critical Degradation, as shown
next. There is no suspension time for this example.
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4  Step-by-Step Examples
 Apply the model to the data set by selecting Calculate from the Data menu or by clicking the Calculate
icon. 

 To view the calculated parameters, click the Show Fit Parameters button in the Control Panel. To view
the extrapolated failure times, click the Show Extrapolated Values button.

The parameter results are shown next.

 Click Close to close the Results Panel window.

 Plot the results in a new sheet by selecting Plot from the Data menu or by clicking the Plot icon. With all
units selected to be displayed, the plot will look like the one shown next.
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4.12  Example 11: Degradation Data Analysis
 To transfer the extrapolated failure times to a Standard Folio, return to the Data sheet and select Transfer
Life Data to New Folio from the Data menu or click the icon. 

 Double-click Folio1 in the Project Explorer to open the new Standard Folio that the failure and
suspension times were transferred to. Select the 2-parameter Weibull distribution with MLE and
calculate the parameters. The estimated parameters for this data set are beta = 8.0551 and eta = 519.5554,
as shown next.

Note that the Specialized Folio that you created for the degradation analysis is now associated with the
Standard Folio that you transferred the life data to. You can click the link at the bottom of the Control Panel
to open the associated Degradation Analysis Folio. In addition, if you change and re-calculate the
degradation analysis, the associated Standard Folio will be updated automatically.
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4  Step-by-Step Examples
 Open the Quick Calculation Pad. Select BX Information and enter 10 for the percentage. Click
Calculate. The results are shown next.

Using the Degradation Analysis utility and the QCP, the B10 life is calculated to be 392,918 cycles.

 Close the QCP.

 Save the project as “Degradation Analysis.rwp” then close the project and proceed to the next example. 

4.13  Example 12: Warranty Data Analysis

A company keeps track of its shipments and warranty returns on a month-by-month basis. Following is a
table for shipments in June, July and August and the warranty returns through September:

Do the following:

 Using Weibull++'s Warranty Analysis module, convert this information to life data and determine the
parameters for a 2-parameter Weibull distribution.

 Predict the number of products from each of the three shipment periods that will be returned under
warranty in October.

The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Warranty Analysis.rwp.”

Returns

Months Shipments July Aug. Sept.

June 100 3 3 5

July 140 - 2 4

Aug. 150 - - 4
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4.13  Example 12: Warranty Data Analysis
Solution

 Create a new project. On the second page of the Project Wizard, select Warranty Analysis Folio, as
shown next.

 Click Next> to proceed to the next step. Select I want to enter data in “Nevada” format, as shown
next, and then click Next>.

 In the next step:

 Select Months for the unit type.

 Select Allow Returns at Time = 0.

 Type June 2005 for the first month of the sales data and specify 3 periods, incremented by 1.

 Type July 2005 for the first month of returns data and specify 3 periods incremented by 1.
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4  Step-by-Step Examples
The window will look like the figure shown next.

 Click Finish to create the Warranty Analysis Folio.

 Enter the shipments data in the Quantity In-Service column on the Sales sheet, as shown next.

 Enter the returns data in the Returns sheet (where the row represents the shipment month and the column
represents the return month).
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4.13  Example 12: Warranty Data Analysis
 Select the 2-parameter Weibull distribution with MLE and calculate the parameters. The window will
look like the figure shown next.

 To transfer the life data to a Standard Folio, select Transfer Life Data to New Folio from the Data
menu or click the icon. 
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4  Step-by-Step Examples
 Double-click Folio1 in the Project Explorer to open the new Standard Folio that the failure and
suspension times were transferred to. The estimated parameters for this data set are beta = 2.4928 and eta
= 6.6951, as shown next.

 Return the focus to the Warranty Analysis Folio and select Generate Forecast from the Data menu or
click the icon.

 Accept the defaults in the Forecast Setup window, as shown next, and click OK.

A new sheet called “Forecast” will be added to the Folio to display the number of failures that can be
expected from each shipment in upcoming months. As shown next, the predicted number of products that
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4.14  Example 13: Competing Failure Modes Analysis
will be returned in October are 12 from the June shipment, 11 from the July shipment and 6 from the August
shipment for a total of 29 returned units.

 Save the project as “Warranty Analysis.rwp” then close the project and proceed to the next example. 

4.14  Example 13: Competing Failure Modes Analysis

This example has been abstracted from Example 15.6 from the Meeker and Escobar textbook Statistical
Methods for Reliability Data, published by John Wiley and Sons. 

An electrical component has two failure modes. One failure mode is due to random voltage spikes, which
cause failure by overloading the system. This failure mode is denoted by a V in the table. The other failure
mode is due to wear-out failures, which usually happen only after the system has run for many cycles. This
failure mode is denoted by a W in the table. The following table shows time-to-failure data for each mode,
along with suspension data.
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4  Step-by-Step Examples
*Failure times are given in thousands of cycles.

Do the following: 

 Determine the overall reliability for the component at 100,000 cycles.

 Plot the competing failure modes.

The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Competing Failure Modes.rwp.”

Solution

 Create a new project with a Standard Folio for times-to-failure data with suspensions and grouped data.

Number in 
State

Failure 
Time*

Failure 
Mode

Number 
in State

Failure 
Time*

Failure 
Mode

1 2 V 1 147 W

1 10 V 1 173 V

1 13 V 1 181 W

2 23 V 1 212 W

1 28 V 1 245 W

1 30 V 1 247 V

1 65 V 1 261 V

1 80 V 1 266 W

1 88 V 1 275 W

1 106 V 1 293 W

1 143 V 8 300 sus-
pended
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4.14  Example 13: Competing Failure Modes Analysis
 Using the Subset ID column to identify the failure mode, enter the data into the Folio. Select the Weibull
distribution with Competing Failure Modes (CFM) and MLE, as shown next.

When the CFM option is selected and you click Calculate, the Competing Failure Modes Select Subsets
window will appear. This allows you to identify the competing failure modes, based on Subset ID. Note that
you can also open this window by clicking the Set... link to the right of the CFM option.

 Place the V failure mode into the Mode 1 column and place the W failure mode into the Mode 2 column,
as shown next. To do this, click a subset ID (mode) from the Available panel and select a Mode panel to
place the subset ID into. Click (+) to add the selected Subset ID to the Mode panel. Click (X) to remove
the selected Subset ID from the Mode panel. You can also double-click or drag and drop a Subset ID to
add or remove it from a panel.
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4  Step-by-Step Examples
 Click OK to close the window and calculate the parameters for both modes. The results displayed in the
Control Panel correspond to the mode currently selected in the menu above the Settings area (Mode __
out of __). The next figure shows the parameters for Failure Mode 1, or the V failure mode.

 The estimated parameters for Failure Mode 1 (the random voltage spikes failures) are beta = .6711 and
eta = 449.4272. The estimated parameters for Failure Mode 2 (the wear-out failures) are beta = 4.3373
and eta = 340.3842.

 Open the Quick Calculation Pad and determine the overall reliability of the system at 100,000 cycles, as
shown next.
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4.15  Example 14: Weibull-Bayesian Analysis
Using the Competing Failure Modes and QCP, the overall reliability for the component at 100,000 cycles is
estimated to be 69.1%.

 Close the QCP.

 Generate the Weibull Probability plot for this analysis, as shown next with labels added (via RS Draw) to
identify the lines for each individual failure mode and for the combined analysis.

 Save the project as “Competing Failure Modes.rwp” then close the project and proceed to the next
example.

4.15  Example 14: Weibull-Bayesian Analysis

A redesign is being reliability tested. Test data from the original design is available. The original cycles-to-
failure data set (in thousands) is as follows:

11.1 66.1 79.6 106.8

43.9 67.3 93.8 109.9

56.4 73.8 93.9 110.8

59.5 74.6 99.6 119.6

60.8 75.9 104.3 160
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4  Step-by-Step Examples
The test of the redesign yielded the following data set (in thousands) after 50,000 cycles of testing.

Do the following: 

 Using a Weibull-Bayesian approach, compute the demonstrated reliability for the redesign at 10,000
cycles at a 90% lower 1-sided confidence level. 

 Repeat this analysis using a standard 2-parameter Weibull approach with Rank Regression on X. 

 Compare the results.

The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Weibull-Bayesian.rwp.”

Solution

 Create a new project with a Standard Folio for individual times-to-failure data. Rename the Folio to
“Bayesian.”

 Rename the data sheet to “Prior” by double-clicking the tab and typing the new name in the Sheet Name
window.

Time F/S

24 F

34 F

50 F

50 S

50 S

50 S
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4.15  Example 14: Weibull-Bayesian Analysis
 Enter the data and calculate the parameters with the 2-parameter Weibull distribution and Rank
Regression on X, as shown next.

 Select Add Report... from the Project menu to add a Report to the project.

 In the Report Wizard window, select the “Prior” data sheet as the default data source, as shown next, then
click OK. 
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4  Step-by-Step Examples
 Build a table like the one shown next, which will contain the Beta parameter values for a range of
confidence levels. Note that the confidence level is entered as a decimal in column D and an equation is
used to convert the decimal to a percentage in column C (e.g. =D6*100).

 With the first Beta parameter cell selected (i.e. B6), open the Function Wizard by selecting Function
Wizard from the Data menu or by clicking the Function Wizard icon.

 Select the PARAMETER function then enter 1 for Param Index and D6 for [Conf Level]. Leave Use
Default selected for the data source. This indicates that the function will return the first parameter for the
analysis in the “Prior” data sheet at the confidence level specified in the referenced cell of the
spreadsheet. 
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4.15  Example 14: Weibull-Bayesian Analysis
The Function Wizard will look like the figure shown next.

 Click Insert to close the Function Wizard and insert the function into the active cell.

 Copy the function from cell B6 to B16 to obtain the Beta values for each confidence level. The table will
look like the one in the figure shown next.

 Copy the first two columns of data (i.e. the Beta values and the confidence level percentages) and then
return to the Standard Folio. 

 Select Insert Data Sheet from the Folio menu to insert a new data sheet for Free-Form (Probit) data
called “B Distribution.” 
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4  Step-by-Step Examples
 Use the Paste Values command to paste the data into the new sheet and calculate the parameters with the

2-parameter Lognormal distribution and Rank Regression on X, as shown next.10

 Generate a probability plot for this analysis, as shown next.

 Insert another new data sheet for individual times-to-failure data with suspensions named “New.” 

10.The Paste Values command is necessary to paste the confidence level percentage (rather than the formula) copied
from the Report spreadsheet. Select Paste Special then Paste Values from the Edit menu.
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4.15  Example 14: Weibull-Bayesian Analysis
 Enter the data for the redesign (given in the second table of the problem statement) and select the
Weibull-Bayesian distribution with MLE. When you attempt to calculate the parameters, you will be
prompted to enter the distribution/parameters for Beta based on prior information. Enter the results from
the B Distribution data sheet (rounded to three decimal places), as shown next.

 Click OK. The data sheet with the Weibull-Bayesian parameters calculated is shown next.
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4  Step-by-Step Examples
 Generate a probability plot with 2-sided 90% confidence bounds (Type I), as shown next with the scaling
manually adjusted.

 Return to the “New” data sheet and open the Quick Calculation Pad. Calculate the reliability at 10,000
cycles with 90% lower 1-sided confidence bounds (Type I). Since the data points were entered as
thousands of cycles, you will enter 10 for the Mission End Time, as shown next.

 Create a new Standard Folio for individual times-to-failure data with suspensions.
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4.15  Example 14: Weibull-Bayesian Analysis
 Enter the redesign data and use the 2-parameter Weibull distribution with Rank Regression on X to
calculate the parameters, as shown next.

 Generate a probability plot for the analysis, as shown next.
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4  Step-by-Step Examples
 Return to the data sheet then use the QCP to calculate the reliability at 10,000 cycles with 90% lower 1-
sided confidence bounds (Type I). Again, enter 10 for the Mission End Time since the data points were
entered as thousands of cycles, as shown next.

As you can see, the Weibull-Bayesian analysis estimates a reliability of 98.69% with a lower limit of 96.31%
while the standard Weibull analysis estimates 98.19% with a lower limit of 80.24%.

 Close the QCP, save the project as “Weibull-Bayesian.rwp” then close the project and proceed to the next
example.

4.16  Example 15: Failure Modes RBD Analysis

Assume that a component can fail due to six independent primary failure modes: A, B, C, D, E and F. The
component fails if mode A, B or C occurs. If mode D, E or F occurs alone, the component does not fail;
however, the component will fail if any two (or more) of these modes occur (i.e. D and E; D and F; E and F).
The following tables present the time-to-failure data for these modes (in hr). Use the 2-parameter Weibull
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4.16  Example 15: Failure Modes RBD Analysis
distribution with MLE to analyze each data set and determine the lower 1-sided 90% confidence interval on
the reliability of this component at 100 hr. 

Mode A Mode B Mode C

Number 
in Group

State Time Number 
in Group

State Time Number 
in Group

State Time

1 F 1144 1 F 19 1 F 2221

1 F 1719 1 F 140 1 F 2257

1 F 2129 1 F 292 1 S 2569

1 F 2803 1 F 432 1 F 3029

1 F 3020 1 F 528 1 F 3805

1 F 3082 1 F 552 10 S 5000

1 F 3589 1 F 605

1 F 3973 1 F 734

1 F 4337 1 F 779

1 F 5011 1 F 874

1 F 5029

18 S 5500

Mode D Mode E Mode F

Number 
in Group

State Time Number 
in Group

State Time Number 
in Group

State Time

1 F 1063 1 F 1290 1 F 605

1 F 1085 1 F 2261 1 F 760

1 F 1399 1 F 2355 1 F 773

1 F 1445 1 F 3209 1 F 854

1 F 1550 1 F 3284 1 F 890

1 F 2056 1 F 3394 1 F 1165

1 F 4384 1 F 3596 1 F 1220

1 F 4863 1 F 4203 1 F 1320

8 S 5000 1 F 4254 1 F 1967

1 F 4294 1 F 2606

1 F 4420 1 F 2834

10 S 5000 15 S 3000
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4  Step-by-Step Examples
The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Mode Diagram.rwp.”

Solution

 Create a new project with a Standard Folio for grouped times-to-failure data with suspensions. Rename
the Folio to “Component.”

 Rename the data sheet to “A,” enter the data given for Failure Mode A and use the 2-parameter Weibull
distribution with MLE to calculate the parameters, as shown next.

 Insert another data sheet of the same type named “B,” enter the data given for Failure Mode B and
calculate the parameters. Repeat the procedure for the remaining failure modes.
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4.16  Example 15: Failure Modes RBD Analysis
 After you have entered and calculated the data for all six failure modes, select Add Diagram from the
Project menu to add a Diagram to the project that contains a template block for each data sheet in the
project, as shown next.

 Build the RBD that describes the reliability-wise configuration of the failure modes. 

To add a block representing a calculated data set, drag the block from the template and drop it into the
diagram. To add the node, select Add Node from the Diagram menu or shortcut menu. Double-click the
node to specify the number of paths leading into the node that must succeed (i.e. 2 out of the 3 paths for this
example). To add the relationship lines, select Join Blocks from the Diagram menu or shortcut menu then
drag lines between blocks to connect them. After you are finished connecting blocks, right-click inside the
diagram to return the cursor to the normal mode. 
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4  Step-by-Step Examples
The diagram will look like the one shown next. 

 Select Calculate from the Diagram menu or click the Calculate icon to analyze the diagram.

 Select Quick Calculation Pad... from the Diagram menu or click the icon to open the QCP. Calculate
the reliability at 100 hr with the lower 1-sided 90% confidence bound, as shown next.

The lower bound is estimated to be 82.23%.

 Close the QCP, save the project as “Mode Diagram.rwp” then close the project and proceed to the next
example.
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4.17  Example 16: Determine Optimum Burn-In Time
4.17  Example 16: Determine Optimum Burn-In Time

An electronic component is undergoing burn-in testing. During burn-in, the following cumulative percent
failed is observed: 

 5% failed by 10 hr

 6% failed by 50 hr

 7% failed by 100 hr

Assume that the cost per hour of burn-in is $10. Additionally, each discovered failure during burn-in costs
$50. If a unit fails in the field, the cost is $4,000. Determine the optimum burn-in time.

The file for this example is located in the “Training Guide” folder in your application directory (e.g.
C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Optimum Burn-in.rwp.”

Solution

 Create a new project with a Standard Folio for free-form data.

 Enter the data and use the 2-parameter Weibull distribution with Rank Regression on X to calculate the
parameters, as shown next.
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4  Step-by-Step Examples
 Select Add Report... from the Project menu. In the Report Wizard, specify the calculated data sheet as
the default data source and select to create the report based on the Optimum Burn-in.wrt report
template that is shipped with the software, as shown next. 

 Click OK to create the report.
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4.17  Example 16: Determine Optimum Burn-In Time
 Enter the costs for this example in the Cost Inputs area at the top of the template (shown in bold blue
text) and accept the other default inputs. The window will look like the figure shown next. 

The optimum burn-in time is 2.3 hr.

 Save the project as “Optimum Burn-in.rwp” then close the project.
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This section contains some additional practice questions. The next section presents solutions to these
examples. The file for these examples is located in the “Training Guide” folder in your application directory
(e.g. C:\Program Files\ReliaSoft\Weibull7\Training Guide) and is named “Practice Questions.rwp.”

5.1  Practice Question 1

Six units were reliability tested and the following times-to-failure were observed: 48, 64, 83, 105, 123 and
150 hr. Do the following:

1. Determine how you would classify this data set, i.e. individual, grouped, suspended, censored, uncen-
sored, etc.

2. Create a new project and Standard Folio for individual times-to-failure data with no censoring, named
“Question1.”

3. Enter the data and select Rank Regression on X as the parameter estimation method.

4. Determine the parameters for this data set using the following distributions and plot the data for each
distribution. From the plot, note how well you think each distribution tracks the data, i.e. how well does
the fitted line track the plotted points?

i. 2-parameter Weibull

ii. 3-parameter Weibull

iii. Normal

iv. Lognormal

v. 1-parameter Exponential

vi. 2-parameter Exponential

5. Use the Distribution Wizard to determine the distribution that best fits your data. Compare with what
you have observed.

7. Save the project as “Practice Questions.rwp.” Close the Folio but leave the project open. 

5.2  Practice Question 2

ACME manufacturing implemented a reliability tracking program for a recent product. A total of 96 units
were released in a small test market. 10 units failed sometime between 0 - 68 hr, 10 units failed between 68 -
90 hr, 10 units failed between 90 - 120 hr and 7 failed between 120 - 130 hr. 59 units were still in the field
after successfully operating for 153 hr. Do the following:

1. Create a new Standard Folio for grouped times-to-failure data with suspensions and interval censoring, 
named “Question2.”

2. Enter the data and determine the parameters of the 2-parameter Weibull distribution using Rank Regres-
sion on X.

Practice Questions 5
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5  Practice Questions
3. Obtain the probability plot for this data set.

4. Plot the 90%, 2-sided confidence bounds (Type II). Export the plot graphic as MyPlot1.wmf.

5. Experiment with annotating the plot while in RS Draw.

6. From the plot, determine:

i. The reliability of these units for a mission of 50 hr, R(50hr).

ii. The 90%, 2-sided confidence bounds on the reliability for a mission of 50 hr (Type II).

iii. The mission duration for these units if ACME Inc. requires a 90% reliability at the 50% confidence
level.

iv. The mission range if ACME Inc. requires a 90% reliability at the 90% confidence level (Type I).

7. Using the Quick Calculation Pad, determine:

i. The reliability of these units for a mission of 50 hr, R(50hr).

ii. The 90%, 2-sided confidence bounds on the reliability for a mission of 50 hr.

iii. The mission duration for these units if ACME Inc. requires a 90% reliability at the 50% confidence
level.

iv. The mission range if ACME Inc. requires a 90% reliability at the 90% confidence level.

v. The 2-sided confidence bounds on the parameters.

8. Obtain the Reliability vs. Time plot for these units.

6. Obtain the pdf plot for these units.

7. Obtain the Failure Rate vs. Time plot for these units. From the plot, what is the failure rate of these units
at 100 hr?

8. Save your changes to the project and close the Folio.

8.3  Practice Question 3

1. Create a new Standard Folio for individual times-to-failure data with no censoring, named “Question3.”

2. Rename the data sheet to “MLE” then copy and paste the data from “Question1.” Use the 2-parameter
Weibull distribution and Maximum Likelihood Estimation to calculate the parameters.

3. Insert a new data sheet named “RRX” and paste the data set into the new sheet. Use the 2-parameter
Weibull distribution and Rank Regression on X to calculate the parameters.

4. Plot both data sets individually.

5. Customize both plots to your liking.

6. Add a Multiple Plot Sheet to the project (named “Question3”) and select both data sets to be displayed.
(Note that both are made up of the same data. Do you see a difference? Why?)

7. Save your changes to the project and close the Folios and Multiple Plot Sheet.
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7.4  Practice Question 4
7.4  Practice Question 4

ACME Manufacturing is preparing to purchase a new component for one of its products. Two competing
manufacturers presented ACME with the following test data. Each manufacturer tested 8 units to failure
with the following results:

1. Create a new Standard Folio for individual times-to-failure data with no censoring, named “Question4.”

2. Enter the data for each manufacturer into separate data sheets (named “A” and “B”) and determine the
parameters of the 2-parameter Weibull distribution using Rank Regression on X.

3. Use the Tests of Comparison utility to calculate the probability that Manufacturer A is better than Man-
ufacturer B. Which design would you choose?

4. Save your changes to the project, close the Comparison Wizard and close the Folio.

4.5  Practice Question 5

As you may have noticed, plotting the data points and seeing how well the line runs through the points is an
indication of how well the calculated parameters fit the data (or how correct the calculation is). However,
when you use Maximum Likelihood Estimation, the data points do not, in general, track the plotted line. The
reasons lie in the way the parameters are estimated. One way to view this convergence, since MLE
maximizes the Likelihood Function, is to view the 3D plot of the Log-Likelihood Function. Weibull++ lets
you do just that.

1. Duplicate the “Question1” Folio and name the copy “Question5.”

2. Calculate the parameters using the 2-parameter Weibull distribution and MLE as the parameter estima-
tion method.

3. Plot the Log-Likelihood Function using 3D Plot.

4. Press Ctrl and click the plot. Move the mouse simultaneously in the direction you would like to rotate
the plot.

5. Rotate the plot and view the maximum beta.

6. Rotate the plot again and view the maximum eta.

7. Close 3D Plot and insert a General Spreadsheet into the Folio.

8. Use the Function Wizard to create a table of Reliabilities with 90% 2-sided confidence bounds for a
time range of 10 to 100, incremented by 5. Note: To get the 2-sided bounds, create one function for the
CL at .05 (lower bound) and a second function for the CL at .95 (upper bound).

9. Save your changes to the project and close the Folio.

Manufacturer A
Time to failure, hr

Manufacturer B
Time to failure, hr

1900 2000

2600 4250

1400 1300

1300 600

800 3000

2650 6600

1850 9000

2400 12000
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5  Practice Questions
9.6  Practice Question 6

The Monte Carlo Data generation is a useful tool when dealing with simulations. You can use it to generate
values for any distribution or function. This example will take you through such a scenario.

1. Create a new Standard Folio for times-to-failure data with no censoring, named “Question6.” 

2. Select Generate Monte Carlo Data... from the Tools menu or click the icon. 

3. Generate a data set using the 2-parameter Weibull distribution with beta = 2 and eta = 1500 hr. Select to
put the data points into the current Folio and Sheet.

4. Calculate the parameters.

5. Are the parameters equal to the ones used in the Monte Carlo tool? Comments?

6. Generate another Monte Carlo data set using the same distribution and parameters. Select to put the data
points into the current Folio and a new Sheet.

7. Compare the two sets. Are they the same?

8. Save your changes to the project and close the Folio.

8.7  Practice Question 7

Your new manager has to be convinced that product X has an MTBF of 1000 hr with a 95% confidence
level. You know from past experience that the shape parameter for this product is 1.5. Due to time
constraints, you are allowed to test the units for no more than 500 hr. Using ReliaSoft's Design of Reliability
Tests (DRT) utility, find the number of units that have to be tested if:

1. No failures are allowed.

2. One failure is allowed.

3. Experiment with the other cases using the DRT.

3.8  Practice Question 8

The next table presents a data set corresponding to the times-to-failure for two samples of the same product,
samples A and B. Both samples are assumed to be identical, so the times-to-failure were entered together in
the same data sheet, utilizing the Subset ID column to identify each sample.

Using the Batch Auto Run feature, extract two different data sets. Do the following:

Time-to-failure, hr Subset ID

49 A

71 A

80 A

85 A

93 A

100 A

16 B

18 B

30 B

34 B

50 B

201 B
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5.9  Practice Question 9
1. Create a new Standard Folio for times-to-failure data with no censoring, named “Question8.”

2. Calculate the parameters for each data set using the 2-parameter Weibull distribution with Rank Regres-
sion on X.

3. Compare the two sets using the Tests of Comparison utility.

4. Create a Multiple Plot Sheet (named “Question8”) and plot the two data sets together.

5. Save your changes to the project and close the Folio.

5.9  Practice Question 9

For this example, design a test to demonstrate a reliability of 90% at t = 100 hr, with a 95% confidence.
Assume a Weibull distribution with a shape parameter beta = 1.5. No failures will be allowed on this test, or
f = 0.

Using the DRT (Design of Reliability Testing) utility, determine the following:

1. The number of units to test for 48 hr (in integers). 

2. The test time for 20 units.
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This section provides answers to the Practice Questions in Chapter 5. 

6.1  Practice Question 1

1. Individual times-to-failure (complete)

4. Parameter values for each distribution:

i. 2-parameter Weibull  = 2.5147,  = 108.5178

ii. 3-parameter Weibull  = 1.8021,  = 86.0358,  = 21.2200

iii. Normal  = 95.5000,  = 42.8050

iv. Lognormal  = 4.4876,  = 0.4767

v. 1-parameter Exponential  = 0.0119

vi. 2-parameter Exponential  = 0.0196,  = 48.0000

5. The Distribution Wizard suggests the 3-parameter Weibull distribution.

6.2  Practice Question 2

1. 2-parameter Weibull  = 1.6284,  = 195.4625

Answers to Practice 
Questions 6

 

  

 

 



 

 
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6  Answers to Practice Questions
4. Probability plot with confidence bounds:

6. From the plot:

i. R(50 hr) @ 89%

ii. Upper CL @ 93.6%, Lower CL @ 83%

iii. Mission Duration @ 50 hr

iv. Requires a mission range of approximately 37-68 hr

7. From the QCP:

i. R(50 hr) = 89.71%

ii. Upper CL = 93.58%, Lower CL = 83.71%

iii. Mission Duration = 49.0802 hr

iv. Requires a mission range of 36.1255 - 66.6805 hr

v. For : 1.3039, 2.0337

For : 171.3340, 222.9889
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6.3  Practice Question 3
8. Reliability vs. Time plot:

9. pdf plot:

10. Failure Rate at 100 hr =  .0055

6.3  Practice Question 3

2. For MLE:  = 3.0622,  = 107.2451

3. For RRX:  = 2.5147,  = 108.5178
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6  Answers to Practice Questions
6. MultiPlot for MLE and RRX:

6.4  Practice Question 4

2. Manufacturer A:  = 2.7017,  = 2107.2287

Manufacturer B:  = 1.0796,  = 5322.1346

7. Manufacturer B is better with a 73% probability
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7.5  Practice Question 5
7.5  Practice Question 5

2.  = 3.0622,  = 107.2451

8. Reliability for time increments from 10 to 100 with a 2-sided confidence level at 90%:

7.6  Practice Question 6

5. The parameters are not equal because the data set was generated via simulation.

7. The two data sets are not the same because they were generated via simulation.

7.7  Practice Question 7

1. 10 units

2. 17 units

2.8  Practice Question 8

2. Product A:  = 4.2669,  = 87.3813

Product B:  = 1.3121,  = 55.4934

Time Lower CL Reliability Upper CL

10 0.9557 0.9993 1.0000

15 0.9217 0.9976 0.9999

20 0.8834 0.9942 0.9997

25 0.8419 0.9885 0.9992

30 0.7982 0.9800 0.9982

35 0.7529 0.9681 0.9963

40 0.7065 0.9524 0.9932

45 0.6596 0.9324 0.9883

50 0.6125 0.9079 0.9811

55 0.5654 0.8786 0.9711

60 0.5187 0.8446 0.9575

65 0.4725 0.8059 0.9398

70 0.4271 0.7628 0.9174

75 0.3825 0.7157 0.8901

80 0.3390 0.6653 0.8576

85 0.2968 0.6122 0.8202

90 0.2559 0.5573 0.7782

95 0.2169 0.5016 0.7325

100 0.1799 0.4461 0.6840

 

 

 
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6  Answers to Practice Questions
4. Probability plot for both data sets:

2.9  Practice Question 9

1. 86 units

2. 126 hr

ReliaSoft Weibull++ 7 - www.ReliaSoft.com

Probability - Weibull

Question 8\B: 
Question 8\A: 

Time, (t)

U
nr

el
ia

bi
lit

y,
 F

(t
)

10.000 1000.000100.000
10.000

50.000

90.000

99.000 Probability-Weibull

Question 8\A
Weibull-2P
RRX SRM MED FM
F=6/S=0

Data Points
Probability Line

Question 8\B
Weibull-2P
RRX SRM MED FM
F=6/S=0

Data Points
Probability Line

Name
Company
10/7/2005
1:25:54 PM
98 http://Weibull.ReliaSoft.com


	1
Weibull++ 7 Training Guide
	1.1 About this Training Guide
	1.2 Other Example Files
	1.3 Weibull++ 7 Documentation
	1.4 Contacting ReliaSoft

	2
Features Summary
	2.1 Intuitive and Flexible Work Environment
	2.2 All the Tools You Need for Standard Life Data Analysis
	2.2.1 Support for All Life Data Types and Multiple Lifetime Distributions
	2.2.2 Choice of Parameter Estimation Methods

	2.3 Results and Plots at the Click of a Button
	2.3.1 Quick Calculation Pad
	2.3.2 Plots and Graphics to Showcase Your Analyses
	2.3.3 Confidence Bounds for Parameters and Results

	2.4 A Complete Array of Related Analyses
	2.5 Additional Tools and Wizards
	2.5.1 Spreadsheets for Custom Analyses
	2.5.2 Template-Based Report Generator
	2.5.3 References and Wizards

	2.6 Data Import and Integration with Other ReliaSoft Software
	2.7 Configure the Workspace to Meet Individual Needs
	2.8 System Requirements

	3
First Steps
	3.1 Starting Weibull++ 7
	3.2 Multiple Document Interface
	3.3 Getting Help in the Weibull++ Environment
	3.4 First Steps Example

	4
Step-by-Step Examples
	4.1 List of Examples
	4.2 Example 1: Life Data Analysis with Complete and Suspended Data
	4.3 Example 2: Obtain the Unreliability for a Given Operating Time
	4.4 Example 3: Calculate Conditional Reliability and Warranty Time
	4.5 Example 4: 3-Parameter Weibull Analysis
	4.6 Example 5: 2-Parameter Exponential Analysis and Plots
	4.7 Example 6: Normal Probability Plot with Confidence Bounds
	4.8 Example 7: Calculate Reliability and MTTF with Confidence Bounds
	4.9 Example 8: Use the Function Wizard and General Spreadsheet
	4.10 Example 9: Analyze Interval Data
	4.11 Example 10: Analyze Accelerated Test Data
	4.12 Example 11: Degradation Data Analysis
	4.13 Example 12: Warranty Data Analysis
	4.14 Example 13: Competing Failure Modes Analysis
	4.15 Example 14: Weibull-Bayesian Analysis
	4.16 Example 15: Failure Modes RBD Analysis
	4.17 Example 16: Determine Optimum Burn-In Time

	5
Practice Questions
	5.1 Practice Question 1
	5.2 Practice Question 2
	8.3 Practice Question 3
	7.4 Practice Question 4
	4.5 Practice Question 5
	9.6 Practice Question 6
	8.7 Practice Question 7
	3.8 Practice Question 8
	5.9 Practice Question 9

	6
Answers to Practice Questions
	6.1 Practice Question 1
	6.2 Practice Question 2
	6.3 Practice Question 3
	6.4 Practice Question 4
	7.5 Practice Question 5
	7.6 Practice Question 6
	7.7 Practice Question 7
	2.8 Practice Question 8
	2.9 Practice Question 9


