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1.1  About this Training Guide

This Training Guide is intended to provide you with many examples to demonstrate the use of Xfmea. It
begins with step-by-step examples and then proceeds into more advanced examples. 

Some of the examples in this Training Guide require you to access files that have been shipped with the
Xfmea application. These files are located in the Training and Examples folders in your application
directory (e.g. C:\Program Files\ReliaSoft\Xfmea5\Training or 
C:\Program Files\ReliaSoft\Xfmea5\Examples). The Examples folder is also accessible by clicking the
Open Examples Folder link in the Get Started window or by choosing Help > Open Examples Folder.

1.2  Xfmea Documentation

Like all of ReliaSoft's standard software products, Xfmea is shipped with detailed
printed documentation on the product (Xfmea User's Guide). This Training Guide is
intended to be a supplement to that reference.

1.3  Minimum System Requirements

Xfmea is compiled and designed for Microsoft Windows XP, Vista and Windows 7
and takes advantage of the features available in these platforms.

Minimum system requirements:

 Windows XP (service pack 2 or higher), Vista and Windows 7.

 Microsoft Office 2000 or higher (Excel and Word) for automated report generation.

 Intel Celeron or Pentium class or AMD processor with 256MB RAM (512MB or more is
recommended), SVGA display and at least 290MB of hard disk space.

 Internet Explorer 6 or higher. A free download is available from Microsoft at 
http://www.microsoft.com/windows/internet-explorer/.

 Microsoft SQL Server 2005 or 2008 to use the Enterprise database capabilities.

 Network access to the database server (if connecting to a SQL Server database).

Please note that if you have set your computer to use large fonts, you will need to set your screen display to
1024x768 in order for all windows to display correctly.
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1.4  Contacting ReliaSoft

ReliaSoft can be reached at:
ReliaSoft Corporation
Worldwide Headquarters

1450 S. Eastside Loop
Tucson, AZ 85710-6703   USA

Phone: +1.520.886.0410
Fax: +1.520.886.0399

E-mail: Support@ReliaSoft.com

For up-to-date product information, visit our Web site at:
http://Xfmea.ReliaSoft.com

For assistance, you may contact our Worldwide Headquarters in Tucson, Arizona or go to 
http://Directory.ReliaSoft.com to locate the regional office nearest you.



Xfmea Training Guide 3

The examples in this Training Guide have been designed to introduce you to the features available in Xfmea.
This chapter presents a brief summary of these features. If you are already familiar with Xfmea’s
capabilities, you can proceed to Chapter 3, First Steps.

ReliaSoft's Xfmea 5 facilitates analysis, data management and reporting for all types of Failure Modes and
Effects Analysis (FMEA), including Design FMEAs (DFMEAs), Process FMEAs (PFMEAs), criticality
analyses (FMECAs) and others. The software also provides built-in utilities for related analyses, such as
functional block diagrams (also called boundary diagrams), design verification plans (DVP&Rs), process
flow diagrams (PFDs), process control plans (PCPs) and design reviews based on failure mode (DRBFMs).
Xfmea 5 provides predefined settings to fit the major industry standards for FMEA (such as AIAG, SAE
J1739 and MIL-STD-1629A) and also provides extensive customization options to fit your particular
analysis and reporting needs.

This database-driven software tool includes numerous features to a) facilitate data entry/management,
b) help you find and use relevant data from existing analyses and c) present analysis information in a variety
of ways that effectively support decision-making. This chapter provides a brief overview of Xfmea 5’s main
features and also provides a summary of the new features and capabilities that have been added in Version 5.

2.1  Centralized Data Storage and Access by Multiple Users

Xfmea has been designed to provide centralized data storage and allow multiple users to work cooperatively
on analysis projects. This provides a powerful opportunity to build and maintain a keyword searchable
“knowledge base” of reliability information that can be accessible throughout the organization. You can
define configurable settings for the entire organization so that all system users follow consistent analysis and
reporting formats. You also have the option to limit access to specific information based on permission
levels defined for each user account.

Xfmea 5 offers the choice to store analysis data in a Standard database (Microsoft Access®) or Enterprise
database (Microsoft SQL Server® or Oracle®). If you have purchased an Xfmea Enterprise license, you will
be able to work with either type of database. If you have purchased an Xfmea Standard license, you will be
able to work with Standard databases only and the options to create, open or import from an Enterprise
database will not be displayed in the software interface.

Standard databases are easy to create and maintain without any special IT infrastructure or support but there
are limitations to the amount of data they can store and the number of users that can access the database
simultaneously. An Enterprise database requires implementation and support of Microsoft SQL Server,
Microsoft SQL Server Express or Oracle but it is a more robust platform that can store much more analysis
information in the same database and supports access by many more simultaneous users. Although most of
the features in Xfmea are available for any type of database, some functionality is available only for
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Enterprise databases or Standard databases with login security enabled. This includes the ability to manage
user accounts with permissions based on access level and/or group.

2.2  Extensive Customization Options

Xfmea provides predefined profiles for all major reporting standards, which makes it easy to configure the
analysis workspace to fit the standard. In addition, the software offers flexible capabilities to customize any
of the sample profiles or create your own profile(s) to meet the specific needs of your organization. Some of
the configuration options include the ability to:

 Define the data fields you want to capture and display.

 Set the classifications, categories and other drop-down lists throughout the software.

 Determine the rating scales and other criteria that will be used for risk assessment.

 Define the logic that will be used for risk discovery analysis.

2.3  Flexible Tools to Facilitate Data Entry and Management

Xfmea’s unparalleled capabilities for finding and using data from existing analyses, templates or phrase
libraries can help to speed up and improve the quality of your analyses. These flexible options to utilize
existing data can save time on data entry and help to ensure consistency among analyses. They also provide
a powerful brainstorming tool. Some of Xfmea’s most useful features for data entry and management
include:

 Cut/Copy/Paste or Drag and Drop: Xfmea makes it easy to copy or move data within and between
analyses. 

 Import/Export via Excel: You can define your own custom templates for importing and exporting data
via Microsoft Excel files. 

 Import from Database or Template: You can browse for data from an existing analysis or predefined
template and then automatically import selected records. 

 Add Existing: You can use up to three search terms to query for data from existing analyses or
predefined templates and then automatically import selected records. For example, the utility can
provide a list of causes that have been associated with a failure mode that contains the word “leak.” 

 Select Existing: For any text field within the software, Xfmea provides easy access to a list of existing
descriptions from specified data sources. Each list can be sorted automatically and/or filtered to match
specific search criteria. For example, the utility can provide a list of failure modes that contain the word
“fatigue.” 

 Find and Replace: The flexible Find and Replace utility provides a quick and easy way to find and/or
update specific text, dates, numbers or selections from drop-down lists. 

 Links and Attachments: The ability to link or attach independent files to any record in your analysis
makes it easy to keep related information (such as flowcharts, design drawings, reliability analysis files,
procedure instructions, etc.) together with the rest of the analysis. 

TIP: Working with a database-driven, multi-user application such as Xfmea may be a bit different from working
with other types of software that you may be familiar with (such as Microsoft Excel® or ReliaSoft's Weibull++).
For example, changes are saved automatically while you are updating the analysis (i.e. whenever you click OK
or navigate away from a cell in a table or worksheet). In addition, you must be diligent about storing backups and
performing adequate database maintenance to guard against data loss or corruption. Specific recommendations
are provided in the Xfmea User’s Guide.
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2.4  Support for Large Multi-Level System Configurations

Xfmea’s flexible System Hierarchy panel allows you to manage large, multi-level system configurations
with a nearly unlimited number of levels and a nearly unlimited number of items within each level. You can
fully define the properties for each item (e.g. supplier, part number, expected operating environment, etc.)
and perform FMEA and/or related analyses at any level within the system configuration (e.g. system,
subsystem or component).

You have the option to import system configuration data from an outside file (e.g. Bill of Materials) or use
built-in features to build the configuration “from scratch” within the software.

2.5  Risk Discovery Analysis

The Risk Discovery tab in the Analysis panel provides a choice of two configurable methods for performing
a preliminary analysis that can help you to choose which items should receive more detailed consideration
via FMEA (e.g. a change point analysis or preliminary risk assessment). The first option allows you to
answer a series of yes/no questions and the second option allows you to assign ratings for a variety of
different factors and then calculate an overall criticality value for each item.

2.6  Analysis Plans

The analysis plan utility allows you to keep track of team members, ground rules and assumptions, estimated
completion dates, scheduled work sessions and other details that will help you to plan and manage your
analysis projects. The software provides a high-level overview of all pending analysis projects and also
makes it easy to generate a report for each individual project plan.

2.7  Functional Block Diagram (Boundary Diagram)

A functional block diagram (or boundary diagram) can help to define the scope of a particular analysis
project and also may provide information about interactions, inputs and outputs that will be useful to the
analysis team when they attempt to identify potential failure modes. Xfmea provides a utility that allows you
to build these diagrams and store them together with your FMEAs. You can build each diagram “from
scratch” or with blocks transferred from the system configuration. You also have the option to save or copy
these diagrams as metafile graphics (*.wmf) that can be pasted into other document files, such as Microsoft
Word®, PowerPoint®, etc.

2.8  Full Featured Support for All Types of FMEA and FMECA

2.8.1  Three Complementary Views of the FMEA Data

The FMEA tab in the Analysis panel offers three complementary views of the information contained in your
FMEAs. It is easy to switch back and forth between the views so you can choose the display that is best
suited for a specific task.

The hierarchy view, which displays the analysis records in a hierarchical tree, tends to be good for viewing
a lot of information in a small amount of space. It can be especially useful when copying and pasting data or
when scanning the analysis to find a particular section of the FMEA.

The worksheet view, which follows the traditional tabular format that most FMEA practitioners are familiar
with, allows you to type directly into the worksheet cells and tab through the analysis as you would in a
spreadsheet application, such as Microsoft Excel.

The filtered view presents a sortable list of all records of a particular type. For example, you may wish to
see all cause records sorted by RPN or all overdue actions. This view allows you to generate these lists on-
the-fly as you work on the analysis.
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2.8.2  Risk Assessment: RPNs, Criticality Analysis and Related Techniques

Xfmea makes it easy to configure the analysis project to fit any of the risk assessment methodologies that are
commonly employed in conjunction with FMEA.

Risk Priority Numbers (RPNs) are calculated automatically by the software based on the your selections
from the fully configurable rating scales for severity, occurrence and detection. Xfmea 5 also supports
related metrics, including SxO (Severity x Occurrence), SOD (Severity, Occurrence, Detection) and SD
(Severity, Detection). These metrics can be displayed in the FMEA worksheet and other queries/reports/
charts generated by the software (e.g. list of effects ranked by severity, list of causes ranked by RPN,
Severity/Occurrence Matrix, etc.). In addition, the flexible Priority Highlights feature can be configured to
categorize issues based on criteria established by your organization and then highlight issues based on this
prioritization.

Xfmea also provides full support for Quantitative Criticality Analysis or Qualitative Criticality Analysis
patterned after MIL-STD-1629A.

2.8.3  Tracking the Completion of Recommended Actions

One of the most costly mistakes among FMEA practitioners is the failure to properly follow up and track the
completion of recommended actions. Xfmea provides multiple features that will help to ensure that your
organization implements the actions identified during the FMEA project so that you can achieve the benefits
that come from improving the design and reducing the risk. Some of the most useful features include the
ability to:

 Capture all of the details that are necessary to fully define and track the recommended action. This may
include the description, person responsible, due date, completion date, actions taken, expected cost,
actual cost, action category, action priority and other details. You also have the option to configure up to
11 user-defined fields.

 Update action records with periodic status reports.

 Capture “Review and Approval” details for completed actions.

 Use detailed reports and graphical charts that present actions sorted by due date, responsibility,
completion status and other characteristics to track the progress on completing assigned tasks.

Xfmea can be configured to send notification e-mails to the person who is responsible for completing an
action and others who may need to stay informed about the progress. These e-mails can be sent
automatically (based on specified conditions) or initiated manually. In addition, the My Portal window,
which is personalized for each individual user, also displays a list of actions that may be of interest to the
user and makes it easy to open and edit these records with a simple double-click.

2.9  Change Log

When an authorized user activates the change log for a particular FMEA, the software records a history of
the specific changes that were made in each tracked revision to the analysis since the log was activated.
Depending on your selections, the log can record the date/time of the change, the user who made the change,
the property that was changed, the value before, the value after and the reason (or justification) that the user
provided at the time of the change. If desired, this utility also can be used to store an electronic record of the
users who have reviewed and approved each version of the analysis.

2.10  Design Verification Plan and Report (DVP&R)

The DVP&R tab in the Analysis panel provides a configurable worksheet for design verification plans and
reports (DVP&Rs). You can create each plan “from scratch” or transfer data from the FMEA that has been
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defined for the same item. For example, you may wish to transfer the controls (and perhaps some
recommended actions) from the Design FMEA (DFMEA) to be the starting point for the new DVP&R.

2.11  Transfer Design FMEA to Process FMEA

You can leverage existing knowledge by automatically transferring relevant data from the Design FMEA
(DFMEA) to provide the starting point for a new Process FMEA (PFMEA). For example, the causes of
failure that have been identified for your design can be transferred as failure modes to consider when
analyzing the manufacturing process. Xfmea’s flexible Transfer Projects utility allows you to specify what
information will be transferred and how it will be “mapped” to the new analysis.

2.12  Process Flow Diagram (PFD)

A process flow diagram (PFD) provides a logical, visual depiction of the process that is being analyzed and
such diagrams can be useful to determine the steps in the process and the critical characteristics that will be
analyzed in the Process FMEA (PFMEA). Xfmea provides a utility that allows you to build these diagrams
and store them together with your FMEAs. You can build each diagram “from scratch” or with blocks
transferred from the items or functions that you have defined. You also have the option to save or copy these
diagrams as metafile graphics (*.wmf) that can be pasted into other document files.

2.13  Process Control Plan (PCP)

The Control Plan tab in the Analysis panel provides a configurable worksheet for process control plans
(PCPs). You can create each plan “from scratch” or transfer data from the FMEA that has been defined for
the same item. For example, you may wish to transfer the process steps (i.e. items or functions) and current
controls from the Process FMEA (PFMEA) to be the starting point for the new process control plan.

2.14  Design Review Based on Failure Mode (DRBFM)

The DRBFM tab in the Analysis panel provides a configurable worksheet for Design Reviews Based on
Failure Mode (DRBFMs). Developed within Toyota Motor Corporation, this methodology uses a modified
version of the FMEA worksheet to evaluate proposed changes to an existing design. Xfmea’s DRBFM
worksheet provides two views of the analysis, one for the design engineer to prepare the initial draft of the
analysis and one for the entire review team to expand on the initial draft if necessary and identify appropriate
corrective actions. The software also provides the option to import selected functions from the FMEA that
has been defined for the same item and also allows you to transfer selected data from the DRBFM to append
to the existing FMEA.

2.15  Queries, Reports and Charts

Of course, Xfmea makes it easy to generate report output in the tabular worksheet format that is commonly
used for FMEAs and related analyses. However, since all of the analysis information is stored in a relational
database, Xfmea is able to go beyond these basic worksheets to provide a complete range of options for
presenting the data in ways that will effectively communicate results and facilitate decision-making.

The Reports window provides a set of predefined report forms and also allows you to build and manage
your own report templates. You can use this flexible tool to build a complete report document that will be
generated in Microsoft Word or Excel.

The Query Utility allows you to search the project or database for the records that meet your specific search
criteria. Since you also have the option to specify which data fields will be included in the tabular results and
the order of the columns, this utility functions as another flexible custom reporting tool. Query results can be
exported directly to Microsoft Excel and you can also integrate saved queries into the documents that you
create via the Reports window.
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The Plot Viewer provides an array of flexible options for you to create attractive graphical charts based on
analysis data. These charts can be saved or copied as graphic files (*.wmf, *.jpg, *.gif or *.png) that can be
pasted into other document files.

2.16  Integration with Other ReliaSoft Software

Xfmea facilitates communication with other ReliaSoft software products whenever integration might be
useful.

 Xfmea’s Item Reliability and Cause Probability features are integrated with ReliaSoft's Weibull++ and
ALTA software packages, which allows you to obtain reliability distribution and parameter information
from an existing data file.

 You also can export system configuration, reliability and failure mode data to ReliaSoft's BlockSim for
more detailed system analysis using either reliability block diagrams (RBDs) or fault trees.

 The data from your failure reporting, analysis and corrective action system (FRACAS) can provide
valuable input to your FMEAs by identifying failure modes and allowing you to estimate the frequency
with which a problem occurs in the field. ReliaSoft's Web-based FRACAS system, XFRACAS, allows
you to export incident data to a file that can be imported by Xfmea. Likewise, you can import/export
system configuration and FMEA data between Xfmea and XFRACAS. 

2.17  Sample Databases Shipped with Xfmea

In order to help you become familiar with the features offered by Xfmea, the software is shipped with a
variety of sample files. These Standard database files (*.rx5) are located in the Examples folder in your
application directory (e.g. C:\Program Files\ReliaSoft\Xfmea5\Examples). Additional example files that are
used when working through the examples in the Xfmea 5 Training Guide are located in the Training folder
in your application directory (e.g. C:\Program Files\ReliaSoft\Xfmea5\Training).

2.18  What’s New in Version 5?

With the release of Version 5, Xfmea offers a completely updated user interface that has many new and
enhanced features. This section describes the most significant enhancements. If you are familiar with
previous versions of the Xfmea interface, Appendix B in the Xfmea User’s Guide provides a list of the most
significant changes with tips for how to find specific capabilities under their new names or locations in the
new interface.

Some of the major additions and enhancements in Version 5 include:

 Ability to Access Both Standard and Enterprise Databases: With the release of Version 5, the
capabilities of Xfmea Standard and Xfmea Enterprise have been combined. If you have purchased an
Xfmea Enterprise license, you now have the option to work with a Standard database (Microsoft Access)
or an Enterprise database (Microsoft SQL Server or Oracle), or a combination of both.

 Redesigned Project Window: The Project window has been completely redesigned and updated for
Version 5 and the new interface provides many enhancements that will make data entry and management
easier than ever. Some of the most noticeable improvements include:

 Analysis Panel: In addition to displaying the FMEA associated with the currently selected item, the
panel on the right side of the Project window now displays tabs for any other analysis information
that has been defined for the item, including item properties, risk discovery, analysis plan, DVP&R,
control plan and/or DRBFM.

 More Configuration Options for Analysis Worksheets: The Interface Style functionality that you
can use to define the configurable settings for each analysis project is now easier to manage and
provides:
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 More user-defined fields, including the ability to create fields for dates, numbers and your own
custom drop-down lists.

 More options to define the risk assessment metrics that will be calculated and displayed in the
software (e.g. RPN, SxO, SOD, SD, etc.).

 The ability to define a tooltip for any analysis field and store this information with each analysis
project so that it is the same for all users.

 The ability to define the order of the columns that will be displayed in the analysis worksheet and
store this information with each analysis project so that it is the same for all users.

 Action and Control Descriptions Displayed in the FMEA Hierarchy: The hierarchical tree view
of the FMEA information now displays all of the record descriptions, including actions and controls.

 Drag and Drop: The new drag and drop functionality makes it easier than ever to move records
within the analysis.

 Paste Special: The new Paste Special command provides additional flexibility when you copy and
paste records from an existing analysis. While the options will vary depending on the data that you
have copied, this can include the ability to paste an item with or without the associated functions,
paste a function with or without the associated failures, etc.

 Improved Spell Checker: The new and improved spell checker functionality now highlights
spelling mistakes while you are typing.

 Improved Functionality for Find and Replace: In addition to text fields, the Find and Replace tool
now works for number and date fields as well. When you select a specific project and property, you
also have the ability to find/replace options in configurable drop-down lists.

 Risk Discovery Analysis: The new Risk Discovery tab in the Analysis panel provides a choice of two
configurable methods for performing a preliminary analysis that can help you to choose which items
should receive more detailed consideration via FMEA (e.g. a change point analysis or preliminary risk
assessment).

 Increased Flexibility for Queries and Report Generation: The Query and Report Generation utilities
have been completely redesigned in Version 5. In addition to a more intuitive user interface, the new
utilities offer greater flexibility to customize the output to meet your particular needs.

 Increased Flexibility for Importing Data from Excel: The new Import Templates feature allows you
to create and manage your own custom template(s) for importing and exporting data via Excel so that
you no longer have to modify your data files to fit one of the predefined import templates shipped with
the software.

 Add Risk Ranking Logic to Priority Highlights Feature: Xfmea 5 now provides the option to define
your own configurable risk ranking logic for the Priority Highlights feature. For example, now you can
configure the project to mark an issue as “High Priority” if the RPN is => XXX and the Severity rating is
=> Y. Alternatively, you might choose to mark an issue as “Acceptable Risk” under certain conditions
and “Must Address” under others. With the new utility, you can configure both the priority levels and the
logic used to assign particular issues to each level.

 Import Existing Utility: With the new Import Existing utility, you can use up to three search terms to
query for data from existing analyses or predefined templates. You can then select records that meet the
specified criteria and import them into the current analysis automatically. This flexible new tool is
available for importing items or any of the records in the FMEA hierarchy (i.e. functions, failure modes,
etc.).

 Linked Records: The ability to link records, which was introduced in Version 4 for actions, allows you
to use the same record properties in multiple locations within a project. In Version 5, this capability is
now available for control records and the interface has been enhanced to make it easier to manage the
linked records. 
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 Managing Backups for Standard Databases: For Enterprise databases, your database administrator
will be able to use the tools built into Microsoft SQL Server or Oracle to perform necessary database
maintenance and store sufficient backups of the analysis data. For Standard databases, you can use the
tools on the Standard Databases page of the User Setup to perform necessary tasks. With the release of
Version 5, this now includes the ability to specify a directory where automatically generated backups
will be stored and to specify the number of recent backups that should be maintained at any given time.

 Additional Lifetime Distributions Available to Define Item Reliability: When you are describing
item reliability characteristics or cause probabilities, you now have the option to use any of the lifetime
distributions that are supported in ReliaSoft’s Weibull++ and BlockSim software. This includes the
Weibull, mixed Weibull, normal, lognormal, exponential, generalized gamma, gamma, logistic,
loglogistic and Gumbel models.

 Send Current View to Excel: For any of the worksheets or hierarchical tree views in the Project
window (e.g. System Hierarchy, Item Properties, FMEA Hierarchy, etc.) you now have the option to
automatically send the data to Microsoft Excel.



Xfmea Training Guide 11

In addition to information on starting Xfmea and a brief overview of the software's main interface, this
chapter allows you to experiment with the data management, analysis and reporting features of the software
using a predefined analysis based on sample data. Working through this example is intended to help you to
become familiar with the software quickly and easily.

3.1  Starting Xfmea

To start Xfmea, choose Start > All Programs > ReliaSoft Office > Xfmea 5. 

3.2  Multiple Document Interface

Xfmea’s Multiple Document Interface (MDI) is the workspace within which you can create, edit and
manage your FMEA and related analyses. You can open one database at a time in the MDI and as many
projects from that database as necessary. The MDI remains open until you close the program and closing the
MDI terminates the program.

The next figure displays the MDI and its components so that you can familiarize yourself with the options
available within the MDI. Your screen may look slightly different from the one shown next, depending on
the windows that are currently open.

First Steps 3
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The Project Explorer panel displays the projects that exist in the current database and provides the tools you
need to manage these projects. 

Within the Project window, the System Hierarchy panel displays the system hierarchy, which includes all
items that have been defined in the project. The Analysis panel displays the analyses associated with the
item that is currently selected in the System Hierarchy panel. You can configure the Project window to suit
your workflow:

 Click the Hide System Hierarchy icon to display only the Analysis panel. 

 Click the Hide Analysis Panel icon to display only the System Hierarchy panel. 

 Click the Split Screen icon to return to the two-panel view. 

 Click the Change Orientation icon to change the orientation of the panels in the Project window. 

In the default view, the System Hierarchy panel is on the left and the Analysis panel is on the right. You
can click this icon to move the System Hierarchy panel to the top and the Analysis panel to the bottom.
Clicking the icon again returns you to the default orientation.

3.3  Getting Help in the Xfmea Environment

ReliaSoft's Xfmea includes complete online help documentation. This help can be obtained at any time by
pressing F1 or by choosing Help > Xfmea Help.

3.4  First Steps Example 

This example allows you to experiment with the data management, analysis and reporting features of the
software. For this example, you will work with a database that has been prepared by ReliaSoft, which
contains sample data related to imaginary products. Sample data sets are not intended to be realistic.

Note that this first example is meant to give you a quick overview of the software. Subsequent examples in
this guide will take you through the steps of adding records and defining analysis properties.

At this time, we assume that you have started the application.
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3.4.1  Open an Existing Database

When you launch Xfmea, the Get Started window will be displayed. This window provides a quick way to
create a new Standard database, open an existing Standard database, create a new Enterprise database or
connect to an existing Enterprise database.

 For this example, click Open Standard Database to open an existing Standard database.

 In the Open Database window, select the file called FirstSteps.rx5 from the Training folder in your
application directory (e.g. C:\Program Files\ReliaSoft\Xfmea5\Training). 

 Click Open to continue.

3.4.2  Open a Project

Xfmea projects give you the flexibility to manage your analyses to fit the particular needs of your
organization. You can have one or many projects in the same database. Every analysis within a given project
will have the same characteristics, including the fields that are enabled/disabled in the interface and reports,
the rating scales that are available for risk assessment and the menu options that are available for codified
information (such as Action Categories, Classification labels, etc.). These properties are fully customizable
and can be set automatically based on predefined profiles and libraries.

NOTE: Standard databases are Microsoft Access® databases. These are easy to create and maintain without
any special IT infrastructure or support but there are limitations to the amount of data they can store and the
number of users that can access the database simultaneously. Enterprise databases are Microsoft SQL Server®
or Oracle® databases. These require implementation and support of Microsoft SQL Server, Microsoft SQL
Server Express or Oracle but the more robust platform can store much more analysis information in the same
database and support access by many more simultaneous users. If you have purchased an Xfmea Enterprise
license, you will be able to work with either type of database. If you have purchased an Xfmea Standard license,
you will be able to work with Standard databases only and the options to create, open or import from an
Enterprise database will not be displayed in the software interface. The following picture shows the appearance
of the Get Started window for a user with an Xfmea Enterprise license.
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 Select the First Steps project in the Project Explorer and choose Project > Project Properties to open
the Project Properties window, as shown next. 

As can be seen in the Select Profile from Library field at the lower left corner of the window, the First
Steps project is based on the Standard FMEA profile. A profile is a predefined set of project properties,
which includes selections for interface styles, rating scales, etc. The Standard FMEA profile enables/
displays a subset of commonly used properties in Xfmea.

 Click OK to close the Project Properties window.

 From the Project Explorer, you can open the First Steps project by double-clicking it or by choosing
Project > Open Project.

The Project window will appear. The Project window is the main window that you will use to perform your
analyses. Notice that the project name, First Steps, appears in the tab or in the title bar at the top of the

Project window.1 

1. You can have more than one Project window open at a time. The way these windows are displayed depends on your
selection on the Window menu. By default, Use Tabs is selected. When this is the case, the Project window(s) will be
maximized and each open Project window will be accessible via a tab just below the MDI toolbar area. If this command
is not selected, each Project window is treated as a separate window within the MDI. For the images in this guide, tabs
are not used in order to conserve space.
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The Project window with System A selected is shown next.

The Project window is divided into two sections. The System Hierarchy panel displays the system hierarchy,
which includes all items that have been defined in the project. The Analysis panel displays information
associated with the item that is currently selected in the System Hierarchy panel. At minimum, this consists
of the item properties, which include the item name, the date it was last updated and the user who performed
the last update, along with any other configurable properties that have been enabled for the project. In
addition, the Analysis panel displays any analyses associated with the selected item, including risk
discovery, analysis plan, FMEA, DRBFM, DVP&R and/or control plan analyses.

3.4.3  View the Item Properties

Each item in the system hierarchy can have a variety of properties defined. You can view and change these
properties in the Item Properties tab in the Analysis panel. For example, to view the properties for
Component A.1.1.1, click the name that appears in the Name column in the System Hierarchy panel. The
properties for the component will be displayed in the Item Properties tab in the Analysis panel. You can
click inside any field with a white background to edit it. Fields with a gray background cannot be edited in
the Analysis panel, either because they are populated by the system or because they are based on inputs that
you make elsewhere in the software.

3.4.4  View the FMEA 

The Component A.1.1.1 item has an FMEA associated with it. This is indicated by the FMEA icon in the
FMEA column in the System Hierarchy panel. In addition, you will notice that when the item is selected in
the System Hierarchy panel, the Analysis panel contains an FMEA tab at the top.

 Click the FMEA tab now to view the FMEA.

3.4.4.1  The FMEA Header

There are four tabs at the bottom of the FMEA tab in the Analysis panel. The first tab is the Header tab. 

 Click the Header tab to display the general properties of the FMEA, including the FMEA type, person
who prepared the FMEA, relevant dates, etc. 

The FMEA header works similarly to the Item Properties tab. You can click inside any field that has a white
background to edit it. 
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The other three tabs allow you to view the FMEA in different ways to facilitate data entry and decision-
making. 

3.4.4.2  The FMEA Hierarchy

 Click the Hierarchy tab to view the FMEA in a hierarchical view. 

This view, which is the default view of the FMEA, displays the functions, failures, effects, causes, controls
and actions defined in your analysis at-a-glance in a hierarchal tree structure. You cannot edit text directly in
this view. Instead, all editing in this view is done via properties windows. For example:

 Double-click the first function record, Description of the function. The Function Properties window
will appear, as shown next.

In properties windows, you can click inside any field with a white background to edit it. A field with a gray
background cannot be edited, either because it is populated by the system, because it does not apply to the
current analysis based on the project properties or because additional information must be entered elsewhere
in the software in order for the field to be meaningful and enabled.

 Click OK or Cancel to close the Function Properties window.
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3.4.4.3  The FMEA Worksheet

The worksheet view displays the analysis in the traditional tabular format for FMEA reports. 

 To view the analysis in the worksheet view, click the Worksheet tab. You can see that the Analysis
panel now displays the information in a tabular format similar to typical FMEA worksheet reports, as
shown next.

When a cell has a blue background, the record is selected but is not currently being edited (i.e. not in “edit
mode”). 

 To initiate edit mode, simply double-click the cell or click the cell and press ENTER to display a
blinking cursor inside the cell. 

 For cells that contain text, you can type directly within the cell. In addition, such cells contain the
Select Existing icon, which allows you to select existing text from within the current project, the
current database, selected phrase sets and/or the FMEA Accelerator® templates enabled on your
computer, if any.

Select Existing functionality is demonstrated in the first example in the next chapter.

 Cells that contain dates can be populated using a calendar or by entering the date manually. Click the
field twice to open a calendar or an additional time to type the date. You must use the mm/dd/yy or
mm/dd/yyyy format. For example, scroll all the way to the right side of the worksheet. In the first
row in the Approval Date column, click twice to open a calendar and click today’s date to enter it as
the approval date for the first action.

 Cells that contain information that is chosen from a list, such as RPN ratings, contain drop-down lists
that become available in edit mode. For example, scroll all the way to the right side of the worksheet
so that you can see the revised ratings columns (i.e. Sr, Or, Dr and RPNr). Change the revised
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severity rating (Sr) for the first cause by double-clicking inside the corresponding cell. A menu will
appear with the available ratings. Choose 6 from the menu, as shown next.

 To exit edit mode, press ALT or click somewhere else in the worksheet to accept this change.2 Notice
that the revised RPN (RPNr) has been recalculated automatically and has changed from 280 to 336.

 Change the revised severity rating back to 5.

You will notice that the cells in the RPNr column have colored backgrounds. By default, Xfmea highlights
the RPNs in the Analysis panel based on the priority, which can be determined based on RPN, severity,
occurrence or detection. For example, you could specify that all records associated with an RPN =>300 or a
Severity => 9 are considered to be high priority; those records would then be highlighted with a color that
represents high priority issues. The priority ranges and colors can be set via the Interface Style in the Project
Properties window. You also can toggle the priority highlighting off and on by choosing FMEA > Highlight
Priority or clicking the Highlight Priority icon. 

In addition to editing the worksheet cells directly, you also can add and edit records by using the menus and
shortcut menus to open the appropriate properties windows. 

 For example, to open the Function Properties window, right-click the cell that contains the function
description and choose Edit Function from the shortcut menu.

 Click OK or Cancel to close the Function Properties window.

3.4.4.4  The Filtered View

When working in the FMEA, you can use the filtered view to filter the information to show only records of
a specific type, along with specific related properties, in a tabular view that can be sorted by any column
(e.g. causes sorted by RPN or actions sorted by due date).

 Click the Filtered tab at the bottom of the Analysis panel.

NOTE: In the image shown here, the System Hierarchy panel has been hidden by choosing View > Hide
System Hierarchy in order to show more of the worksheet view.

2.  You also can exit edit mode without saving your change by pressing ESC.
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 From the Filter By drop-down list at the upper right corner, choose Actions. The Analysis panel will
change to display only the action records and specific related properties, as shown next. (Please note that
you may have to scroll and/or resize the window to view all the actions and their properties.)

 You can then sort the records that are shown. Click the Action Status column header to sort the actions
by their statuses. These can include:

 Due: An action is due if its Due Date is today’s date or later, or if no due date is assigned.

 Overdue: An action is overdue if its Due Date is prior to today’s date.

 Complete: An action is complete if a Completion Date has been entered.

 Reviewed and Approved: An action is reviewed and approved if an Approval Date has been
entered.

You can click the column header again to reverse the direction of the sort.

 Click the Hierarchy tab to return to the hierarchy view.

3.4.5  Check the Analysis

Prior to creating any reports or presenting any results, you may find it helpful to run the Check Analysis
utility, which identifies any possible discrepancies and/or omissions in each FMEA. The utility lists the
potential issues and you can make the decision of whether or not to address each issue.

 Choose FMEA > Check Analysis to open the Check Analysis utility.

 Select all items in the system hierarchy for inclusion in the check by selecting the check box in the
header of the Select Items to Be Included in the Analysis Check area.

 On the FMEA Checks tab in the lower section of the window, select all checks to be performed, then
click Check to run the checks.
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When the process is complete, the Analysis Check Results tab will display a list of all the checks that were
performed and a notation if any portions of the analysis failed the check. The window will look like the
figure shown next. 

If you scroll down to the bottom in the Analysis Check Results tab, you will see that the check reveals that
some causes have the same description. The same is true for some controls and some actions. In addition, the
check notifies you that there are certain causes that do not have controls and/or actions defined. In normal
use, if these issues were of concern, you could close the utility, fix the problem(s) that were found and then
return to the utility to run the checks again.

 Click Close to close the Check Analysis utility.

3.4.6  User-Defined Queries

The Query utility allows you to search the current project or the current database for the records that meet
your specific query criteria. The results of the queries are returned in tabular grids that can then be exported
to Microsoft Excel, if desired.
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 To access the Query utility, choose Tools > Queries. The utility will appear, as shown next.

 In the Data Source area, select Active Project. This specifies that the query will search only in the
current project, rather than in the entire database.

 The Select Items area is used to indicate that query results will include data associated with the selected
component(s) only. By default, the item selected in the System Hierarchy panel when you open the
Query utility is selected, along with its sub-items. Thus, it is likely that Component A.1.1.1 is already
selected in this area. If it is not, select the Component A.1.1.1 item and clear all other items.

 In the Query area, choose FMEA Actions from the drop-down list. This specifies that the query will
search for action records within the FMEA(s) associated with the item(s) selected in the Select Items
area.

 You can specify which columns you want to appear in the query results. For this example, clear all of the
columns by clearing the check box for the Actions Properties heading in the Include in Results column,
then select the individual check boxes for the following properties:

 Recommended Action

 Action Category

 Action Priority

 Completion Date

 Reviewed and Approved By

 Approval Date

 For Completion Date, specify that only actions that have not yet been completed will be included in the
query results by choosing is empty in the first of the Criterion 1 columns.
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The window will look like the one shown next.

 Click Run Query.3 The query results will appear in the Results tab, as shown next.

3. You also can use the Headers Customization tab to specify, for each property included in the query results, the column
width and the column name.
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You can sort the results by any of the columns by clicking the column header. You also can double-click any
record to open it.

 Click the Send to Excel icon to send the query results to a spreadsheet in Microsoft Excel. 

 A window will appear that allows you to specify the name and location to save the results to. Enter
Incomplete Actions.

 Click Save. The query results will open automatically in Microsoft Excel.

 Close Microsoft Excel. The query results have been saved to the file name and location you specified
and can be accessed again later, if desired.

 From the Query utility, you can save the query criteria as a custom query that can be applied to any data
set in the future. Click the Save Query icon.

The Save Query window will appear, as shown next.

 Type Incomplete Actions for the query name. In the Description field, type Actions Without a

Completion Date, then save the custom query by clicking OK.4

If you want to perform this custom query at a later time, you can click the Open Saved Query icon in the
Query utility.

The Select Existing Query window will appear. Choose a query category in the Search drop-down list (in
this case, FMEA Actions). A list of the custom queries that you have created for actions records will be
displayed. Select a query from the list and click OK. The Query utility will be updated with all of the
selections from the saved query. Please note that when you save a query, it does not save the specified items
or projects because the same query can be used for any selected data set.

If you are working with a Standard database, saved queries are stored in an independent database. If you are
working with an Enterprise database, the queries are stored within the Enterprise database. In both cases, the
saved queries are considered “templates” and can be managed (added, edited or deleted) via the Templates
Manager. You can access the Templates Manager by clicking the Templates Manager button in the Select
Existing Query window or by choosing Tools > Templates Manager.

In addition, your saved custom queries can be included in reports, as demonstrated in the next section.

4. If you are working with an Enterprise database, you can select the Show to all system users option to allow all users
of the database to access the saved query. If you do not select this option, the saved query will be available only for you.
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 Close the Query utility.

3.4.7  Generate a Report of the Analysis

Xfmea provides a complete set of reports for your analysis. Reports can be generated in Microsoft Word
and/or Excel, which provides maximum flexibility for customization and the ability to create HTML and/or
PDF versions of the reports, as desired.

 Choose Tools > Reports. The Report Generation window will appear.

 The Select Items area allows you to specify the item(s) from the system hierarchy that will be included in
the report. By default, the item selected in the System Hierarchy panel when you open the Report
Generation window is selected. Thus, it is likely that Component A.1.1.1 is already selected in the Select
Items area. If it is not, select the Component A.1.1.1 item to be included in the report by clicking its
check box and clear all other items.

 You will notice that two report forms are present in the Selected Reports area by default. These forms are
not used for this example. To move the forms from the Selected Reports area to the Available Reports
area, click the Exclude All icon (<<).

 There are three ways to select the forms that will be included in the generated report.

 In the Available Reports area, click the Report Summary form under the General heading and then
click the Include icon (>). The Report Summary form will be moved to the Selected Reports area
and will be included in your generated report.

 You also can include the results of the query that you created in the previous section of this example
in the generated report. In the Available Reports area, double-click the Incomplete Actions
(Queries) form under the FMEA Records heading to move it to the Selected Reports area. 

 In the Available Reports area, click the AIAG Form A form under the FMEA Spreadsheet heading
and drag it onto the row containing the Incomplete Actions (Queries) form in the Selected Reports
area. The AIAG Form A form will be added to the Selected Reports in the second position and the



3.4  First Steps Example

 Xfmea Training Guide 25

Incomplete Actions (Queries) form will be moved down to the third position. The Report Generation
window will look like the one shown next.

 In the Select Output Type area, select Word Document. Note that you also can generate the report in
Excel, which will be demonstrated in later examples.

 Click Generate Report. The Save File As window will appear, which allows you to specify the name
and location for the document. Specify to save the report as First Steps Report. When you click Save, a
progress bar will appear in the MDI. When the progress is 100% complete, the report will open
automatically in Microsoft Word.

 When you have finished viewing the report, leave it open and return to Xfmea.

 From Xfmea, close the Report Generation window by clicking the Close button.

3.4.8  Generate Charts Based on the Analysis

Xfmea also provides a complete array of plots and charts for graphical presentation of your analysis.

 To create graphical charts, choose Tools > Plots.
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 In the Select Items window that appears, select to include data associated with Component A.1.1.1 in
the charts, as shown next.

 Click OK.

The Plot Viewer utility will appear. The Plot Viewer provides a variety of different plot types to choose from
and all of these plot types provide additional options to allow you to select the information to be displayed.
When you first open the Plot Viewer, it will create a chart automatically based on the current data and the
plot type and options for the last chart that you created.

 If a chart other than the RPN (Pareto) chart is displayed, choose RPN (Pareto) from the Plot Type drop-
down list. Make the following selections:

 Display Range = 1 to 5

 Automatic Scaling = Selected

 Automatically Refresh = Selected

 Keep Aspect Ratio = Selected

 RPN Type = Initial
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The Plot Viewer will look like the one shown next.

The Plot Summary panel at the bottom of the Plot Viewer window shows the details associated with the
current chart. This includes the pathname/filename for the database, the project name, the numbers and
names of the items included in the chart and the details for the cause records that are represented in the chart.
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 Next, select to view Initial and Revised as the RPN Type. Since Automatically Refresh is selected in
the Control Panel, the Plot Viewer will be updated automatically to display the plot type you have
selected, as shown next. 

The plot legend in the upper right corner of the plot shows that the blue bars represent the initial cause RPNs
and the red bars represent the revised cause RPNs.

 Next, choose Action Priority Pie from the Plot Type list. This plot shows the percentage of actions that
have priority ratings of low, medium, high and safety, based on the Action Priority field in the Action
Properties window for each action, as well as the percentage of actions that do not have a priority rating
assigned.

 You can exclude actions with a description of “none” (or any other terminology that your organization
uses for this) from this accounting. Select the Exclude Records with Description option, then enter
None in the text input field and press ENTER. All actions with this description are now excluded from
the plot.

 Next, choose Occurrence/Severity Matrix from the Plot Type list. 

The Occurrence/Severity Matrix displays the severity ratings on the X-axis and the occurrence ratings on the
Y-axis. The matrix displays a point for each cause in the data set, at the location where the severity and
occurrence ratings intersect.

The matrix also includes two priority lines that are intended to differentiate the high, medium and low
priority causes, based on severity and occurrence ratings. The coordinates for these lines are set in the
Priority Area Coordinates area of the Control Panel.

 For this example, make the following selections:

 High Occurrence = 8
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 Low Occurrence = 5

 High Severity = 9

 Low Severity = 5

 View the initial ratings. You will see that there are seven causes in the high priority area, one in the
medium priority area and one in the low priority area, as shown next. 

 View the revised ratings. There are five high priority causes based on revised ratings, three medium
priority causes and one low priority cause.

 Click any of the points in the matrix to display additional details about the cause that it represents. This
information is also displayed in the plot summary panel at the bottom of the Plot Viewer window.

3.4.8.1  Copy Plot Graphic and Summary

Xfmea allows you to add the plot graphic and summary to other documents, such as FMEA reports.

 To do this, click the Copy Plot Graphic icon.

 Next, go to the First Steps Report that you created in Microsoft Word and paste the graphic into the
document.

 Now return to Xfmea’s Plot Viewer. This time, click the Copy Plot Summary icon and return to the
report.
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 Place the cursor below the chart graphic and paste the contents of the Clipboard into the report.

 You can save the changes you have made to the report, if desired, and then close Microsoft Word.

 Close the Plot Viewer.

3.4.9  Close the Database

You have completed the First Steps Example. You can now close the Xfmea database.

 To close the database, choose File > Close Current Database. If you do not close the database, it will be
closed automatically when you create a new database for the next example.

 Notice that “No Current Database” appears in the caption bar and status bar at the top and bottom of the
MDI, indicating that a database is not currently open in the MDI.

 Proceed to the Step-by-Step Examples in Chapter 4.
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4.1  List of Examples

This chapter provides the following step-by-step examples, designed to introduce you to the features of the
Xfmea software:

 Example 1 - Design FMEA (DFMEA) Using the Hierarchy View - page 31

 Example 2 - Process FMEA (PFMEA) Using the Worksheet View - page 49

 Example 3 - Quantitative and Qualitative Criticality Analysis - page 55

 Example 4 - Import/Export for Items and/or FMEAs - page 68

 Example 5 - Design Review Based on Failure Mode Analysis - page 73

 Example 6 - DFMEA and DVP&R - page 77

 Example 7 - PFMEA and Control Plan - page 82

 Example 8 - Using Change Logs - page 86

 Example 9 - Using Profiles/Libraries for Configurable Settings - page 93

 Example 10 - Performing Your Own FMEA - page 107

4.2  Example 1 - Design FMEA (DFMEA) Using the Hierarchy View

This example guides you through the process of performing a Design FMEA (DFMEA) for an automotive
component and generating a report of the analysis in the SAE J1739 (2008) reporting format.

For this example, you will work with sample data based on a modified version of the example provided in
the 2008 revision of the SAE J1739 guidelines.

4.2.1  Create a New Database1

 Create a new Xfmea Standard database by choosing File > New Standard Database or by clicking the
New Standard Database icon.

 When you are prompted for a filename, type TrainingExamples and click Save to continue. The
database will be created and the New Project window will appear.

Step-by-Step Examples 4

1. Although the examples in this guide are performed using Standard databases, you can also perform them while
connected to an Enterprise database.
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4.2.2  Create a New Project

The New Project window allows you to supply information about the project, such as its name, description,
etc., and to specify the profile that will be used to set the configurable properties that apply to all of the
analyses within the given project. This includes:

 Interface Style: which determines which data fields will be enabled/displayed for the analysis (and
what they will be called). This includes user-defined fields. The interface style also controls the
available options for menus throughout the analysis, such as Action Categories, Control Types, etc.

 RPN Scales: which allow you to rate the relative severity of the failure effects and the relative
likelihood of occurrence and detection for the failure causes.

 Criticality Scales: which allow you to rate the relative severity classification and failure probability
for the failure modes in each criticality analysis within the project.

 Risk Discovery Questions and Ratings: which set the available options used in each risk discovery
analysis within the project.

 In the New Project window, type Design FMEA for the project name. At the bottom of the window,
choose the DFMEA: J1739 (2008) profile from the Select Profile from Library drop-down list, as
shown next.

 Click OK. The new project will be displayed in the Project Explorer and will be opened in the Project
window. 
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4.2.3  Define the System Configuration

For this example, the analysis will be performed on the power steering pump, which is a component of the
“Steering” subsystem in the “Automobile” system.

 Automobile

 Steering

 Power Steering Pump

Each project contains the system hierarchy (which could contain a single item or multiple items arranged in
hierarchical system configurations) and the analyses associated with any of the items in the system
hierarchy.

The first item was added automatically when the project was created and is selected automatically in the
System Hierarchy panel. The item’s properties are displayed in the Analysis panel. You will notice that the
fields that can be edited are white, while the fields that cannot be edited, because they are populated
automatically, are gray.

 Click within the Item field under the General heading and change the item name to Automobile then
press ENTER or click outside the field to accept your change. Next, add the Steering subsystem to the
system configuration by selecting the system, Automobile, and then choosing System Hierarchy > Add
Next Level Item.

 Change the name of the new subsystem to Steering.

 Repeat these steps to add the Power Steering Pump item to the Steering subsystem.

Once all three items have been added to the system hierarchy, your Project window will look like the one
shown next.
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4.2.4  Create an FMEA

The next step is to add an FMEA for the item of interest. 

 Select the Power Steering Pump item in the System Hierarchy panel then choose Analyses > Add
FMEA or click the Add FMEA icon. 

The FMEA tab will appear at the top of the Analysis panel. In addition, the FMEA icon (F) will appear in
the FMEA column for the Power Steering Pump item in the System Hierarchy panel.

 In the Analysis panel, click the Header tab at the bottom of the window to view and change the header
information that will be displayed at the top of the FMEA spreadsheet report. This includes such
information as the document number, the name of the person who prepared the document, the revision
date, etc. Enter the following information.

 FMEA Type: Component

 DFMEA Number: XTG1234

 Click the Hierarchy tab at the bottom of the window to return to the FMEA hierarchical view.

4.2.5  Define the Function

Although a given item may perform numerous functions, for this example we will focus on a single function
of the power steering pump. 

 Choose FMEA > Functions > Add New Function. The Function Properties window will be displayed.

To enter the function, we will first enable a predefined phrase library that will save you time during data
entry for the rest of this example.

 Click the Select Existing icon on the right side of the Function text box.

 In the Select Existing window that appears, go to the Options page and select Active Phrase Sets and
then select Training Examples to indicate that the descriptions from the chosen phrase set will be
available. In order to limit the number of descriptions that are displayed when you are adding/editing
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records, it is recommended that you de-activate any other phrase sets, as well as descriptions from the
current database, during this example. 

 Return to the Select page of the Select Existing window. It will now display all of the function

descriptions that meet the criteria that you specified on the Options page.2

2. You also can filter these descriptions by entering one or more keywords into the Find input box.
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 Select the description that begins Transforms rotational speed... and click OK (or double-click the
description) to place the text into the Function Properties window, as shown next. 

 Click OK. The function will appear in the Analysis panel, as shown next.

4.2.6  Define the Potential Failure

One potential failure has been identified for this example:

 Inadequate flow (less than xx lpm).
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 With the function selected, choose FMEA > Failures > Add New Failure. The Failure Properties
window will appear. 

 Click the Select Existing icon beside the Potential Failure Mode input box.

 In the Select Existing window, select the description that begins Inadequate flow... and click OK (or
double-click the description) to place the text into the Failure Properties window, as shown next.

NOTE: Commands for adding and editing records also are available in the shortcut menu that appears when
you right-click a record. For example, here you can right-click the function in the Analysis panel and the shortcut
menu will contain commands for adding and editing functions and failures.
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 Click OK to save the changes and return to the Project window. The failure will appear in the Analysis
panel, as shown next.

4.2.7  Define the Potential Effects of Failure

One potential effect of failure has been identified:

 Increased steering effort when turning.

 Select the failure in the Analysis panel and choose FMEA > Effects > Add New Effect. The Effect
Properties window will appear.

 Click the Select Existing icon beside the Potential Effect(s) of Failure input box.

 In the Select Existing window, select the description that begins Increased steering effort... and click
OK (or double-click the description) to place the text into the Effect Properties window.

 In the Initial Severity area of the window, choose 7 - Degradation of Primary Function from the drop-
down list. The initial severity is a numerical rating that estimates how serious the effects will be if the
failure occurs. The available options in the drop-down list are determined based on the Severity rating
scale that has been assigned to the current project. A severity rating must be defined in order for the RPN
to be calculated automatically.
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The Effect Properties window will now look like the one shown next.

 Click OK. The effect will appear in the Analysis panel, as shown next.

4.2.8   Define the Potential Causes of Failure

One potential cause of failure has been identified:

 Fluid viscosity incorrectly specified.

 Select the effect in the Analysis panel and choose FMEA > Causes > Add New Cause. The Cause
Properties window will appear.
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 Click the Select Existing icon beside the Potential Cause(s) of Failure input box.

 In the Select Existing window, select the description that begins Fluid viscosity... and click OK (or
double-click the description) to place the text into the Cause Properties window.

The Cause Properties window will now look like the one shown next.

 Click OK. The cause will appear in the Analysis panel, as shown next. 
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4.2.8.1  Define and Classify the Current Controls

For each cause, you can identify the controls that are currently in place to reduce or eliminate the risk
associated with the potential cause of failure. For this example, there are two controls associated with the
cause:

 Prevention Control: Design guidelines for fluid.

 Detection Control: Vehicle durability testing.

The prevention control is intended to reduce the likelihood that the cause, and consequently the failure, will
happen. The detection control is intended to increase the likelihood that if the cause does happen, the
problem will be detected before it reaches the customer or end user.

 Select the cause in the Analysis panel and choose FMEA > Controls > Add New Control. The Control
Properties window will appear.

 Click the Select Existing icon beside the Current Design Controls input box.

 In the Select Existing window, select the description that reads Design guidelines for fluid and click
OK (or double-click the description) to place the text into the Control Properties window.

 Select Prevention in the Control Type drop-down list.3 The Control Properties window will look like
the one shown next.

 In the lower left corner of the Control Properties window, click the Add Next Control navigation arrow
to add another control for the same cause. 

3. The options that will appear in the Control Type drop-down list are specified on the Control page of the interface style
defined for the project.
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 Click the Select Existing icon beside the Current Design Controls input box.

 In the Select Existing window, select the description that reads Vehicle durability testing and click OK
(or double-click the description) to place the text into the Control Properties window.

 Choose Detection in the Control Type drop-down list. The Control Properties window will look like the
one shown next.

 Click OK. The controls will appear in the Analysis panel, as shown next. 

4.2.8.2  Assign Occurrence and Detection Ratings to the Cause

Now that the controls have been identified, a more accurate assessment can be made of the likelihood that
the failure will occur and the likelihood that the failure will be detected before it reaches the end user.
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 In the Analysis panel, double-click the cause, Fluid viscosity incorrectly specified, to re-open the
Cause Properties window.

 In the Initial Ratings area, choose 5 – Moderate from the Initial Occurrence drop-down list. The initial
occurrence is a numerical rating that estimates the probability of occurrence for the potential failure
cause, taking into consideration any prevention controls that might be in place. The options available in
the drop-down list are determined based on the Occurrence rating scale that has been assigned to the
current project.

 Next, choose 6 – Post Design Freeze and Prior to Launch from the Initial Detection drop-down list.
The initial detection is a numerical rating that estimates the probability that the problem will be detected
before it reaches the customer or end user, taking into consideration any detection controls that might be
in place. The options available in the drop-down list are determined based on the Detection rating scale
that has been assigned to the current project. 

The Cause Properties window will look like the one shown next.

You will notice that the initial RPN is calculated automatically and displayed in the RPNi field.

 Click OK to accept your changes.

In the Analysis panel, you will now notice that the initial RPN for the cause has been calculated
automatically.

Cause RPN = Effect Severity x Cause Occurrence x Cause Detection

The next step in a typical FMEA would be to go through this process for all functions and failure modes that
the analysis team identifies. Once all initial RPNs have been determined, you can then prioritize the issues
based on risk. At that point, you can select issues for improvement and define appropriate recommended
actions.
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4.2.8.3  Identify and Assign the Recommended Action

The recommended action for the cause in this example is:

 Obtain and evaluate results of durability testing.

 Select the cause in the Analysis panel and choose FMEA > Actions > Add New Action. The Action
Properties window will appear.

 Click the Select Existing icon beside the Recommended Action(s) input box.

 In the Select Existing window, select the description that begins Obtain and evaluate results... and
click OK (or double-click the description) to place the text into the Action Properties window.

 Enter a due date for the action in the Target Completion Date field, either by clicking the calendar and
selecting a date or by typing it in any standard date format (e.g. October 15, 2009; 10-15-09; 10/15/09,
etc.).

 To assign the action, type the responsible person’s name in the Responsibility field. If desired, you also
can click the Details button and enter more specific information in the pop-up that appears, as shown
next.
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 Click OK to save the action record. The action will appear in the Analysis panel, as shown next. 

4.2.9  Record the Action Taken and Revise the Ratings

Once actions have been taken to reduce the risk associated with a cause of failure, the RPN rating for the
cause will change. The steps given in this section show how to record the action taken and enter revised
ratings in Xfmea.

4.2.9.1  Describe the Action Taken

To specify the action that was taken, do the following:

 In the Analysis panel, double-click the action. The Action Properties window will appear.

 Click the Select Existing icon beside the Actions Taken input box.

 In the Select Existing window, select the description that begins Confirmed fluid specified... and click
OK (or double-click the description) to place the text into the Action Properties window.
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 Enter today’s date in the Effective Date field, either by clicking the calendar and selecting a date or by
typing it in any standard date format (e.g. October 15, 2009; 10-15-09; 10/15/09, etc.). The action status,
shown in the upper right corner of the window, will change to complete, as shown next.

 Click OK to accept your changes.

4.2.9.2  Revise the Severity Rating for the Effect

In this example, the action taken has no effect on the severity of the effect itself.

 To specify this, double-click the effect, Increased steering effort when turning, in the Analysis Panel.

 In the Revised Severity area of the Effect Properties window that appears, choose 7 - Degradation of
Primary Function from the drop-down list. The available options will be the same as the options for the
initial severity rating. In this case, the action taken has not changed the severity of the effect, so the
revised rating is the same as the initial rating.
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The Effect Properties window will look like the one shown next.

 Click OK to accept your changes. 

4.2.9.3  Revise the Cause Ratings

 In the Analysis panel, double-click the cause. The Cause Properties window will appear.

 In the Revised Ratings area, choose 2 – Low from the Occurrence drop-down list. The revised
occurrence rating is based on the assumption that all recommended actions for the cause have been
performed. The available options will be the same as the options for the initial occurrence rating. In this
case, the action taken has reduced the likelihood of occurrence from moderate to low.

 Next, choose 6 – Post Design Freeze and Prior to Launch from the Detection drop-down list. The
revised detection is based on the assumption that all recommended actions for the cause have been
performed. The available options will be the same as the options for the initial detection rating. In this
case, the action taken has not changed the likelihood of detection, so the revised rating is the same as the
initial rating.
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The Cause Properties window will look like the one shown next. 

You will notice that the revised RPN was calculated automatically and the % Reduction in RPN field now
shows that there has been a 60% reduction in RPN through implementation of recommended actions. This is
calculated as follows:

% Reduction = 

 Click OK to accept your changes.

4.2.10  Generate a Report of the Analysis

Xfmea provides a complete set of reports for your analysis. Reports can be generated in Microsoft Word
and/or Excel, which provides maximum flexibility for customization and the ability to create HTML and
PDF versions of the reports, as desired.

 Choose Tools > Reports. The Reports window will appear.

 In the Select Items area, select the check box for the Power Steering Pump item, if it is not already
selected, to include it in the report. Clear any other items.

 You will notice that the report forms that you selected the last time you generated a report are present in
the Selected Reports area by default. Move these forms from the Selected Reports area to the Available
Reports area by clicking the Exclude All icon (<<).

 In the Available Reports area of the window, select the Report Summary and Rating Criteria and
Classifications forms under the General heading and the J1739 (2008) form under the FMEA
Spreadsheet heading. (You can select multiple items by holding down CTRL and clicking the items.)
Click the Include icon (>) to move the selected forms to the Selected Reports area for inclusion in your
generated report.

RPNi RPNr–

RPNi
---------------------------------
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 In the Select Output Type area of the window, select Word Document. 

The window will now look like the one shown next.

 Click Generate Report. The Save Report As window will appear, which allows you to specify the name
and location for the report. Specify to save the report as Design FMEA Report.

 Click Save. The report will be created and will open automatically in Microsoft Word. Once you have
finished viewing the report, close it and return to Xfmea

 From Xfmea, close the Reports window by clicking the Close button.

 Close the Project window by clicking the red X in the Project window tab if you are using tabs, or in the
Project window title bar if you are not using tabs. Leave the database open and proceed to Example 2.

4.3  Example 2 - Process FMEA (PFMEA) Using the Worksheet View

This example will guide you through the process to create a Process FMEA (PFMEA) for a portion of the
manufacturing process for a semiconductor component.

For this example, you will work with a sample data set created by ReliaSoft, which was prepared based on
the sample Process FMEA (PFMEA) on page 15 of the EIA/JEP131 document, published by the Electronics
Industries Association (EIA) and the JEDEC Council.

4.3.1  Create a New Project

 Choose Project > Add New Project. The New Project window will appear, which allows you to create a
project within the database.

 In the New Project window, type Process FMEA for the project name.

 In the Select Profile from Library field, choose the PFMEA: AIAG-4 profile from the drop-down list. 

 Click OK to create the project and display the Project window.
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4.3.2  Define the System Configuration

For this example, the analysis will be performed on the manufacturing process for CMOS memory.

 The first item in the system hierarchy has been added automatically and will already be selected in the
System Hierarchy panel. In the Analysis panel, click within the Item field under the General heading and
change the item name to CMOS Memory then press ENTER or click outside the field to accept your
change.The Project window will look like the one shown next.

4.3.3  Create an FMEA

The next step is to add an FMEA for the item of interest. 

 Choose Analyses > Add FMEA or click the Add FMEA icon. 

The FMEA tab will open in the Analysis panel. In addition, the FMEA icon (F) will appear in the FMEA
column in the System Hierarchy panel.

 In the Analysis panel, click the Header tab at the bottom of the window to view and change the header
information that will be displayed at the top of the FMEA spreadsheet report. This includes such
information as the document number, the name of the person who prepared the document, the revision
date, etc. Enter the following information.

 FMEA Type: Component

 FMEA Number: PF307

4.3.4  Define the Functions

 For this example, you will use the worksheet view to enter the data. To do this, click the Worksheet tab
at the bottom of the Analysis panel.
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 You can see that the panel on the right side of the Project window now displays the information in a
tabular format similar to typical FMEA spreadsheet reports. To display more of the worksheet within the
window, click the Hide System Hierarchy icon.

The Project window will now look like the figure shown next.

When you are editing data in the worksheet view, keep the following tips in mind.

 When the cell has a blinking cursor inside, it is in “edit mode” and you can edit the text by typing
directly within the cell. To initiate the edit mode, simply double-click the cell or click the cell and press
ENTER to display a blinking cursor inside the cell. When you are in the edit mode, you can press TAB
to edit the text in the cell to the right, SHIFT+TAB to edit the text in the cell to the left or ENTER to
edit the text in the cell below. 

 In this mode, the shortcut menu allows you to cut, copy, paste, delete or select the text within the cell.

 When you are in the edit mode, some cells will contain drop-down lists and some will contain dates.
Other cells take only text input; these cells contain the Select Existing icon. For the remainder of this
example, you can enter the text specified in each step or you can use the Select Existing functionality.

 To stop the edit mode, press ALT (which will save your last text change) or ESC (which will not save
your last text change). 

 When the cell has a blue background, the record is selected but not in edit mode. When you are not in the
edit mode, you can use the navigation arrows to move up, down, right or left within the worksheet.

 In this mode, the shortcut menu allows you to add, insert, edit, delete, copy and paste entire records.

You can now add the following function:

 Bake out the product.

 To add a function, click inside the Function column and type the function description. A single click
allows you to edit a cell that is already selected. To edit a cell that is not selected, double-click the cell.
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4.3.5  Define the Potential Failure Mode

 Enter the following failure mode in the Potential Failure Mode column:

 Insufficient moisture elimination.

4.3.6  Define the Potential Effect of Failure

 Enter the following potential effect in the Potential Effect(s) of Failure column:

 Cracking of modules at card assembly.

 To assign the initial severity rating, choose 8 - Loss of Primary Function from the drop-down list that
appears when you edit the cell in the SEVi column. The severity rating scale that has been assigned to
this project was obtained from the AIAG FMEA-4 guidelines and predefined in Xfmea's profiles and
libraries.

4.3.7  Define the Potential Causes of Failure

 Enter the following potential cause in the Potential Causes(s) of Failure column:

 Insufficient bake temperature.

4.3.8  Define and Classify the Current Controls

For this example, there are two controls associated with the cause:

 Prevention Control: Thermocouple motor and alarm.

 Detection Control: Monthly bakeout monitor.

 Enter the prevention control in the Current Process Controls (Prevention) column and specify the initial
occurrence rating for the cause by choosing 3 - Low from the drop-down list in the OCCi column.

 To add the next control, choose FMEA > Controls > Add New Control. A new row will be added to the
FMEA worksheet, with all columns to the left of the Current Process Controls columns unavailable.
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 Enter the detection control in the Current Process Controls (Detection) column and specify the initial
detection rating for the cause by choosing 6 - Low from the drop-down list in the DETi column. When
you exit edit mode, the initial RPN will be calculated and displayed in the RPNi column, as shown next.

The next step in a typical FMEA would be to go through this process for all functions and failure modes that
the analysis team identifies. Once all initial RPNs have been determined, you can then prioritize the issues
based on risk. At that point, you can select issues for improvement and define appropriate recommended
actions.

4.3.9  Identify and Assign the Recommended Action

 Enter the following action in the Recommended Action(s) column for either one of the two rows:

 Increase frequency of bakeout monitor to weekly.

 Assign responsibility for the action by entering a name in the Responsibility column.

 Enter a due date for the action in the Target Completion Date column, either by using the calendar or by
typing the date in the mm/dd/yy or mm/dd/yyyy format.

4.3.10  Specify the Action Taken

 In the Actions Taken column, enter Implemented weekly bakeout monitor.

 In the Effective Date column, enter today’s date.

4.3.11  Revise the Severity Rating for the Effect

In this example, the action taken has no effect on the severity of the effect itself.

 To specify this, choose 8 - Loss of Primary Function from the drop-down list in the SEVr column.

4.3.12  Revise the Occurrence and Detection Ratings for the Cause

In this example, the action taken has no effect on the likelihood of occurrence.

NOTE: If you exit the worksheet view and then re-open it, the two controls will be displayed in the same row.
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 In the OCCr column, choose 3 - Low from the drop-down list. 

The action is expected to increase the likelihood that the failure will be detected before the product reaches
the end user.

 In the DETr column, choose 3 - High from the drop-down list.

You will now notice that the revised RPN for the cause, shown in the RPNr column has been calculated
automatically.

 To view the reduction in the RPN, select the cause in the worksheet and choose FMEA > Cause > Edit
Cause. In the Revised Ratings area of the Cause Properties window that appears, you can see that the
RPN has been reduced by 50% (i.e. from 144 to 72).

 Close the Cause Properties window.

4.3.13  Generate a Report of the Analysis

 Choose Tools > Reports to open the Reports window.

Because it is the only item in the project, the CMOS Memory item will already be selected for inclusion in
the report.

 Select the following forms to be included in the generated report:

 General

 Report Summary

 Rating Criteria and Classifications 

 FMEA Spreadsheet

 AIAG Form A

 Use the Exclude icon (<) to remove any other forms from the Selected Reports area.
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 In the Select Output Type area of the window, select Excel Spreadsheet. The Reports window will look
like the one shown next.

 Click Generate Report. The Save Report As window will appear, which allows you to specify the name
and location for the report. Specify to save the report as Process FMEA Report and click Save.

 The report will be created and will open automatically in Microsoft Excel. Each form that you selected
for inclusion will appear in a separate worksheet.

 Once you have examined the report, close Microsoft Excel and then close the Reports window.

4.3.14  Last Steps

 To restore the Project window to its default appearance with the System Hierarchy panel on the left and
the hierarchical view of the FMEA displayed on the right, click the Hierarchy tab at the bottom of the
Analysis panel and choose View > Split Screen or click the Split Screen icon.

 Close the project. Leave the database open and proceed to the next example.

4.4  Example 3 - Quantitative and Qualitative Criticality Analysis

This example will guide you through the process to perform both quantitative and qualitative criticality
analyses patterned after the MIL-STD-1629A guidelines. This example also will demonstrate Xfmea's direct
integration with ReliaSoft's Weibull++ life data analysis software and the capability to work with files
created with other software that have been linked or attached to the Xfmea analysis.

For this example, you will work with a database that has been prepared by ReliaSoft, which contains sample
data related to imaginary products. Sample data sets are not intended to be realistic.
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4.4.1  Import a Project

 Choose Project > Import Projects to open the Import Projects window, which allows you to import a
project from another Xfmea 5 database.

 In the Import From area of the Import Projects window, select Standard Database and then click
Browse.

 Select the TrainingData.rx5 file from the Training folder in your application directory (e.g. C:\Program
Files\ReliaSoft\Xfmea5\Training) and click Open. The projects in the selected database will be
displayed in the Import Projects window.

 Select the Quantitative Criticality project and click OK to import it to the current database. When the
import is complete, the project will appear in the Project Explorer.
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 Double-click the project name, Quantitative Criticality, to open it. With Component A selected, the
Project window will look like the figure shown next.

4.4.2  Link and Attach Files to the Analysis

Xfmea allows you to link and/or attach files that were created in other applications. This allows you to keep
supporting documentation all together in the same place with the analysis.

For links, Xfmea stores the full pathname/filename of the file and allows you to open and/or print the file
directly from within Xfmea (as long as the necessary software is installed on your computer and the link is
valid). The file is not stored inside the database and the link does not increase the size of the database.

For attachments, Xfmea stores a complete copy of the file inside the database. If you transfer the database,
the attached file will be transferred with the database. If you update the information in the attached file, you
can save your changes and the modified file will replace the existing file automatically. The attachment will
increase the size of your database.

 For this example, you will link a Weibull++ Folio that you can use to obtain the Item Reliability
distributions and parameters. Select the item called Component A and choose System Hierarchy >
Attachments > Item Attachments.

 Click the Add File Link button, then select the file called Criticality Example Data.rwp in the
Training folder in your application directory (e.g. C:\Program Files\ReliaSoft\Xfmea5\Training) and
click Open.
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 The Links and Attachments window will now look like the figure shown next.

You can see that the file name has been added to the list of linked files at the top of the window, with the file
name, size, extension, date and time the file was last modified and the file location displayed.

When you close the Item Links and Attachments window and return to the Project window, you will see that
a paper clip icon has been added to the Attachments column in the System Hierarchy panel, to indicate that

the item has one or more linked or attached files.4

Follow a similar procedure to link the same file to Component B and Component C.

4.4.3  Use Weibull++ to Set Item Reliability

Now you can use the linked Weibull++ file to define the reliability characteristics for each of the items in
this project.

 First, select Component A in the System Hierarchy panel. At the top of the Analysis panel, click the
Item Properties tab.

 Choose System Hierarchy > Item Reliability or, on the Item Properties tab, click the Reliability icon to
open the Item Reliability window. 

4. If this column is not displayed, choose File > User Setup and select the Attachment check box on the System
Hierarchy page, then click OK.

NOTE: Although you must have Weibull++ installed to use this function, you can still work through the example
if it is not installed on your computer by manually entering the parameters, which are shown in this guide.



4.4  Example 3 - Quantitative and Qualitative Criticality Analysis

 Xfmea Training Guide 59

 For Data Source, type In-house testing and Weibull++ analysis, as shown next.

 Then click the Weibull++ icon.

 The Select Weibull++ Folio window will appear, as shown next. 
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 Click the link in the Linked and Attached Folios list. The Weibull++ Data Folio will look like the figure
shown next. 

 Select Weibull from the Distribution menu and 3 from the Parameters/Type area.

 Calculate the parameters by clicking the Calculate icon.

 Close the Weibull++ Folio and answer Yes when prompted to save the changes you made to the
Weibull++ Data Folio. Then answer Yes when prompted to update the Item Reliability window with the
distribution and parameters calculated in Weibull++.
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The Item Reliability window will now look like the figure shown next.

 Click OK to apply the changes and close the window.

 The reliability information for the component will now appear in the Item Properties tab, as shown next. 

 Follow a similar procedure to define the reliability characteristics of Component B and Component C.
You should use the appropriate data sheet for each component. The data sets for these components have
been entered into additional sheets in the same Weibull++ Data Folio, Criticality Example Data.rwp.
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 For Component B, you must use a 2-parameter Weibull distribution. To do so, select 2 from the
Parameters/Type area before clicking the Calculate icon. The Item Reliability window for Component B
will look like the figure shown next.

 For Component C, you must use a 3-parameter Weibull distribution. To do so, select 3 from the
Parameters/Type area before clicking the Calculate icon. The Item Reliability window for Component C
will look like the figure shown next.

4.4.4  Perform the Quantitative Criticality Analysis

 To perform the quantitative criticality analysis, choose Tools > Criticality Analysis and then select all of
the items to be included in the analysis and click OK. The Criticality Analysis window will look like the
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figure shown next. You can use the horizontal and vertical scroll bars to view the full analysis or re-size
the window as needed to display the full analysis without scrolling.
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 Change the Operating Time to the time of interest for this analysis, 1000, and click Calculate to update
the Expected Failures, Mode Criticality and Item Criticality columns. The window will now look like the
figure shown next.

The Expected Failures values are based on the operating time that you entered and the reliability
characteristics that have been defined for each item. The Mode Criticality values are calculated by
multiplying the Expected Failures x Mode Ratio x Prob of Loss. The Item Criticality values are the sum of
all Mode Criticalities associated with each item.

You can see that Component A has the highest criticality, followed by Component C and then Component B.
The first failure mode for Component A, called Failure Mode 1, has the highest criticality among the modes.

 If desired, you can create a report of the analysis by selecting the output type (Microsoft Word or Excel)
and clicking Generate Report. When you are finished, click Close to exit the utility and return to the
Project window.

NOTE: The original MIL-STD-1629A approach assumes that the failure behavior of each item follows an
exponential distribution and can therefore be defined with a failure rate (  ) that does not vary with time. This
failure rate can then be multiplied by the operating time (  x t ) in order to estimate the expected number of
failures value, which is then used in the Mode Criticality calculation. However, in reality, the constant failure rate
assumption is not valid for many types of components that will be analyzed with the FMECA methodology (e.g.
components that exhibit infant mortality, wearout or other types of non-random failure behavior). Therefore,
ReliaSoft's engineers have developed an alternative criticality calculation method that will allow analysts to
define the failure behavior more realistically using the Weibull, lognormal or other statistical lifetime distribution
but still returns results identical to the original MIL-STD calculation method if all items have been defined with a
constant failure rate. When the item's reliability/unreliability is defined with the exponential distribution, this
calculation will return the same value as the  x t calculation specified in the original MIL-STD guidelines.
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4.4.5  Create a Duplicate Project

The previous part of this criticality analysis example follows the quantitative criticality analysis procedures
described in MIL-STD-1629A (i.e. it uses the Expected Failure metric that has been obtained
quantitatively). The rest of this example will demonstrate Xfmea's features for qualitative criticality
analysis.

 Create a duplicate of the Quantitative Criticality project by selecting it in the Project Explorer and then
choosing Project > Duplicate Project. The duplicate project will be named “Quantitative Criticality_1.”

 Select the Quantitative Criticality_1 project and choose Project > Project Properties. In the Project
Properties window that appears, change the project name to Qualitative Criticality. Notice that the rest
of the project properties are the same as those for the Quantitative Criticality project, including the MIL-
STD-1629A profile.

 Click OK to save the changes and close the window.

 Open the Qualitative Criticality project.

4.4.6  Define the Qualitative Criticality Analysis Factors

The next step is to define the qualitative criticality analysis factors for each of the failure modes in the
analysis.

 To begin, select Component A in the System Hierarchy panel. On the FMEA tab in the Analysis panel,
double-click Failure Mode 1.

 In the criticality analysis factors area of the Failure Properties window, click the Select Existing icon
associated with the Failure Probability field and select Level C - Occasional from the Select Failure
Probability window, as shown next.

 Click OK (or double-click the selection) to update the Failure Properties window with your selection.
Then, follow a similar procedure to assign Category II - Critical to describe the Severity Classification.
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Note that because you are using the predefined MIL-STD-1629A profile, the qualitative Failure Probability
and Severity Classification scales have been predefined in this project to match the criteria presented in the
military standard. For your own qualitative criticality analyses, you may choose to use any of the predefined
rating scales or your own custom scales to make these assignments.

 Click OK to save the changes and close the window. You could repeat the procedure to define the
qualitative criticality analysis factors for all of the remaining failure modes via the Failure Properties
window. However, you also can make these assignments quickly and easily within the Criticality
Analysis window. This method will be described next.

4.4.7  Perform the Qualitative Criticality Analysis

 Choose Tools > Criticality Analysis and then select all items to be included in the analysis. When the
Criticality Analysis window opens, select the Show Columns for Qualitative Analysis check box on
the right side of the window. This will add additional columns to the analysis worksheet.

 Scroll all the way to the right to view the new columns. Then, click inside the Severity Class column for
Failure Mode 2 and choose Category IV - Minor from the drop-down list that appears. If you prefer to
view detailed descriptions of the severity classes, you can click the Browse (...) icon that appears along
with the drop-down list to view the Select Severity Class window, as shown next.
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 Follow a similar procedure to make the rest of the Severity Class and Failure Probability assignments. A
complete list of the assignments is presented in the following table, including the ones you have already
made.

When you are finished, the window will look like the figure shown next.

4.4.8  Generate the Report

 Make the following selections in the Generate Criticality Reports area.

 Select Forms:

 FMECA Report Summary

 Criticality Analysis (MIL-STD Qualitative)

Failure Mode Severity Class Failure Probability

Failure Mode 1 Category II - Critical Level C - Occasional

Failure Mode 2 Category IV - Minor Level B - Reasonably Probable

Failure Mode 3 Category II - Critical Level D - Remote

Failure Mode 4 Category III - Marginal Level C - Occasional

Failure Mode 5 Category III - Marginal Level E - Extremely Unlikely

Failure Mode 6 Category I - Catastrophic Level D - Remote

Failure Mode 7 Category IV - Minor Level A - Frequent
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 Criticality Matrix (MIL-STD Qualitative)

 Output Type: Excel Spreadsheet

 Click Generate Report.

 Type Qualitative Criticality for the report name and then click Save to generate the report in Microsoft
Excel.

 Once the report has been generated and the Excel spreadsheet opens, click the Criticality - MIL Qual
tab to view the qualitative spreadsheet report. You will notice that instead of calculated criticality values,
this report displays the Severity Classifications and Failure Probabilities that you assigned to each failure
mode.

 Click the Criticality Matrix - MIL Qual tab to view the qualitative matrix. For the qualitative analysis,
this matrix displays the Severity Classification on the X-axis and the Probability of Occurrence on the
Y-axis. You may notice that this is similar to the Severity/Occurrence matrix that is available in the Plot

Viewer for analyses that use RPNs for risk assessment.5

 Close Excel and return to Xfmea.

 Click Close to close the Criticality Analysis window. 

 Close the database by choosing File > Close Current Database.

4.5  Example 4 - Import/Export for Items and/or FMEAs

This example guides you through the process to import/export system configuration data and FMEA data

from Excel files.6

5. The colors used in the criticality matrix represent the high, medium and low priority thresholds. The colors used and
the threshold limits can be specified in the interface style defined for the project.
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4.5.1  Export a System Configuration to Excel

 To begin, choose File > Open Standard Database or click the Open Standard Database icon. 

 Select the TrainingData.rx5 file from the Training folder in your application directory (e.g. C:\Program
Files\ReliaSoft\Xfmea5\Training) and click Open.

 In the Project Explorer, double-click the Import and Export Data project. 

 Choose System Hierarchy > Import/Export > Export to Excel.

 The Export Type field allows you to specify the type of information that you want to send to Excel, such
as the items in the system hierarchy, the FMEA hierarchy or DVP&R for the selected item, etc. For this
example, choose Items. This will export the items in the system hierarchy, along with their item
properties and any defined reliability properties.

 In the Export Template field, accept the System Hierarchy template, which is provided by default. (If
your exporting needs differ from the format provided in the default template, this field allows you to
choose a different template for use, add a new template and/or edit an existing template.)

 At the bottom of the Export to Excel window, choose to export the Entire System Hierarchy, as shown
next, then click OK.

 Type System Configuration for the Excel filename and then click Save.

When the process completes, the Excel file will open automatically. Examine the exported information.
Notice in particular that the top row contains header information and the actual data starts in row 2. You will
need this information in a subsequent step.

 After you have reviewed the export file, close Excel and return to Xfmea.

4.5.2  Open a Database and Create a Project

 Open the TrainingExamples.rx5 database that you created in Example 1 by choosing File > Recent and
then choosing the Training Examples.rx5 file. 

 Choose Project > Add New Project. In the New Project window, type Import and Export for the
project name and choose the Standard FMEA profile to set the properties for the new project.

 Click OK to create the project and display the Project window.

6. Xfmea also provides import functionality for data from ReliaSoft’s XFRACAS system and from Ford Motor
Company's FMEAplus F2F export files. For more information about importing and exporting, refer to the Xfmea
User’s Guide.
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4.5.3  Import the System Configuration from Excel

 Delete the item (i.e. System 1) that was automatically added to the system hierarchy when the project
was created by right-clicking it and choosing Delete from the shortcut menu or by selecting it and then
pressing DELETE or clicking the Delete icon. 

 Choose System Hierarchy > Import/Export > Import from Excel.

 In the Import Type field, choose Items. This will import the items in the system hierarchy, along with
their item properties and any defined reliability properties.

 In the Import Template field, accept the default template, System Hierarchy. 

 Click Browse and, in the window that appears, navigate to the System Configuration.xls (or .xlsx) file
that you just created, then click Open.

 In the Worksheet field, accept the default selection, System Hierarchy. (If there were more than one
worksheet in the selected Excel file, this field would allow you to specify the worksheet to import from.)

 The Starting Row field allows you to specify the first row of the Excel worksheet that contains data,
rather than header information. You will recall that the data in your export file started in the second row,
so enter 2 in this field.

 Click Next to view a preview of the data that will be imported. Scroll through the preview to make sure
that the appropriate information appears in each column, then click Finish to perform the import.

 When import is complete, you will see that the system configuration information from the Excel
spreadsheet has been imported into the current project.

4.5.4  Import Item’s FMEA from an Existing Xfmea Project

As mentioned in the preceding sections, it is possible to import FMEA data from Excel, either separately
from a system hierarchy or simultaneously, depending on the information contained in the Excel
spreadsheet. Xfmea also offers the capability to import from existing Xfmea projects in the current database

or in other databases, which is demonstrated in this section.7

7. The window presented in this section also allows you to import from the FMEA Accelerator® templates that have
been enabled on your computer (if any). For more information on FMEA Accelerator® templates, please refer to the
Xfmea User’s Guide.
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 Select the Component B.2.4 item in the System Hierarchy panel and choose System Hierarchy >
Import/Export > Import Existing Items (Browse). The Import Existing Items (Browse) window will
appear, as shown next.

 In the Data Source area, select Standard Database and then click Browse.

 Select the TrainingData.rx5 file from the Training folder in your application directory (e.g. C:\Program
Files\ReliaSoft\Xfmea5\Training) and click Open.

 In the Projects area, select the Import and Export Data project.

 At the bottom of the window, select the Import Selected FMEA Items Only option. This option allows
you to import only the records selected in the FMEA Hierarchy area, without importing any items from
the system hierarchy. The imported records will be associated with the item that was selected in the
System Hierarchy panel when you opened the Import Existing Items (Browse) window.
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 In the System Hierarchy area, select Component B.2.4. The FMEA Hierarchy area on the right side of
the window will update to show the FMEA that is associated with the selected item, as shown next. 

 Select the check box in the Description header of the FMEA Hierarchy area to select all items in the
FMEA hierarchy.

 Click Import. You will see a confirmation once the import is complete. Click OK to continue.

 Close the Import Existing Items (Browse) window.

You can see that the functions, failures, effects, causes, controls and actions that were defined in the existing
Xfmea project have been added to the current project, as shown next.

 Close the project before proceeding with the next example.8
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4.6  Example 5 - Design Review Based on Failure Mode Analysis

Xfmea supports the Design Review Based on Failure Mode (DRBFM) methodology, which is used in the
automotive and other industries for evaluating proposed changes to an existing design. Xfmea allows you to
attach a DRBFM analysis to any item in the System Hierarchy. 

4.6.1  Import a Project

 Choose Project > Import Projects to open the Import Projects window.

 In the Import From area of the Import Projects window, select Standard Database and then click
Browse.

 Select the TrainingData.rx5 file from the Training folder in your application directory (e.g. C:\Program
Files\ReliaSoft\Xfmea5\Training) and click Open. The projects in the selected database will be
displayed in the Import Projects window.

 Select the DRBFM project and click OK to import it to the current database. When the import is
complete, the project will appear in the Project Explorer.

 Double-click the project name to open it. 

4.6.2  Display the DRBFM Column

 Choose File > User Setup to open the User Setup window.

 On the System Hierarchy page, select the DRBFM column option then click OK.

 When you return to the Project window, you will see the DRBFM column displayed in the System
Hierarchy. The column is designated by the following icon. 

This example focuses on a hair dryer. A proposal to change the way the motor of the hair dryer is attached to
the motor holder is being evaluated. An FMEA has been prepared for the Attaching Screws item in the
system hierarchy. You will now create a DRBFM to examine the proposed change. 

4.6.3  Design Engineer - Create a DRBFM

 With the Attaching Screws item selected in the System Hierarchy, choose Analyses > Add DRBFM
Analysis or click the Add DRBFM Analysis icon. 

The DRBFM tab will open in the Analysis panel. In addition, the DRBFM icon (R) will appear in the
DRBFM column in the System Hierarchy panel.

 In the Analysis panel, click the Header tab at the bottom of the window to view and change the header
information that will be displayed at the top of the DRBFM report. You can enter the header information

8. Xfmea offers many other options for importing and exporting data. For more information, refer to the Xfmea User’s
Guide.
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automatically by choosing DRBFM > Get Header from FMEA. The information from the FMEA
header will be used to populate the header, as shown next.

 Return to the Worksheet tab of the DRBFM analysis in the Analysis panel.

The utility provides two different “views” for the worksheet, which you can select at the top right corner of
the Analysis panel; one is intended to be used by the Design Engineer who performs the first draft of the
analysis and the other is intended to be used by the entire Review Team to modify and expand upon the
initial draft. For now, the worksheet should be in Design Engineer view. If it is not, select Design Engineer
immediately above the DRBFM worksheet.

 You can import the functions you created in the FMEA to the DRBFM. Choose DRBFM > Get
Functions from FMEA. A window allowing you to select the functions you want to transfer will appear,
as shown next.

Select all three functions, either by selecting their individual check boxes or by selecting the check box
in the Function header, and click OK. The functions will be transferred to the DRBFM. Each function is
imported as a new row. 

 Double-click inside the first cell in the Part/Change to Design or Environment column and enter the
following proposed change:

 Eliminate screws - change from screw attachment to press fit between motor holder and motor.
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The DRBFM will now look like the one shown next.

 Enter the concerns (i.e. failure modes), effects, causes and controls shown next in the appropriate
columns. You can enter a line break in a cell by pressing CTRL+ENTER.

 Function: Screws prevent rotation between motor and holder.

 Concerns Related to Change: Motor may rotate inside motor holder.

 Potential Effects of Concern: 

Noise/vibration.

Electrical connections to motor twisted/broken.

 Potential Cause of Concern: No feature to prevent rotation between motor and vanes.

 Function: Screws provide serviceability.

 Concerns Related to Change: Motor no longer easily separated from motor holder for service.

 Potential Effects of Concern: Customer not able to service motor, must replace hair dryer.

 Potential Cause of Concern: Pressfit prevents separation of parts without damage.

 Current Design Controls - Detection: General unit testing to determine frequency of problem.

 Function: Screws seat/secure motor holder to motor.

 Concerns Related to Change: Motor comes loose from motor holder in axial direction.

 Potential Effects of Concern: 

Contact between fan and motor holder - noise/vibration.

Fan stops turning.

 Potential Cause of Concern: Improper spacing between motor and motor holder.

 Current Design Controls - Detection: Take measurements on multiple units to determine
spacing thresholds.
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The DRBFM will look like the one shown next. 

4.6.4  Review Team - Review the DRBFM

Once the Design Engineer has created the first draft of the analysis, the Review Team can then modify and
expand upon it. For example, they might identify additional concerns or additional causes for existing
concerns. The team will then define recommended actions to address the concerns that have been identified.

 Select Review Team above the DRBFM worksheet to change to the Review Team view. You will note
that several more columns appear.

 For the first function, enter the following action in the Recommended Action - Design column:

 Redesign motor and motor holder with asymmetric shape (e.g. tab and notch) to ensure that
rotation is impossible.

 For the third function, enter the following action in the Recommended Action - Design column:

 Add 3 plastic spacers to ensure proper spacing.

4.6.5  Generate a DRBFM Report

The next step is to generate a report of the DRBFM analysis.

 Choose Tools > Reports to open the Reports window.

 In the Select Items area, select the check box for the Attaching Screws item, if it is not already selected,
to include it in the report. Clear any other items.

 In the Available Reports area of the window, select the DRBFM Standard form, located under the
DRBFM Spreadsheet heading, and then click the Include icon (>) to add it to the Selected Reports area.

 Use the Exclude icon (<) to remove any other forms from the Selected Reports area.

 Select Word Document for the report output type.

 Click Generate Report and save the report as DRBFM.

 The report will be created and will automatically open in Microsoft Word. 

 Once you have finished viewing the report, close Microsoft Word.

 Close the Reports window.

4.6.6  Transfer the Data to the FMEA

You may choose to append the data from the DRBFM to your original FMEA.
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 Choose DRBFM > Send Functions to FMEA. In the window that appears, select all three functions,
either by selecting the check box corresponding to each function or by selecting the check box in the
Function header.

 Click OK. You will see a confirmation once the transfer is complete.

 Click the FMEA tab.

Take some time to investigate how the DRBFM analysis information has been transferred to the FMEA. You
will notice, for example, that the data from the Concerns Related to Change columns transfer to the FMEA
as failure modes. You might choose to copy these new failures to the original function records in addition to
the original failure records.

 Close the project and proceed to the next example.

4.7  Example 6 - DFMEA and DVP&R

This example guides you through the process of creating a Design Verification Plan and Report (DVP&R).
The DVP&R is a worksheet that is used to track the progress of design verification tests. The lessons learned
from the DFMEA can be a valuable input to the DVP&R (and vice-versa).

For this example, you will import a project containing the item and its DFMEA from a sample database that
has been prepared by ReliaSoft. This database contains sample data based on a modified version of the
example provided in the AIAG FMEA-4guidelines. Sample data sets are not intended to be realistic.

4.7.1  Import a Project

 Choose Project > Import Projects and import the DFMEA and DVP&R project from the
TrainingData.rx5 file in the Training folder in your application directory (e.g. C:\Program
Files\ReliaSoft\Xfmea5\Training). When the import is complete, the project will appear in the Project
Explorer.

 Double-click the project name to open it. 

 Click the FMEA tab at the top of the Analysis panel and then click anywhere inside the FMEA and
choose View > Expand Tree or click the Expand Tree icon.

In the FMEA, you will notice that the “Vehicle durability test” control appears numerous times and that its
icon is different from the icon used by other controls. This is because the controls are linked; essentially,
only one instance of the control exists, and it is used in multiple places. For more information on linked
controls and linked actions, please refer to the Xfmea User’s Guide.

4.7.2  Display the DVP&R Column

 Choose File > User Setup to open the User Setup window.

 On the System Hierarchy page, select the DVP&R option then click OK.

 When you return to the Project window, you will see the DVP&R column displayed in the System
Hierarchy. The column is designated by the following icon. 
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4.7.3  Customize the DVP&R Synchronization Options

When creating a new DVP&R, you have the ability to transfer data from the associated FMEA, providing a
starting point for the full DVP&R analysis. In addition, you can synchronize an existing DVP&R with the
associated FMEA at any time. By default, only the controls from the FMEA are automatically transferred to
the new DVP&R. For this example, however, we also want to transfer actions that have been assigned to the
“Testing” category.

 Choose Project > Project Properties.

 On the Configurable Settings page of the Project Properties window, click the View/Edit Settings icon
for the current interface style. 

 In the navigation panel on the left side of the Edit Project Interface Style window that appears, click
Synch Options under the DVP&R heading.

 Make sure the Integrate New DVP&Rs with FMEA option is selected. This causes data to be
automatically transferred from the FMEA to the DVP&R when a new DVP&R is created.

 Select the Transfer Controls and Actions option and, in the Specify Action Categories field, enter
Testing. The window will look like the one shown next.

4.7.4  Customize the Columns Shown in the DVP&R

In the navigation panel, click Plan under the DVP&R heading. You will see all of the properties that are
available for the FMEA header in a table with five columns.

 You can click the Enabled column for each property to toggle the property between displayed (Yes) and
hidden (no). For this example, make sure the following properties are enabled and set the remaining
properties to No:

 Test Request #
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 Test/Specification Method

 Acceptance Criteria

 Planned Sample Size

 Planned Start

 Planned End

 Assigned To

 Notes (Plan)

 Click OK to apply your changes and close the Edit Project Interface Style window, then click OK to
accept your changes and close the Project Properties window.

4.7.5  Create a DVP&R

 To create a DVP&R for the Front Door L.H. item, select the item and then choose Analyses > Add
DVP&R Analysis or click the Add DVP&R Analysis icon. 

The DVP&R tab will open in the Analysis panel. In addition, the DVP&R icon (D) will appear in the
DVP&R column in the System Hierarchy panel.

4.7.6  Define the Plans and Reports

A DVP&R can have zero, one or many plan records. Each plan can be associated with zero, one or many
report records. The background color in each cell of the worksheet identifies the record type (plan = blue
and report = green). 

NOTE: The changes you made apply only to the current project. When you work with any other project, these
synchronization options may be different.
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You will notice that the controls and the specified actions from the FMEA have been transferred
automatically to the Test/Specification Method column in the DVP&R, as shown next. This can be the
starting point for completing the rest of the worksheet. 

 To edit the Acceptance Criteria for Test Request #1, double-click inside the cell. Type the following text
directly into the cell: 95% reliability (i.e. no corrosion) at XXX miles of operation. Press ENTER,
Tab or click somewhere outside of the cell to save the changes.

 Enter Per Established Test Plan in the Planned Sample Size column for Test Request #1.

 To edit the Planned Start for Test Request #1, double-click inside the cell and select a date two weeks
from now from the calendar that appears.

 Enter a date approximate a month later in the Planned End column for Test Request #1.

 Enter Test Lab in the Assigned To column for Test Request #1.
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To complete the DVP&R, you would continue to update the worksheet with information for each test plan,
as well as adding more test plans if necessary. The DVP&R with completed test plans is shown next, but it is
not necessary for you to take the time to enter all the data.

When results from the planned tests become available, you would then add one or more reports for each test
plan. For example, the test report section of the DVP&R is shown next, with a report added for the first test
plan.

If additional controls and/or testing actions are added to the FMEA during this process, you can add them to
the DVP&R by choosing DVP&R > Synch and selecting the appropriate options in the Synchronization
Options window (e.g. you could select to append data from the FMEA to the end of the worksheet, rather
than clearing the worksheet and starting over, and you could choose to transfer only new records, last
updated after a specified date).

 Close the project before proceeding with the next example.
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4.8  Example 7 - PFMEA and Control Plan

This example guides you through the process of creating a Control Plan. The Control Plan describes the
actions that are required at each phase of the process to assure that all process outputs will be in a state of
control. The Process Flow Diagram and the lessons learned from a Process FMEA can be a valuable input to
the Control Plan.

For this example, you will work with sample data based on a modified version of the example provided in
the AIAG FMEA-4 guidelines. Sample data sets are not intended to be realistic.

4.8.1  Import a Project

 Choose Project > Import Projects and import the PFMEA and Control Plan project from the
TrainingData.rx5 database in the Training folder in your application directory (e.g. C:\Program
Files\ReliaSoft\Xfmea5\Training). When the import is complete, the project will appear in the Project
Explorer.

 Open the project. You will see that the system hierarchy contains one item, Front Door L.H., which has
an associated FMEA.

4.8.2  Display the Control Plan Column

 Choose File > User Setup to open the User Setup window.

 On the System Hierarchy page, select the Control Plan option then click OK.

 When you return to the Project window, you will see the Control Plan column displayed in the System
Hierarchy. The column is designated by the following icon. 

4.8.3  Create a Control Plan

 To create a Control Plan for the Front Door L.H. item, select the item and then choose Analyses > Add
Control Plan Analysis or click the Add Control Plan Analysis icon. 

The Control Plan tab will open in the Analysis panel. In addition, the Control Plan icon (C) will appear in the
Control Plan column in the System Hierarchy panel.

4.8.4  Revise the Characteristics and Methods

A Control Plan can have one or more part/process records. Each part/process can be associated with one or
more characteristic records and each characteristic can be associated with one or more methods. The
background color in each cell of the Control Plan worksheet identifies the record type (part/
process = purple, characteristic = green and method = tan). 

Notice that the function from the FMEA has been transferred to the Process Name/Operation Description
column in the Control Plan. The causes from the FMEA have been transferred to the Process Characteristic
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column and the Class selection for each cause has been transferred to the Classification column. In addition,
the controls from the FMEA have been transferred to the Control Method column. 

The newly created Control Plan is shown next.

This provides a starting point for your Control Plan analysis, although your desired final Control Plan may
be rather different from the initial transferred data. The final Control Plan for this example is shown on the
next page.

NOTE: The way the FMEA records are transferred in this example are representative of the default
synchronization settings. These settings can be modified on the Control Plan > Synch Options page of the Edit
Project Interface Style window.
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You will notice that the first revised process characteristic, “Spray head correctly positioned, not damaged,
not clogged,” encompasses the information that was originally conveyed by three of the transferred causes:
“Spray head clogged because viscosity is too high, temperature is too low or pressure is too low;” “spray
head not inserted far enough;” and “Spray head deformed due to impact.” The second revised process
characteristic, “Spray time,” corresponds to the final transferred cause, “Spray time insufficient.” These
changes were made to better express the actual process characteristics that are being controlled. In addition,
two product characteristics have been added: “Wax thickness” and “Wax coverage.”

 To do this in your Control Plan, double-click the first cell in the Process Characteristic column and then
delete the original text (“Spray head clogged because viscosity is too high, temperature is too low or
pressure is too low”) and type the new text (Spray head correctly positioned, not damaged, not
clogged.) instead. Do the same for the second process characteristic. For the third and fourth process
characteristics, delete the text entirely and type the new text in the Product Characteristic column
instead.

There are several controls that were used for multiple causes in the FMEA, so those controls transferred
multiple times. For instance, the “Preventive maintenance program to maintain heads” control transferred
along with both the first cause, “Spray head clogged because viscosity is too high, temperature is too low or
pressure is too low,” and the fourth cause, “Spray head deformed due to impact.” Now that we have revised
the product and process characteristics, however, we want to associate each control only with the revised
characteristic to which it applies. 

 To do this, right-click the second cell in the Control Method column (i.e. “Variables check for film
thickness”) and choose Delete from the shortcut menu that appears. Continue to do this to remove the
remaining control methods that do not apply. 

An additional control method has been identified for the “Spray time” process characteristic. To add it:

 Select the Spray Time process characteristic and choose Control Plan > Add Method or right-click the
process characteristic and choose Add Method from the shortcut menu. Enter Spray Time. in the new
cell in the Control Method column. The Control Plan will look like the one shown next.

Note that not all columns are shown in the image above.

Completing the Control Plan is now a matter of filling out the remaining cells. For example, to complete the
first row:
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 In the Specification/Tolerance column, enter:

Viscosity must be AA to BB.

Temperature must be CC to DD.

Pressure must be EE to FF.

You can enter a line break in a cell by pressing CTRL+ENTER.

 In the Evaluation/Measurement Technique column, enter Instrument PQ12345.

 In the Sample Size column, enter Variable.

 In the Sample Frequency column, enter At start-up and after idle periods.

 In the Reaction Plan column, enter If spray head is clogged, perform maintenance and adjust
viscosity, temperature and/or pressure.

You would then continue to update the worksheet as shown on page 84. 

If additional functions, causes and/or controls are added to the FMEA during this process, you can add them
to the Control Plan by choosing Control Plan > Synch and selecting the appropriate options in the
Synchronization Options window (e.g. you could select to append data from the FMEA to the end of the
worksheet, rather than clearing the worksheet and starting over, and you could choose to transfer only new
records, last updated after a specified date).

 Choose File > User Setup to open the User Setup window.

 On the System Hierarchy page, clear the DRBFM, DVP&R and Control Plan options then click OK.

 Close the project before proceeding with the next example.

4.9  Example 8 - Using Change Logs

This example allows you to experiment with Xfmea's Change Log feature and guides you through the
process to create and manage versions of an Xfmea database.

For this example, you will work with a project that has been prepared by ReliaSoft, which contains sample
data related to imaginary products. Sample data sets are not intended to be realistic.

4.9.1  Import an Existing Project

 Choose Project > Import Projects and import the Data for Change Log project from the
TrainingData.rx5 database in the Training folder in your application directory (e.g. C:\Program
Files\ReliaSoft\Xfmea5\Training). When the import is complete, the project will appear in the Project
Explorer.
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 Open the imported project. With System A selected, the Project window will look like the figure shown
next.

4.9.2  Activate a Change Log

 Select Component A.1.1.1 in the System Hierarchy panel and click the FMEA tab in the Analysis panel. 

 Choose FMEA > Activate Change Log. You will see a warning notifying you that activating a Change
Log for this item will mean that users can only make changes to the analysis when a Revision is in
progress. Click Yes to continue. The FMEA Change Log window will appear, as shown next. 



4  Step-by-Step Examples

88 http://Xfmea.ReliaSoft.com

You will see in the Version History table that the only version of the analysis currently in existence is the
original version. Now that you have activated a Change Log for this system, there must be a Revision
currently in progress in order to make changes; if no Revision is in progress, the analysis will be locked.
Once a Revision is in progress, all changes made to the analysis will be logged. Note that you can configure
a Revision to require a reason for every change made, if desired, by selecting Require Reason for Change
in the FMEA Change Log window. It is also possible to require electronic approval when each Revision is
ended; this ensures that no further changes can be made to the analysis until the user(s) designated as

approvers have “signed off” on the most recent Revision.9

4.9.3  Start a New Revision

 Click Start Revision to begin a new Revision. The Version Details window will appear. The first new
Revision will always be a major revision to the original version (e.g. 1.0) instead of a minor revision
(e.g. 0.1), so the Major and Minor options are not available. Enter Revision 1 in the Version Label field.

 Click OK to return to the FMEA Change Log window. You will see that the new Revision now appears
in the Version History table.

 Click Close to return to the Project window. In the System Hierarchy panel, you will see that the icon in
the FMEA column for Component A.1.1.1 has changed, as shown next. 

This icon indicates that a Change Log is active for the item’s FMEA, and that a Revision is currently
open.

4.9.4  Make Changes to the Analysis

The Change Log tracks all changes made to the FMEA associated with the selected item. To see this process,
you will now make a few changes.

 Select Component A.1.1.1. In the FMEA tab in the Analysis panel, using the hierarchy view, double-
click Cause H under Effect A to open the Cause Properties window. You will notice that the Change
Log icon at the bottom of the window is unavailable; this is because no changes have yet been made to
the cause. 

9. For more information about the revision tracking and management features, refer to the Xfmea User’s Guide.
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 Change the Revised Occurrence rating for the cause to 1 - Very Low, as shown next, and click OK to
save your changes.

 Re-open the Cause Properties window for Cause H. You will see that the Change Log icon has become
active. 

 Click the icon to open the Record Change Log window, as shown next. 

You can see that the change you made is listed in the Record Change Log window.

 Click Close to return to the Cause Properties window.
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 Click OK to close the Cause Properties window.

4.9.5  End the Revision

 Choose FMEA > View FMEA Change Log. In the FMEA Change Log window that appears, you will
see that the change you made to the analysis is listed in the Change Log table, as shown next.

 Click End Revision. You will see a warning that users will not be able to make changes to the current
version of the analysis unless the Revision is re-opened. Click Yes to proceed.

 Close the FMEA Change Log window.
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In the System Hierarchy panel, you will see that the icon in the FMEA column for Component A.1.1.1 has
changed again, as shown next. 

This icon indicates that a Change Log is active for the item’s FMEA, but that no Revision is currently open.

4.9.6  Track More Changes in Another Revision

 Repeat the steps given above to start a new major Revision called Revision 2.

 In the Analysis panel, double-click Cause A under Effect A to open the Cause Properties window. 

 Click the Controls button to open the Controls window and then click Add. In the Control Properties
window, enter New Control for the name and select Prevention as the Control Type, as shown next.

 Click OK to add the control then click Close to close the Controls window. Finally, click OK to close the
Cause Properties window.

 Choose FMEA > View FMEA Change Log.



4  Step-by-Step Examples

92 http://Xfmea.ReliaSoft.com

 In the FMEA Change Log window, click End Revision.

 You will notice that only the changes from the most recent Revision are currently displayed in the
Change Log table. You can use the filters below the table to specify criteria for which changes are
displayed. For example, select All in the Revision field. All of the changes from both Revisions are now
displayed, as shown next. 
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 Then select Edit in the Change Type field. Only changes of type Edit from both Revisions are
displayed, as shown next.

4.9.7  Export Change Log Information

You can export the information from either the Version History table or the Change Log table to Microsoft
Excel, if desired.

 Click Export Change Log to export the current contents of the Change Log table to Excel (note that
because you have filtered the change records that are displayed, the exported data will correspond to the
filtered data shown in the Change Log table).

 In the Save File As window that appears, name the file Change Log and click Save. Xfmea will generate
a spreadsheet of the current Change Log view. Once the spreadsheet has been exported, it will open
automatically in Microsoft Excel.

 When you have finished viewing the report, close Microsoft Excel, then close the project.

4.10  Example 9 - Using Profiles/Libraries for Configurable Settings

All of the analysis settings that can be configured in Xfmea (including the data fields, the options in drop-
down lists, the rating scales used for risk assessment and other analysis preferences) are stored in the
database together with the data for each project. 

Xfmea allows authorized users to use the Profiles/Libraries Manager to manage predefined sets of
configurable settings in a library. This library will contain one or more profiles that can be used to set all of
the configurable settings for a particular type of FMEA. For example, you might have one profile for Design
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FMEAs and another profile for Process FMEAs. These settings can be copied from the library to a particular
project at any time.

The simplest way to set the properties for a particular project is to choose a profile from a drop-down list on
the General Page of the Project Properties. It is important to note that the settings are copied from the active
library to each project, not linked. If you change a predefined profile in the active library, the settings for
existing projects will not be updated automatically. However, you can easily apply the latest settings to an
existing project by opening the Project Properties and choosing the profile again from the drop-down list.

You also have the option to edit settings from within the Project Properties window. See Section 4.10.5 on
page 104. If you edit the profile from the General page, the changes will update the active library and also
update the current project. If you edit individual settings from the Configurable Settings page of the Project
Properties, the changes will update the current project only and the profile that was used to define the
settings originally will be unchanged. 

Therefore, if you want your changes to apply to all future projects, it is recommended that you edit the active
library (either via the Profiles/Libraries Manager or via the General page of the Project Properties) and then
re-apply the profile to any existing projects that need to be updated. If you want your changes to apply to a
particular project only, it is recommended that you edit the project settings directly via the Configurable
Settings page of the Project Properties.

This example allows you to experiment with Xfmea's profiles and libraries functionality and guides you
through the process to create your own custom libraries and profile.

NOTE: If a Standard database (*.rx5) is currently open, the active library is the separate Standard library file
(*.lb5) that has been specified at the top of the Profiles/Libraries Manager window. This can be a file on your own
computer or a shared file in a network location that other Xfmea users can edit also. 

If an Enterprise database (SQL Server) is currently open, the active library is stored within the Enterprise
database itself and the ability to edit this library is restricted to authorized users only.

NOTE: If you are using an Enterprise database to work through these examples but you do not have the
permissions necessary to edit the library data, you can create a new Standard database and practice in the
Standard library.
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4.10.1  Open the Profiles/Libraries Manager

 To open Xfmea's Profiles/Libraries Manager, choose Tools > Profiles/Libraries Manager. A window
like the one shown next will be displayed.

This window allows you to manage the configurable settings that are currently available to apply to new or
existing projects.

4.10.2  Create a Custom Interface Style

As the previous examples in this Training Guide have demonstrated, an interface style is a set of instructions
that determine the data fields that will be enabled/displayed in the Xfmea interface and report output, the
method of risk assessment, the order of worksheet columns and other configurable settings. For example, if
your organization captures three levels of effect description (e.g. Local Effect, Next Level Effect and End
Effect), then you can define the interface style to enable/display all three fields. If not, then you can define
the interface style to enable/display only one field and rename the field to be called “Effect Description” or
whatever terminology is appropriate for your application.

 To create your own custom interface style, which can be applied to the projects that you create in Xfmea,
select Interface in the navigation panel on the left side of the Profiles/Libraries Manager. The Interface
page shows a list of existing interface styles in the active library.
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 Click Add to open the Add Interface Style window.

4.10.2.1  Copying an Existing Style

Note that if there is an existing interface style that comes close to meeting your particular needs, you can
copy the style and modify it as necessary to define the new custom style. If you want to create your new
interface style based on an existing one, follow the steps described in this section. If this does not apply to
you, you can start with the default settings for a new interface style and skip ahead to the next section
(Section 4.10.2.2).

 To set the properties in your new style automatically based on the properties of an existing style, click
Copy Existing and then select the style from the Select Interface Style window that is displayed, as
shown next.

You can choose to select the style from a Standard library or an Enterprise library. If you use a Standard
library, you can select the style from the current library or click Browse to specify a different library file
(*.lb5) to choose from. If you use an Enterprise library, you will need to enter the server and database
names.
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 Click OK to update the settings for the new interface style you are creating with the settings from the
existing style. You can use these settings as a starting point and modify them as necessary to meet the
specific needs that will be addressed by the new style.

4.10.2.2  Name and Description

 In the Name field, type a name for the new interface style that will be meaningful to you, such as the
name of your company and perhaps the type of analysis that the style is appropriate for (e.g. “ReliaSoft
DFMEA” or “Acme FMECA”). This name must be unique among the interface styles that have been
created in the active library.

 If desired, type a more detailed description of the purpose in the Description field.

4.10.2.3  Customize the Settings

For item properties, FMEAs, risk assessment, control plans, DVP&Rs and DRBFMs, you can determine
which fields will be enabled/displayed in the interface and reports when this style is applied to the project,
what the fields will be called, the tooltip for each field (if any) and, for drop-down lists, the options available
in the list. You also have the option to set the order of the columns for the worksheet view. For example, to
modify the FMEA settings:

 In the navigation panel, select Header under the FMEA heading.

You will see all of the properties that are available for the FMEA header in a table with five columns:

 Property: Contains a list of all properties (data fields) that are available in Xfmea for the FMEA
header. You cannot change the information in this column.

 Type: Indicates the type of data contained in each property field (text, date, number or drop-down).
For text fields, the character limit is shown in parentheses. For drop-down lists, an Edit icon is
available. Editing drop-downs is presented later in this section.

 Enabled: Contains an indication of whether or not each property (field) will be enabled/displayed in
the interface and report output. You can set this to Yes or No by clicking inside the cell to toggle the
selection. Fields that cannot be disabled are marked with an asterisk in this column. Enabled fields
are shown in bold text.

 Display Name: Contains the name that will be used within the interface and report output to identify
each property. You can change this name by clicking inside the cell and editing the text.

 Tooltip: Contains the tooltip that will be displayed when you point to each property’s header in the
worksheet (if applicable). You can change this by clicking inside the cell and adding or editing the
text.

 Take some time now to review the fields that are available for each type of record. Determine whether
each field will be displayed and, if so, what it will be called in the interface and reports for projects that
use this interface style.
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 For example, if you want to display the “Model Year(s)/Program(s)” field for item records but you want
to call the field “Model Year,” set the Enabled column to Yes for that property and delete “(s)/
Program(s)” from the text in the Display Name column, as shown next.

 If you want to change the options available for selection in the FMEA Type field, click the Edit icon in
the Type column for that property. 

The Modify Drop-downs window will appear, as shown next.
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You can edit the existing text or type new text in the blank row at the bottom. Populating this row will
cause another blank row to be added. Click Delete Row to delete the currently selected row. Click Insert
Row to add a blank row above the currently selected row. Use the Move Up and Move Down buttons to
arrange the options in the desired order. When you have finished making changes, click OK to return to

the Add Interface Style window.10

As you review the properties available for each record type in the FMEA, you will notice that certain pages
have additional options. For example, the Controls page is shown next.

The Enable Controls for Causes option, located above the table, allows you to define controls in projects
that use this interface style. If this option is not selected, any selections that have been made in the table
below will be ignored by Xfmea because the Controls functionality will not be available in the project. 

The Number of Controls Columns in Worksheet View area allows you to specify whether control
descriptions will be displayed in one or two columns in the worksheet view and the FMEA Spreadsheet
reports. If you select One Column, then all control descriptions will be displayed in the same column with a
second column used to set/display the control type. If you select Two Columns, then the control
descriptions will be displayed in two columns, with the placement determined by the control type that has
been assigned to each record. If the control type assigned to the record matches the text specified in this area,
then the description will appear in the Prevention column. Otherwise, the description will appear in the
Detection column. A description is considered to be a match if the specified text (i.e. “Prev” by default)
appears anywhere within the control type (e.g. “prevention,” “preventive,” “preventative,” etc.).

10.You also can edit drop-downs for all of the drop-down fields enabled in the interface style by clicking the Customize
Drop-Downs button at the bottom of the Add Interface Style window. The Modify Drop-Downs window will have a
navigation panel on the left side that allows you to choose the drop-down field to edit. Edit as many of the drop-downs as
necessary before clicking OK to return to the Add Interface Style window.

NOTE: Clearing the Enable Actions for Causes option on the Actions page will have a similar effect for
actions.
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The final page in the FMEA section, Worksheet Columns, allows you to specify the order in which the
columns will appear in the worksheet view.

The columns listed on this page correspond to the fields that are enabled for the FMEA in the interface style.
To move an item up or down in the list (i.e. to the left or to the right, respectively, in the worksheet), select
the item and either drag it to the desired location or use the up and down arrows at the right.

4.10.2.4  Risk Assessment

The Risk Assessment pages allow you to determine how the Risk Priority Numbers (RPNs) or Criticality
Analysis will be used for the projects that use the current interface style.

 For instance, on the RPN page, in the Highlight Priority Based on area, choose the criterion that you
want to use to determine high, medium and low priority causes. If you choose to base priorities on RPN
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or on any one of the scales (severity, occurrence or detection), you can specify the priority thresholds. If
you choose Risk Ranking, you can click the Risk Ranking Logic button to create your own logic for
determining the priority of causes using the criteria fields provided. For instance, the Risk Ranking
window shown next specifies that a cause with an RPN of 200 or higher and associated with an effect
with a severity of 7 or higher will be ranked as high priority.

 When you return to the RPN page, you also can specify the colors used to indicate high, medium and low
priority.

 Finish making the required selections to meet your particular needs and click OK to create the new
interface style.

4.10.3  Create Custom Severity, Occurrence and Detection Scales

A rating scale is a predefined range of ratings and criteria (often from 1 to 5 or from 1 to 10) that can be used
to rate the severity, probability of occurrence and likelihood of detection for the issues that you identify
through your analysis. These rating scales are used to calculate Risk Priority Numbers (RPNs) and for
qualitative criticality analyses.

 To create your own custom severity scale, which can be applied to the projects that you create in Xfmea,
select the Severity page in the Profiles/Libraries Manager. This page displays a list of existing severity
scales.

 Click Add to open the Add Severity Scale window.

Like the Add Interface Style window described in Section 4.10.2, this window requires a unique name for
the scale and provides the ability to apply the properties of an existing scale into the new scale. In addition,
you can use a table with four columns to add, edit and delete values within the scale.

 Value: The numerical rating that will be applied to the record. Note that each value must be unique
within the scale and the values can be whole numbers or decimals. Xfmea will order the numbers
automatically from smallest to greatest when you save the scale.

 Description: The short text description that will be associated with the numerical rating in the drop-
down lists within the interface.

 Criteria 1 and 2: Longer text descriptions of the specific criteria used within the organization to
determine whether the rating will be assigned to the issue. These will be displayed in the Select
Existing window that can be accessed from within the interface.
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The window shown next provides an example of what your screen might look like as you add entries to the
new custom severity scale. The appearance will vary, of course, based on the information that is appropriate
to your particular needs.

 When you have fully defined the scale, click OK to save the changes and add the new custom scale to
the list of available severity scales.

 Next, follow a similar procedure to create your own custom occurrence and detection scales.

4.10.4  Create a Custom Profile

As the previous examples in this Training Guide have demonstrated, profiles provide a quick and easy way
for you to assign the interface style, rating scales and other configurable options for the projects that you
create and manage with Xfmea.

 To create your own custom profile, begin by clicking Profiles in the navigation panel of the Profiles/
Libraries Manager. This page displays a list of existing profiles.

 Click Add to open the Add Profile window.

 Type a unique name for Name and, if desired, type a more detailed text description for Description.

 On the General tab, select the custom interface style that you created in Section 4.10.2 from the
Interface Style drop-down list. You also will notice that you can use the Add and Edit icons in this field
to add or edit interface styles directly from here. 
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 Next, select the custom severity, occurrence and detection scales that you created in Section 4.10.3 from
the Severity Class, Failure Probability, Severity Scale, Occurrence Scale and Detection Scale lists.

 Click the Risk Discovery tab to view and/or change the questions and ratings that are used in Risk
Discovery analysis in projects using this profile. 
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 When you have made all selections, click OK to create the new profile. When you apply this profile to a
new or existing project, the interface style, rating scales and risk discovery questions and/or ratings used
within the project will be updated automatically to fit the custom preferences that you have predefined.

4.10.5  Modify Project Properties Directly Within the Project

Although the previous examples in this Training Guide have always set the project properties automatically
with a predefined profile, you also can modify the project properties directly within a project. These changes
apply to the project only and have no direct effect on the profile and libraries that were used to set the
project properties originally.

 Choose Project > Import Projects and import the Sample Project project from the TrainingData.rx5
database in the Training folder in your application directory (e.g. C:\Program
Files\ReliaSoft\Xfmea5\Training). 

 In the Project Explorer, click the Sample Project project and then choose Project > Project Properties.

As you can see, the properties for this project originally were set based on the Standard FMEA profile that is
shipped with Xfmea. For this example, suppose that all of the properties from the Standard FMEA profile
are appropriate for the project except that you would like to choose a different Occurrence scale and make a
few adjustments to the interface style.

 To change the Occurrence scale assigned to this project, click the Configurable Settings tab. On the
Configurable Settings page, choose the DFMEA: J1739 (2008) scale in the Occurrence Scale drop-
down list, as shown next.

 Next, click the Edit button in the Interface Style field to open the Edit Project Interface Style window. 

For this example, suppose that the interface style defined for this project is acceptable except for the
following:

 Users will not be able to enter Design Engineer or Drawing Number for item records.

 The Responsibility field for the FMEA header will be called “Design/Process Responsibility.”
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 Users will be able to enter three levels of effect descriptions, called End Effect, Next Level Effect and
Local Effect.

To make these changes, do the following:

 Go to the Item page of the window by clicking Properties under the Item heading in the navigation
panel. Click inside the Enabled column in the row for the Design Engineer property and set the value to
No. Then disable the Drawing Number property as well, as shown next.

 Next, click Header under the FMEA heading in the navigation panel. Click inside the Display Name
column for the Responsibility property. Edit the text to set the label as Design/Process Responsibility,
as shown next.
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 Finally, click Effects under the FMEA heading in the navigation panel and then enable the Next Level
Effect Description and Local Effect Description properties, as shown next.

 Click OK to accept your changes.

4.10.6  Create a Profile in the Library Based on Project Properties

 The changes that you have made to the interface style are applied to the current project when you click
OK. In addition, if you want to save the modified interface style to a new profile in your library so that it
will be available to apply to the projects that you create and modify in the future, click the Send Settings
to Library button in the lower left corner of the Project Properties window. The Select Profile Name and
Description window will appear.

 Type a name (required) and description (optional) for the new profile that will be added to the library, as
shown next.

 Click OK to add the modified interface style to the library for future re-use. You will see a notification
that the settings have successfully been added to the library. Click OK to continue.

 Now, click OK to apply the modified interface style to the current project and close the Project
Properties window.

 Close the project and the database before proceeding with the next example.
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4.11  Example 10 - Performing Your Own FMEA

This example guides you through the steps to perform an FMEA or FMECA analysis for one of your own
products or processes. It has been designed to bring together all of the techniques that you have practiced by
working through the examples in this Training Guide. The example will help you to focus your new skills
toward performing a real analysis that will be of interest to you and your organization.

All instructions for this example are very general and the appearance of the windows will vary depending on
your particular processes and information.

4.11.1  Overview of Basic Analysis Steps

The basic steps required to perform your own analysis are presented next. Specific instructions for
performing each of these actions have been included within the previous examples of this Training Guide
and/or in the Xfmea User’s Guide. 

For this example, you will perform those steps that are applicable to your particular analysis requirements.

 Database: Create a Standard database. See Section 4.2.1 on page 31.

 Project: Create a project with the appropriate properties to fit the requirements of your analysis. See
Section 4.2.2 on page 32. If applicable, use the custom profile that you created in Example 9 to quickly
set the project properties. See Section 4.10.4 on page 102.

 Items: Create one or more items in the system hierarchy for the project. See Section 4.2.3 on page 33.

 Item Reliability: If applicable, define the reliability characteristics for the item(s) in your analysis. This
information will be included in item properties reports and used in quantitative criticality analyses, if
performed. See Section 4.4.3 on page 58.

 FMEA: Add an FMEA for the item(s) of interest in your analysis and define the FMEA header
information. See Section 4.2.4 on page 34.

 Functions, Failures, Effects, Causes and Controls: For each item that you want to analyze, define
functions, failures, effects and causes, including all relevant properties. See Section 4.2.5 on page 34. If
applicable, define the current controls that have been identified for each cause in the analysis. See
Section 4.2.8.1 on page 41.

 FMEA/FMECA Risk Assessment: If applicable, use the Risk Priority Number or Criticality Analysis
method to assess the risk associated with potential failure causes and to prioritize issues for corrective
action. See Section 4.2.8.2 on page 42.

 Actions: If applicable, define the recommended actions that have been identified for each cause in the
analysis. See Section 4.2.8.3 on page 44.

 Monitor the progress on recommended actions.

 Check Analysis: Use the Check Analysis utility to identify any possible discrepancies and/or omissions
within the project. Address the appropriate issues and use the Check Analysis utility to confirm that the
issues have been resolved. See Section 3.4.5 on page 19.

 Graphical Plots and Charts: Use the Plot Viewer utility to create a variety of pareto (bar) charts, pie
charts and matrix charts based on the information within the project. See Section 3.4.8 on page 25.

 If desired, copy/paste the chart information into separate report documents and/or save the chart
graphics as Windows metafiles (*.wmf) that can be used in other applications.

 Reports: Generate a variety of reports for the information contained within the project in Microsoft
Word and/or Excel. See Section 4.2.10 on page 48.
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 Control Plans, DVP&Rs and Other Related Analyses: If desired, perform related analyses including
transferring Design FMEAs to Process FMEAs, Process Flow Diagrams, Control Plans, DVP&Rs,
DRBFMs, Relationship Diagrams, etc. See Section 4.7.5 on page 79.
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